This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.04 hours from now. Thank you for your understanding.

This topic contains 12 risposte, has 2 voci.

Last updated by enricoD-16 3 mesi, 1 settimana fa.

Assigned support staff: Alejandro.

Autore Post
July 9, 2019 at 8:27 am #4168539

enricoD-16

Sto tentando di: Quando eseguo l'update del plugin alla versione 4.2.7.1, gli adds on String Translation & Translation Management smettono di funzionare e vengono disattivati. Le traduzioni del subfooter e del banner cookie vengono disattivate.
Dopodiché, mi viene chiesto di acquistare un piano a pagamento, cosa che ho naturalmente già fatto.

Come possiamo risolvere questo problema?

July 9, 2019 at 1:25 pm #4171229

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Allora, come prima cosa vedo che il
SiteURL=hidden link
e invece il HomeURL= hidden link

Ti consiglio di cambiare la homeURL e aggiungere invece lo stesso URL della SiteURL, così non riscontrerai più l'avviso dell'acquisto della nuova licenza.

Immagino che String Translation e Translation management non siano aggiornati all'ultima versione, questo spiegherebbe perché quando aggiorni il Core di WPML ti si disattivano gli altri plugin.

Prova ad aggiornare anche questi 2 plugin e fammi sapere come va.

July 9, 2019 at 2:31 pm #4171871

enricoD-16

Ciao e grazie,

dove posso cambiare la Home URL?
String Translation e Translation management sembrano aggiornati, eventualmente come posso verificare se sono l'ultima versione o no, ed a aggiornarli?

July 9, 2019 at 2:53 pm #4172023

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Per cambiarla puoi andare su Impostazioni > Generali

Lì vedrai 2 campi, uno di loro è la HomeURL.

L'ultima versione di Translation Management è: 2.8.6.2
e invece quella di String Translation è: 2.10.5.1

Saluti.

July 10, 2019 at 7:18 am #4176525

enricoD-16

Non riesco a trovare dove cambiare

"SiteURL=hidden link
e invece il HomeURL= hidden link"

allego screenshot ("settings").
Nell'altro screenshot, l'errore che appare nella dashboard. Al momento le traduzioni del subfooter e del cookie banner sono state disattivate, quindi ho urgenza di risolvere questo problema al più presto.
Grazie

July 10, 2019 at 11:13 am #4179227

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Interessante, mi sa che il problema si vede soltanto dal database (oppure è stato cambiato recentemente, anche se non penso sia il caso). Le informazioni di debug prendono tutti i dati dal database stesso ed è li' che vedevo questa problematica.

Accedendo sul database troverai una tabella wp_options (dove "wp" è il prefisso scelto da te durante l'installazione di WordPress), tra le prime opzioni ci saranno quelle per il site e Home URL, puoi cambiarle manualmente.

Se non sai dove trovarle o non vuoi farlo tu, basta che mi dai accesso al tuo sito e permesso di accedere al tuo database (lo farò dal tuo sito stesso tramite lo script "Adminer") ma prima di tutto ciò ho bisogno tu mi confermi di avere al meno un backup per il database.

Ho attivato dei campi che servono per inserire le credenziali. ti chiedo gentilmente di inserirle lì per mantenerle sicure e private.

Saluti.

July 10, 2019 at 4:31 pm #4182649

enricoD-16

come scritto nell'altro mio ticket, ecco cosa dice il mio developer:

The issue is a lot more than a simple URL. it's related to this:

/home/jobbami4/public_html/wp-content/plugins/sitepress-multilingual-cms/menu/post-menus/post-edit-screen/wpml-meta-boxes-post-edit-html.class.php

I reverted back on all optimization changes I made. However, errors still persist. I have a very strong feeling that all of these issues are a result of the WMPL plugin. The exception is the missing referral. I believe this was my fault and I will work to fix this now.

There is nothing I can do until WPML fix the issues. When that is done I can reapply the optimization changes.

Luckily, there is a really simple way to find out. SiteGround take a backup of your website every day. You have 30 days of backups. A few days ago, I used this feature to revert your website back to the day before I began working on your website. I then updated the WPML plugin.

I noticed that this update had major conflicts with your website. This is why I warned you about it.

Il sito è inutilizzabile, per favore date massima urgenza al ticket.
grazie

July 11, 2019 at 9:24 am #4187901

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Allora,

Penso che i lavori del tuo sviluppatori e le cose che io farò non si scontreranno ma anche se fosse, io appena faccio una modifica la comunico qui proprio per essere sicuro che tutti sappiano cosa ho fatto (questo per te e anche per i futuri lettori di questo ticket).

Per ora ho semplicemente fatto quello che avevo suggerito in altri ticket e ho aggiornato String Translation e Translation manangement.

Potresti controllare la situazione adesso?

Ho provato ad attivarli e si attivano correttamente (prima non si attivavano perché non erano aggiornati, mentre il plugin core lo era).

In più l'errore che diceva che non potevano essere aggiornati è sparito andando su questa pagina: hidden link
e poi premendo "Check for updates" (facendo così, abbiamo aggiornato tutte le informazioni della licenza e delle versioni dei plugin).

Non saprei dove verificare le informazioni del messaggio cookie e del subfooter, quindi ti chiedo gentilmente di controllare quello e di vedere se al momento compaiono correttamente tradotti.

Se non sono tradotti, prova a tradurli, perché se li hai tradotti mentre i plugin non erano aggiornati, probabilmente avrai perso le modifiche.

Fammi sapere come va.

July 11, 2019 at 10:33 am #4188725

enricoD-16

Ciao Alejandro,

sto testando il sito e vedo che il subfooter + il cookie banner funziona, e i commenti anche.
Ce l'abbiamo fatta 🙂

un'ultima cosa. Come posso, in futuro, evitare questa situazione? Se devo aggiornare plugin e add ons insieme, come devo fare?
grazie!

July 11, 2019 at 10:49 am #4188833

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Non è che si devono aggiornare tutti insieme allo stesso tempo. basta che li aggiorni tutti lo stesso giorno per dire.

Per qualche ragione (e penso che sia anche per colpa del cache o del OPcache che ha wp-rocket/il tuo server) molte volte su plugins > Tutti i plugin vedrai solo 1 aggiornamento, ad esempio.

Quasi sempre quando WPML ha un aggiornamento disponibile, anche i suoi add-on ce li hanno, quindi per essere sicuro puoi andare su plugin > Aggiungi nuovo > Commerciale

Così vedrai l'elenco dei plugin e gli aggiornamenti disponibili (e potrai aggiornarli anche da lì se ti viene comodo).

Altrimenti puoi sempre disabilitare e abilitare i plugin sulla pagina di plugin (questo applica non solo per WPML ma per tutti i plugin) perché quasi sempre quando disabiliti/abiliti un plugin si fa una richiesta per vedere se ci sono aggiornamenti disponibili.

Saluti.

July 12, 2019 at 12:21 pm #4198483
enricoD-16

ciao,

ho un ultimo problema di layout che prima dell'update di WPML non era presente, e non è stato risolto dopo l'update di ieri.
Non è causato dal lavoro del ns developer, copio e incollo le sue parole:

"I don't add or remove code. I just change the way the code is loaded (async/defer), I implement caching, minification, compression and a few other items. I have turned all of this off and no speed optimization is currently present on your website. However, the white space persists. Does WPML allow for CSS in the page editor? This might be a good place to look".

I problemi sono diversi, come da screenshot allegati.
- differenze tra versione ENG e ITA del sito, in tutte le pagine relative alle città (sotto-pagine delle Location) e in tutte le pagine appartenenti a "Ruoli", i layout sono diversi. Come puoi vedere anche navigando sul sito, nella versione italiana manca la sidebar (dovrebbe esserci), c'è il title page (non dovrebbe esserci), e c'è un orribile spazio bianco sotto il titolo. La versione ENG presenta uno spazio bianco più piccolo che non dovrebbe esserci - e prima non c'era, ma per il resto è corretta.

- Spazi bianchi un po' ovunque nel sito, sotto gli header e in altre parti anche nella HOME sia in inglese che in italiano (vedere screenshot home e home2).

Importante: il nostro developer sta effettuando ottimizzazioni e dovrebbe aver finito in giornata. Vi prego di non effettuare alcuna modifica finché non vi dirò di farlo, più tardi, per non sovrapporvi al suo lavoro.

Attendo una soluzione.
grazie

Enrico

I nuovi thread creati da Alejandro e collegati a questo sono elencati di seguito:

https://wpml.org/it/forums/topic/split-problemi-update-del-plugin-e-add-on-string-translation-management/

July 12, 2019 at 1:16 pm #4199269

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao, ho separato questo ticket perché il problema che hai appena menzionato è un po' diverso dal tema principale di questo ticket.

L'ho già risposto quindi puoi darmi una risposta per conoscere come procedere.

Nel frattempo, però, ti chiedo gentilmente di chiudere questi ticket se pensi che il problema principale di questo ticket è risolto.

Saluti.

July 12, 2019 at 1:30 pm #4199345

enricoD-16

My issue is resolved now. Thank you!