This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.63 hours from now. Thank you for your understanding.

This topic contains 19 risposte, has 2 voci.

Last updated by Laura 3 settimane, 2 giorni fa.

Assigned support staff: Laura.

Autore Post
September 9, 2019 at 9:55 am

alessioM-18

Ho i seguenti prodotti e categorie:
hidden link

nelle altre lingue non vengono visualizzati:
hidden link

hidden link

fino a ieri venivano visualizzati correttamente mentre da oggi no.

Aspetto vostre direttive grazie

September 9, 2019 at 2:53 pm #4538159

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

Cosa è successo ieri che potrebbe aver scatenato il problema?

Puoi aggiornare WordPress, WPML e gli addon e verificare se il problema si presenta ancora?

Inoltre ti suggerirei di aumentare il WP Memory Limit. Per farlo, aggiungi questo snippet all'inizio del file wp-config.php, dopo il tag di apertura <?

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

Il file wp-config si trova nella root del sito, è lo stesso file che contiene la configurazione del database. Per modificarlo ti servirà un accesso FTP o SFTP. Per controllare il valore registrato del WP Memory Limit puoi andare in WPML -> Assistenza
Ulteriori informazioni:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

September 9, 2019 at 3:10 pm #4538303

alessioM-18

Grazie Laura per la risposta,
Ho aggiornato WPML e gli addon ma il problema persiste.

Il tutto è successo quando ho creato manualmente dei prodotti in inglese. Ora sono tutti sincronizzati ma non funziona.

Ho aumentato la "Memory Limit" a 256M ma ancora niente.

Se nota in questa pagina categoria --> hidden link

c'è scritto "Visualizzazione di tutti i 12 risultati" ma non vengono visualizzati.

September 10, 2019 at 7:16 am #4542375

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

e questi nuovi prodotti creati sono solo in inglese?

Puoi provare ad aggiornare le categorie e i prodotti (solitamente basta uno soltanto per farli riapparire tutti)?

Se questo non funziona, ti chiederei le credenziali del sito per un'occhiata più approfondita.

September 10, 2019 at 11:47 am
September 10, 2019 at 3:45 pm #4546997

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

ho fatto alcune prove ma senza risultato. In passato alcuni ticket simili sono stati risolti ripristinando i permalink originali per lo shop e poi traducendoli nuovamente, ma non è un'operazione che posso fare senza autorizzazione.

Puoi fare un test, se neppure questo funziona proverò a prendere una copia del sito e a fare ulteriori prove.

September 10, 2019 at 3:47 pm #4547007

alessioM-18

Ok provo e Vi faccio sapere.
grazie

September 12, 2019 at 8:01 am #4559139

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Prego, aggiornami quando puoi.

September 12, 2019 at 2:41 pm #4561921

alessioM-18

Salve Laura,
effettivamente il problema sembra proprio provenire dai permalink.

Ho provato a ripristinarli ma purtroppo quando aggiorno la pagina non mi salva il cambio dei permalink originali ma restano su quelli personalizzati.

September 13, 2019 at 7:28 am #4566017

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

se non salva i permalink originali ci deve essere qualche altro problema.

Prova a disabilitare tutti i plugin tranne WPML e WooCommerce e vedi così si salvano - potrebbe esserci uno degli altri plugin che in qualche modo blocca tutto (per esempio WordFence).

Se invece anche con i plugin disabilitati non riesci, ti chiederei di abilitare la console del browser (vedi qui hidden link) e verificare se al momento di salvare ci sono errori.

Se neppure così riscontri nulla, provo a prendere una copia del sito per effettuare ulteriori prove.

September 16, 2019 at 6:12 am #4576475

alessioM-18

Ciao Laura,

ho provato a fare quanto da te suggerito ma purtroppo non si è risolto nulla.

September 16, 2019 at 7:55 am #4577049

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

non si è risolto nel senso che non riesci a salvare i permalink o anche ripristinando quelli di default non si risolve il problema?

September 16, 2019 at 8:38 am #4577469

alessioM-18

Ho disattivato tutti i plugin e ho provato a ripristinare i permalink ma niente da fare.

September 16, 2019 at 12:57 pm
September 19, 2019 at 10:05 am #4603365

alessioM-18

Buongiorno Laura,

non riesci a fare il tutto tramite FTP?

The topic ‘[Closed] Prodotti WooCommerce non visibili’ is closed to new replies.