This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 risposte, has 2 voci.

Last updated by andrea-giovanniF 1 anno, 9 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
November 22, 2017 at 3:00 pm #1438301

andrea-giovanniF

Ciao Vincenzo.

Ti scrivo in quanto, come già anticipato in altri post, abbiamo effettuato il trasferimento del sito da hosting di sviluppo (Keliweb) a hosting di produzione (Siteground).

Notiamo un'abissale differenza sulle performance all'accesso del backend.

Abissale vuol dire che rispetto a Keliweb, Siteground ha dei tempi di attesa anche di 10 secondi, con schermata bianca.

Ci hanno indicato che potrebbero essere alcuni plugin, (ci indicano anche WPML) che pertanto solo gli stessi presenti sul server di sviluppo.

Mi puoi aiutare a capire come migliorare le cose?

Grazie.

Andrea

November 22, 2017 at 3:36 pm #1438345

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Andrea,

sembra che qualcosa posso essere andata male nel trasferimento.

Puoi dirmi come è stato effettuato?
- Io uso spesso il plugin Duplicator per questo scopo.

Per capire quale possa essere la causa del rallentamento e delle pagine bianche potrebbe essere utile attivare la modalità di debug di WordPress.

Per attivare la modalità di debug di WordPress bisogna:

- aprire il file wp-config.php e cercare la riga:

define('WP_DEBUG', false);

Cambiarla in:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', false);

In questo modo gli errori verranno salvati nel file debug.log all'interno della cartella /wp-content/

Una volta attivata la modalità di debug si deve provocare nuovamente l'errore navigando nel backend in maniera da registrare il problema nel file di log.

A questo punto puoi postare il contenuto del file wp-content/debug.log qui sul forum o, se è troppo grande, su pastebin.com e postare qui il link al paste.

Ti attivo una risposta privata per postare il debug in maniera sicura.

Documentazione relativa:
- https://wpml.org/it/documentazione/informazioni-per-gli-sviluppatori/eseguire-il-debug-di-wpml/
- https://wpml.org/documentation/support/debugging-wpml/
- http://codex.wordpress.org/Debugging_in_WordPress
- https://wpml.org/faq/500-error/

November 23, 2017 at 8:36 am #1438929

andrea-giovanniF

Buongiorno Vincenzo.

Ho dei problemi ad inviarti messaggio. Non riesce a caricare file zip del db...arriva al 99% e mi da errore http.

Ho già caricato tutto su Dropbox log e dump del db.

Puoi inviarmi risposta senza blocco obbligatorio per dump db?

A presto.

Grazie

Andrea

November 23, 2017 at 11:05 am #1439110

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno Andrea,

ho attivato un'altra risposta privata.

Ti basta postare il link al file nella risposta.

Grazie

November 23, 2017 at 11:13 am #1439154

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

questo avviso: "La query non contiene il numero corretto di segnaposti (2) per il numero di argomenti forniti" è stato aggiunto nelle ultime versioni di WordPress per risolvere un problema di sicurezza.
Questa modifica ha coinvolto molti plugin fra cui anche WPML.
Il problema è stato subito risolto con gli ultimi aggiornamenti di WPML.

Puoi provare se, aggiornando WPML e i suoi add-on plugin, l'avviso scompare?

Gli stessi avvisi potrebbero anche essere causati da altri plugin non aggiornati.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

November 24, 2017 at 9:50 am #1440210

andrea-giovanniF

Ciao Vincenzo.

Aggiornati tutti i plugin WPML. Tutti gli errori sono scomparsi.

Rimane il problema della lentezza allucinante dell'accesso al backend.

Il supporto di siteground ci informa che lato server hanno ottimizzato tutto e anche un upgrade del piano non porterebbe a miglioramenti.

Ripeto su Keliweb, l'accesso è veloce e fluido, su Siteground no e non ho idea di cosa fare.

Grazie.

Andrea

November 24, 2017 at 2:47 pm #1440587

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Andrea,

puoi dirmi se il problema è della stessa entità di prima, comprese le pagine bianche, oppure è migliorato un po'?

Questi sono alcuni passaggi utili:

❌ Assicurati d'avere un backup del sito prima di procedere! ❌

1. Un aggiornamento del software del server e del PHP porterebbe vantaggi in termini di velocità e stabilità.
- In particolare il PHP potrebbe essere aggiornato alla versione 7

2. Per capire la causa del rallentamento, prova questi passaggi:
- Disattiva tutti i plugin tranne WPML e i suoi addon plugin.

Se il rallentamento sparisce, comincia ad attivare i plugin uno alla volta e verifica le prestazioni.

- Fammi sapere i risultati di questo test

3. Verifica se ci sono nuovi errori nel file di log di WordPress.
- Se non ce ne sono più, puoi disattivare la modalità di debug di WordPress

4. Se stai usando un plugin di cache, prova a disabilitarlo temporaneamente.

5. Apri una console del browser (tasto F12) per vedere se ci sono errori.

Grazie

November 27, 2017 at 1:39 pm #1442390

andrea-giovanniF

Ciao Vincenzo.

Abbiamo provato a seguire quanto da te indicato. Il tempo di attesa per accesso al back end è sempre lo stesso.

Fammi sapere se hai altre idee...

A presto.

Andrea

November 27, 2017 at 6:20 pm #1442726

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Andrea,

puoi darmi maggiori dettagli sui risultati dei test punto per punto?

Mi aiuterebbe a capire in quale direzione proseguire con il debug del problema.

Grazie

November 28, 2017 at 2:57 pm #1443760

andrea-giovanniF

Ciao Vincenzo,

per quanto riguarda i vari punti ti rispondo sotto ad ognuno con le virgolette:

1. Un aggiornamento del software del server e del PHP porterebbe vantaggi in termini di velocità e stabilità.
- In particolare il PHP potrebbe essere aggiornato alla versione 7

""""Modificato da cpanel. Risultato: tempi di accesso identici"""

2. Per capire la causa del rallentamento, prova questi passaggi:
- Disattiva tutti i plugin tranne WPML e i suoi addon plugin.

""""Abbiamo diattivato tutti i plugin, accesso identico, attivazione di un plugin alla volta. Non è cambiato nulla.""""

Se il rallentamento sparisce, comincia ad attivare i plugin uno alla volta e verifica le prestazioni.

- Fammi sapere i risultati di questo test

3. Verifica se ci sono nuovi errori nel file di log di WordPress.
- Se non ce ne sono più, puoi disattivare la modalità di debug di WordPress

""" Non abbiamo più errori dopo l'aggiornamento dei plugins come da te indicato."""

4. Se stai usando un plugin di cache, prova a disabilitarlo temporaneamente.

""" Fatto. Nessuna variazione """

5. Apri una console del browser (tasto F12) per vedere se ci sono errori.

""" Fatto , nessun errore rilavato."""

Grazie e a presto

Andrea

November 28, 2017 at 6:06 pm #1444028

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Andrea,

è possibile che il rallentamento sia causato dal tema, da WPML o dalla loro interazione.

Verifica se il problema persiste in queste configurazioni:
- Con il tema attuale e WPML disattivato.
- Con un tema predefinito (per es. Twenty Sixteen) e WPML disattivato
- Con un tema predefinito (per es. Twenty Sixteen) e WPML Attivo

Puoi segnalarmi in quale delle tre configurazioni il problema è presente?

Prova ad effettuare questi test anche con browser diversi.

Grazie

December 6, 2017 at 8:10 am #1450463

andrea-giovanniF

Grazie problema risolto disattivando Cloudflare.

A presto