This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 risposte, has 2 voci.

Last updated by Alejandro 2 mesi, 3 settimane fa.

Assigned support staff: Alejandro.

Autore Post
July 23, 2019 at 5:22 pm

MartinaEngame

Sto tentando di: vedere le pagine in inglese

Link a una pagina dove è possibile vedere il problema: qualsiasi pagina

Mi aspettavo di vedere: il richiamo della pagina in inglese

Invece ho ottenuto:la home page inglese

July 24, 2019 at 7:54 am #4271183

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Ho controllato il tuo sito e le pagine con una traduzione mi rindirizzano correttamente a quelle in Inglese.

Mi potresti dare un esempio più specifico da poter provare?

Grazie in anticipo

July 24, 2019 at 8:20 am #4271475

MartinaEngame

Tutte le pagine. Ho fatto anche pulizia cache e usato chrome e firefox ma non mi funziona.
Ad esempio hidden link Clicco su ENG e mi manda hidden link

Cos' con tutte le pagine

July 24, 2019 at 11:16 am #4273903

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Vai su WPML > Lingue > Attiva l'opzione "Ajax Cookie" (Documentazione: https://wpml.org/documentation/getting-started-guide/language-setup/enabling-language-cookie-to-support-ajax-filtering/ )

Penso che sia questo il problema che riscontri (che finalmente sono riuscito a riprodurre. sono dovuto andare in diverse pagine e tradurre da una lingua all'altra per vedere il problema).

Fammi sapere come va.

July 24, 2019 at 11:23 am #4274037

MartinaEngame

Purtroppo no. Anche quelli del template lo vedono giusto ma sia io che il cliente invece nulla
Qui un video hidden link

July 24, 2019 at 2:45 pm #4275781

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Prova raggiungendo i requisiti minimi di WPML:

Per favore, aggiungi questo codice nel tuo file wp-config.php, subito dopo l'informazione del database

define('WP_MEMORY_LIMIT','128M');

Dopodiché vedi se per caso ora il problema è risolto perché al momento anche a me non da più problemi ma vedo che la memoria assegnata è di 40M mentre stai usando 33M quindi forse per quello in questo momento mi funzionava ma se poi questa memoria raggiunge 41M ad esempio, sicuramente alcune cose non funzioneranno bene e potranno creare questo problema (non succede sempre, ma a volte, il che rende tutto più difficile! ).

Fammi sapere come va.

July 24, 2019 at 2:52 pm #4275861

MartinaEngame

Era un problema d'incompatibilità col tema. Praticamente c'era un'opzione di default segnata che non può essere utilizzata con wpml.

Grazie mille per l'aiuto!

July 24, 2019 at 3:25 pm #4276091

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Bellissimo! grazie per l'aggiornamento.

Ti auguro un eccellente resto della settimana!