This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.21 hours from now. Thank you for your understanding.

This topic contains 20 risposte, has 2 voci.

Last updated by simoneM-27 11 mesi, 3 settimane fa.

Assigned support staff: Laura.

Autore Post
October 29, 2018 at 1:32 pm

simoneM-27

hidden link

Nella versione italiana del sito
se clicco sul primo tasto SCOPRI DI PIU'
vengo portato alla versione inglese della pagina successiva, anziché continuare la navigazione in italiano
(nell'editor di traduzione non mi fa mettere link diversi quindi posso metterne uno solo, ma non è possibile che la lingua cambi durante la navigazione)

solo un esempio, succede spesso sul sito

serve che guardiate subito nel dettaglio

October 29, 2018 at 4:45 pm #2858827

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

il pulsante che mi hai indicato punta su hidden link, quindi il link è corretto, non è che la lingua "cambia".

Puoi provare ad andare in WPML -> Impostazioni -> Traduci i link target e vedere se così risolvi, altrimenti dobbiamo capire come è creato il pulsante e modificare il link in altro modo.

Potresti inserire le informazioni di debug di WPML? Le puoi trovare in:
WPML -> Assistenza -> click sul link "informazioni di debug"
Copia tutto il testo nel box che abiliterò nella prossima risposta.
Altre informazioni qui: https://wpml.org/faq/provide-debug-information-faster-support/

October 29, 2018 at 5:19 pm #2858966

simoneM-27

Non ha funzionato
Serve uno sguardo più approfondito
Grazie

October 30, 2018 at 9:55 am #2861139

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

ho controllato sul tuo sito e fatto qualche prova sul nostro sito di compatibilità per Elementor.
Il link collegato al pulsante dovrebbe apparire nell'editor di traduzione, cosa che nel tuo caso non avviene.

Dalle informazioni di debug mi sembra che sia tutto a posto, quindi ti chiederei di effettuare questo test di compatibilità:
- fai un backup del sito
- disattiva tutti i plugin tranne WPML ed Elementor
- cambia il tema con uno di default come TwentySeventeen
- verifica se il problema è ancora presente
- se sì, riattiva i plugin uno alla volta, verificando ogni volta cosa succede
- per ultimo, riattiva il tema

Fammi sapere il risultato di questo test.

Se nel frattempo hai bisogno di un workaround rapido, utilizzando le traduzioni manuali (ossia cambiando lingua dalla barra nera in alto) e modificando la pagina con l'editor di Elementor dovresti essere in grado di modificare il link.

October 30, 2018 at 11:46 am #2861497

simoneM-27

Ho già un tema di default (Twenty Sixteen) e quasi nessun plugin abilitato.

October 30, 2018 at 3:00 pm #2862354

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

allora in questo caso creerei un sito Sandbox dove dovresti riprodurre l'errore, impostando quindi WPML ed Elementor come sono sul tuo sito e creando una pagina uguale a quella dove si presenta l'errore. Se anche così il link non è visibile possiamo pensare a qualche bug non ancora identificato, altrimenti dobbiamo ipotizzare un problema presente solo sul tuo sito.

Se per te va bene ti fornisco il link.

October 30, 2018 at 3:19 pm #2862456

simoneM-27

Link di cosa?
Non sono un tecnico
Serve il vostro supporto
Già avete accesso

October 30, 2018 at 3:29 pm #2862520

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Il link per la sandbox dove ricreare il problema come ho spiegato nel mio post precedente.

October 30, 2018 at 3:35 pm #2862533

simoneM-27

Non so cosa sia purtroppo, non sono un tecnico.

October 30, 2018 at 3:47 pm #2862576

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ti ho spiegato cos'è una sandbox e perché ho bisogno di fare questa prova qui: https://wpml.org/it/forums/topic/reindirizzamento-sbagliato/#post-2862354

Questo è il link per accedere al sito
hidden link

dovresti impostare WPML com'è nel tuo sito e installare il plugin Elementor. Dopodiché crea una pagina con un pulsante simile a quella in cui mi hai segnalato il problema e verifica se nell'editor di traduzione è presente il box per tradurre il link di destinazione oppure no.

October 30, 2018 at 4:15 pm #2862674

simoneM-27

Non trovo come esportare i settaggi di WMPL per caricarli nella sandbox

October 30, 2018 at 4:21 pm #2862710

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

non c'è un'opzione per esportare le impostazioni di WPML. Puoi lasciare le impostazioni predefinite configurando solo le stesse lingue che usi sul sito.

October 30, 2018 at 4:33 pm #2862795

simoneM-27

Qui sembra comparire
hidden link

Devi allora fare un'indagine approfondita sul mio sito

October 31, 2018 at 8:32 am #2864776

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

sono entrata sul sito e ho fatto qualche prova ma non riesco ad individuare il problema.

Avrei bisogno di una copia del sito. Noi suggeriamo il plugin Duplicator per crearla, poi dovresti caricarla su qualche sito come Dropbox e GoogleDrive e passarmi il link.

Abilito una risposta privata.

October 31, 2018 at 9:52 am #2865082

simoneM-27

Ho provato a creare il file ma non sono riuscito, mi dà dei warning.
Comunque ho abilitato Duplicator. potete provare direttamente.

Aggiungo un'informazione:
ho dovuto aggiungere alla stessa pagina un nuovo bottone, più in basso (il terzo).
E per quel tasto, è comparsa la traduzione anche per il link, correttamente.
Perché nei primi due no?
hidden link