This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 21 risposte, has 2 voci.

Last updated by Laura 1 mese, 1 settimana fa.

Assigned support staff: Laura.

Autore Post
April 30, 2020 at 3:16 pm #6031975

alessandroM-28

Buongiorno,

Ho tre siti duplicati tutti con attivo WPML.
Su due siti ho performance 75+ da Google Speed Insight, su uno dei siti ho le stesse performance se disattivo WPML ma se lo riattivo le mie performance crollano a 0.

May 1, 2020 at 7:51 am #6035679

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

Cosa significa performance 75+? E' possibile avere qualche dato numerico?

Quali sono le performance se lasci attivo solo WPML?
Considerando che ci sono oltre 30 plugin sul sito, alcuni dei quali molto pesanti, può darsi semplicemente che l'ulteriore aggiunta di un plugin abbia fatto collassare il tutto.

May 4, 2020 at 9:31 am #6051939

alessandroM-28

Salve,

Con 75+ intendo che a seconda della reattività del server ha un punteggio che si aggira intorno a quel numero o superiore.

Le allego due schermate di Google Speed Insight, una del .it e una del .co.uk. Il .co.uk è una copia del .it, è stata solo disabilitata la lingua italiana.

Ho inoltre fatto una prova di diagnositca con Health Check & Troubleshooting, disattivando tutti i plugin tranne WPML, il risultato non cambia.

Cambia invece se disattivo solo WPML, passando da un 10%, in modalità Desktop, ad un 80%, e da un 1% ad un 50% in mobile.

May 4, 2020 at 10:09 am #6052323

alessandroM-28

Siamo inoltre a coscenza del fatto che ci sono tanti plugin, alcuni dei quali anche pesanti, per questo motivo abbiamo installato un nostro applicativo che rende questi plugin attivi solo nelle pagine in cui sono necessari, nelle altre pagine vengono disabilitati.

May 5, 2020 at 7:39 am #6058237

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

avremmo bisogno di una copia del sito per fare dei controlli più approfonditi.

Abilito una risposta privata per la condivisione del pacchetto Duplicator.

Potresti inoltre spiegarmi meglio come funziona questo vostro applicativo? Può darsi che interferisca con le performance di WPML.

May 7, 2020 at 9:11 am #6077857

alessandroM-28

Sto avendo dei problemi a creare uno Zip con il plugin Duplicator. Il sito è più pesante di quanto riesce a comprimere il plugin, anche escludendo tutti i video e i file non necessari.

Può andare bene anche un backup completo del sito da Jet Backup?

May 7, 2020 at 9:18 am #6077931

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Per noi è più complicato installare un backup così.

Puoi provare ad escludere le cartelle upload e cache, oltre a tutti i file media e di archivio.

Se no se mi dai le credenziali faccio io una copia con Duplicator Pro.

May 7, 2020 at 11:20 am #6079149

alessandroM-28

Anche eliminando tutti gli uploads, archivi etc non riusciamo a stare sotto al limite di 500MB richiesto da duplicator, possiamo darvi accesso al sito se non si può fare altrimenti e poi ricaricare un backup successivamente.

May 7, 2020 at 3:08 pm #6081649

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Abilito una risposta privata

May 8, 2020 at 10:24 am #6087669

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

ho creato una copia del sito.

Puoi darmi qualche indicazione in più sull'applicativo che menzionavi qualche post più sopra?

May 8, 2020 at 10:55 am #6087949

alessandroM-28

Semplicemente per le pagine scritte (quindi da un URL) disattiva i plugin elencati, attraverso l'utilizzo di una cartella mu-plugins.

Ma è un applicativo installato su tutti i nostri siti e non ha mai dato problemi con WPML inoltre è presente anche negli altri "siti copia" dove il problema non si presenta.

May 8, 2020 at 10:58 am #6087981

alessandroM-28

Se cambiate i dati del database bisogna andare a questo path:
/public_html/wp-content/bTag/common_init.php

e cambiare i seguenti dati, oltre che dentro al wp-config.php

$dbname = "";
$user = "";
$pwd = '';
$host_test = "";
$dbname_test = "";
$user_test = "";
$pwd_test = '';

Se è possibile mettere questa come risposta nascosta sarebbe meglio

May 9, 2020 at 1:10 pm #6094599

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

E' possibile disabilitare in qualche modo queste impostazioni nella cartella bTag?

Anche utilizzando i dati del server di test non riesco ad accedere al sito.

May 11, 2020 at 9:16 am #6102043

alessandroM-28

Disabilitarla è difficile perché è un core del sito e senza quella molto probabilmente ritornano dei Fatal Error, ha inserito i dati corretti del database? Sia in wp-config sia in common_init?

Che errore incontrate durante l'impostazione, magari posso essere d'aiuto?

In dbname_test, dovrebbe esserci nome database + _test (non dovrebbe importare più di tanto se il database di test esiste effettivamente o no). L'utente invece è lo stesso del database normale.

Se può essere d'aiuto comunque abbiamo notato che se invece che hidden link facciamo un test su hidden link i risultati di google speed insight ritornano nella norma.

May 12, 2020 at 8:19 am #6109979

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

lo script cambia automaticamente i dati in wp-config una volta effettuata la migrazione (altrimenti il sito non sarebbe accessibile in nessun modo) perciò ho usato in common_init gli stessi parametri in wp-config.

Il sito mi dà errore ma non trovo nessun log, neppure tra quelli del server.

L'unica cosa che posso fare è provare a prendere un'ulteriore copia.
Questo script lo usate anche su altri siti? Perché se non lo usate, è molto probabile che i problemi di performance dipendano da questo.