This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.32 hours from now. Thank you for your understanding.

This topic contains 24 risposte, has 2 voci.

Last updated by francescoP-43 3 mesi, 2 settimane fa.

Assigned support staff: Andreas W..

Autore Post
June 19, 2019 at 9:19 am #4049969

francescoP-43

Hi,

I have seen that the English version page the room image is not displayed, only the translated text is seen but without the image. Maybe I need to enable something else?

Here is page link:
hidden link

June 19, 2019 at 9:29 am #4050053

francescoP-43

also the price is € 0.00 and this should not be the case.

June 19, 2019 at 4:26 pm #4053415

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

I can see the translation is working as expected for other product variations. Did you verify if the variation is correclty translated? How are you translating?

Are you using the WPML Translation Editor? Are the fields showing up here?
https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

To help you faster, I've enabled a private message for submitting the debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

Kind regards
Andreas

June 19, 2019 at 4:48 pm #4053463

francescoP-43

yes, I'm using the WPML translation editor and the fields are visible. I attach a screenshot.
Thanks for the attention.

June 19, 2019 at 5:58 pm #4053765

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Those fields on your screenshot only refer to the images. There must be another issue why they are not displaying oon front end.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons.

If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related. Honestly, I do not think that this is theme related, as the images are shown on other products but maybe you could try in case of any doubt.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1500. I would recommend you to change this setting to at least 3000.
You can find the php.ini file on your server inside the folder for your currently used PHP version 7.3.6 or you can make the chnage inside of the .htaccess file.

More information here:
hidden link

Kind regards
Andreas

June 19, 2019 at 7:33 pm #4054341

francescoP-43

I tried to perform a minimum configuration by deactivating plugins not strictly necessary but the problem persists.

Changing the theme doesn't seem like a good idea since the parts I can't translate are only present in the theme in use (the rooms are part of the theme I am using and there are not in another theme).

I also changed the value of maxInputVars to 3000 but it didn't solve the problem.

I also tried to translate the descriptions of the other rooms and I noticed something that could perhaps be useful to understand what's wrong: in the translations they are all displayed as single rooms, while they should be double rooms, single rooms, rooms triple and double bedroom.

I also set the debug to true and I also tried to set WP_DEBUG_DISPLAY to true by getting these 2 notices on the screen:

Notice: ob_end_flush (): failed to send buffer of zlib output compression (0) in /home/vjjrvekf/public_html/hotello/wp-includes/functions.php on line 4339

Notice: ob_end_flush (): failed to send buffer of zlib output compression (0) in /home/vjjrvekf/public_html/hotello/wp-content/plugins/really-simple-ssl/class-mixed-content-fixer.php online 111

June 19, 2019 at 10:31 pm #4055047

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

The error is refering to the Plugin Really Simple SSL. I do not think that it is linked to the theme issue. The issue persists if the plugin is disabled, correct?

Please go to WPML -> Taxonomy Translation. Choose the matching taxonomy form the dropdown and verify everthing is translated or if a hierarchy synchronization is available.

If this will not solve the issue I would prefer to take a look at the site.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

June 20, 2019 at 7:18 am #4057173

francescoP-43

Hello,
the site is currently located in a subdirectory called hotello (in the document root resides the old site that is currently active), when the site inside the hotello folder will be finished the old site will be removed.

Please check the site yourself. I made a backup of the files and the database.

**CREDENTIALS REMOVED**

June 20, 2019 at 7:32 am #4057253

francescoP-43

but wasn't this message to be private? I changed my passwords, please let me have a form to send you the data in private.

June 20, 2019 at 4:43 pm #4061725

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have removed the information and enabled the private box again.

Please provide access again.

Kind regards
Andreas

June 20, 2019 at 9:40 pm #4063157

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

When translating alsways make sure to mark the language options for media attachments in the right sidebar. They were not assigned for single beds. Further, the Multilngual Content Setup was not set to make the post type translatable and I have modified the translation options for the custom fields. See screenshots.

Anyhow, there seems to be an issue that also appears if all WPML plugins are disabled. If you go to hidden link you will see that the gallery images areavailable but the featured images are not showing up. I would adivse you to test this behavior with all plugins disabled and contact the theme support for further assistance.

Kind regards
Andreas

June 20, 2019 at 9:56 pm #4063215

francescoP-43

ok, but I see that in the English version page all single rooms appear, when instead they should be single, double, triple.

And even the prices are all zero in the English version.

I attach screenshot. This is a significant problem. Do I have to open a new topic for this or do we go on here?

June 20, 2019 at 10:23 pm #4063313

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I was able to adjust theprice in the Multilingual Content Setup but it seems there is an issue with WPBakery in reagrds to the Rooms Caroussel. I have attached a custom xml config in order to transalte the room IDs but the items are still not showing up correctly.

Did you test if it behaves the same when additonal plugins are disabled or the theme changes?

Please install the theme and any plugin necessary to recreate the issue on the follwing test site. Leave me short notifcations once everzthing is installed. I will then proceed further tests in order to escalate the issue to out compatiblity team.

One Click Login: hidden link

Kind regards
Andreas

June 20, 2019 at 10:44 pm #4063419

francescoP-43

Well, now i try to disable additional plugins and see what happens. Then if the situation does not change I will install the theme on the follwing test site.

June 20, 2019 at 11:10 pm #4063555

francescoP-43

Disabling additional plugins does not change the situation. I installed the theme on the test site.

I don't know what time they are on your side of the globe, but here it is night... : )
I think we will update tomorrow

Thanks for your help.