Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

This topic contains 24 risposte, has 2 voci.

Last updated by Laura 1 mese fa.

Assigned support staff: Laura.

Autore Post
May 16, 2022 at 3:46 pm #11231345

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi mandi le credenziali del sito?

May 18, 2022 at 2:41 pm #11248187

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Se da qui hidden link provo ad aprire Elementor ricevo l'errore "Il contenuto di quest'area non è stato trovato nella pagina" perciò sembrerebbe essere un errore con questo post specifico come pensavo.

Puoi provare ad attivare il debug log di WordPress.
Per farlo inserisci queste righe all'inizio del file wp-config.php dopo il tag di apertura:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

dopodiché riproduci l'errore e dovresti trovare un file debug.log nella cartella wp-content.

Copia le ultime righe qui. Se necessario, rimuovi le informazioni sensibili.

Altrimenti l'alternativa è provare a rifare il prodotto da zero.

May 18, 2022 at 3:06 pm #11248687

nadiaC-5

Ciao Laura, quel messaggio credo sia normale che venga fuori perché quando si usa il template builder di elementor non si può modificare partendo dal prodotto, ma solo dal template builder di elementor.

Lo spiegano qui hidden link
b. WooCommerce product pages must be edited with Elementor Pro’s WooCommerce Builder. If you edit it there and not into WooCommerce, you won’t receive the the_content error and you will be able to assign the template to your WooCommerce product pages.

In merito al fare il prodotto da zero lo avevamo già fatto ed ha funzionato fin quando non ho iniziato ad aggiungere il prezzo alle diverse varianti. In pratica il prodotto con il prezzo non lo fa vedere nel template prodotto singolo; mentre lo stesso prodotto che abbiamo ricreato da zero, senza i prezzi, si vede solo fin quando non aggiungo il prezzo delle varianti.

May 18, 2022 at 3:21 pm #11248883

nadiaC-5

[18-May-2022 15:17:51 UTC] PHP Notice: Undefined index: id in /home/customer/www/constanciabags.com/public_html/wp-content/plugins/woocommerce/src/Internal/Admin/Settings.php on line 162
[18-May-2022 15:17:51 UTC] PHP Notice: Undefined index: value in /home/customer/www/constanciabags.com/public_html/wp-content/plugins/woocommerce/src/Internal/Admin/Settings.php on line 162

Ho provato a togliere i prezzi dall'altro prodotto che non funzionava.. senza rifare il post da zero e se tolgo i prezzi alle varianti funziona! quindi non è un problema relativo al post.
Se inserisco i prezzi con WPML string questi due prodotti non funzionano. Se tolgo i prezzi e WPML string è attivo allora funziona.
Se disattivo WPML string e aggiungo i prezzi entrambi i prodotti sono funzionanti.

I prodotti sono questi:
hidden link
hidden link

May 19, 2022 at 12:11 pm #11256821

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Se disattivo la modalità multivaluta mi sembra che i prodotti si vedono, confermi?

Perché la utilizzi se non ci sono altre valute configurate?

May 20, 2022 at 9:38 am #11264227

nadiaC-5

Ciao Laura, si vedono se non inserisco i prezzi. Anche adesso con modalità multivaluta disattivata quando inserisco i prezzi per le varianti il prodotto continua a non vedersi.
Dei due prodotti con il problema ne ho lasciato uno con il prezzo ed uno senza prezzo. Puoi verificare ai soliti link
hidden link
hidden link

May 20, 2022 at 10:26 am #11264619

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

A questo punto devo chiedere un secondo parere perché non ho più idee, ti faccio sapere il prima possibile.

May 23, 2022 at 9:36 am #11278077

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Devo inviare il ticket al secondo livello.
Puoi fornirmi una copia del sito, preferibilmente con Duplicator? Puoi caricarlo su Dropbox, Google Drive o simili e condividere il link con me.

May 24, 2022 at 9:41 pm #11297267

nadiaC-5

Con duplicator mi da errore.. credo sia perché il pacchetto è troppo grande. come possiamo fare?

hidden link

May 25, 2022 at 9:01 am #11301485

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hai provato a filtrare tutti i media e i file di cache per ridurre la grandezza del pacchetto?

Altrimenti se risulta comunque troppo grosso posso fare un tentativo con Duplicator Pro, se mi autorizzi

The topic ‘[Closed] Salve, ho un problema con WPML string translation.’ is closed to new replies.