This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.40 hours from now. Thank you for your understanding.

This topic contains 6 risposte, has 2 voci.

Last updated by Pietro 4 anni, 6 mesi fa.

Assigned support staff: Selena.

Autore Post
December 16, 2014 at 8:01 pm #529754

Pietro

WPML (3.1.8.4) non funziona con NextGen (2.0.66.33), va in conflitto.

Potete aiutarmi con le informazioni di debug che vi ho mandato? o vi serve altro?

Grazie, Pietro Floris

December 17, 2014 at 11:00 am #530087

Selena
Supporter

Languages: Inglese (English )

Timezone: Europe/Rome (GMT+02:00)

Ciao Pietro,

Sono Selena e ti aiuterò a risolvere il tuo problema.

NextGen appare nella lista dei plugin compatibili con WPML:
http://wpml.org/documentation/plugins-compatibility/

Dalla lista dei plugin che hai installato non vedo NextGen, come mai?

Avrei bisogno di alcune ulteriori informazioni:
Postresti descrivermi il problema?
Potresti riportare le condizioni in cui si è verificato e il risultato ottenuto?

December 17, 2014 at 11:15 am #530100

Pietro

Ciao Selena, quando lo attivo da problemi WPML, o funziona l'uno o funziona l'altro.

Uno dei due lo devo lasciare disattivo ma a breve, l'altro lo dovrò sostituire se non riesco a risolvere il problema. Il mio cliente dovrà scegliere quale mantenere dei due plugin. Ho chiesto anche a NextGen ma finora da loro nessuna risposta, da voi si... grazie.

Qui vedi il prima: hidden link ...prima di attivare NextGen
Qui il dopo: hidden link che rende non più gestibile la bacheca...

Grazie dell'aiuto, Pietro.

December 17, 2014 at 3:10 pm #530322

Selena
Supporter

Languages: Inglese (English )

Timezone: Europe/Rome (GMT+02:00)

Ciao Pietro,

Il plugin NextGen e WPML sono compatibili 100%.
Per investigare al meglio sul problema devo chiederti l'accesso temporaneo al tuo sito (sia wp-admin che FTP). Se possibile, le credenziali devono essere di un sito web di test dove il problema è stato replicato.
Questo per poterti aiutare al meglio.
Immediatamente sotto la sezione dei commenti,troverai dei campi appositi. Le informazioni che introdurrai saranno private, il che significa che solamente io e te possiamo vederle e ne abbiamo accesso.

December 23, 2014 at 8:21 am #533056

Selena
Supporter

Languages: Inglese (English )

Timezone: Europe/Rome (GMT+02:00)

Ciao Pietro,

grazie per la tua risposta e per aver fornito le tue credenziali.

Ti informo che è stata rilasciata una versione successiva di NextGen, la 2.0.66.37, potresti aggiornarla e verificare se il problema persiste?

Se il problema persiste, potresti controllare e verificare le credenziali in quanto quelle che mi hai inviato, provando ad accedere, non risultano corrette.

December 24, 2014 at 11:14 am #533676

Selena
Supporter

Languages: Inglese (English )

Timezone: Europe/Rome (GMT+02:00)

Ciao Pietro,

Ho potuto esaminare il tuo backend e ho attivato la procedura di Debug di WordPress.

Potrai controllare eventuali e possibili errori/notice/alert di plugin e temi che andrai ad utilizzare.
Ti allego un link con le spiegazioni:
http://codex.wordpress.org/Debugging_in_WordPress

Inoltre, sarebbe preferibile ripulire il file .htaccess:
http://wpml.org/it/documentazione/guida-introduttiva/configurazione-della-lingua/impossibile-attivare-le-directory-delle-lingue/
nella sezione "Accertatevi che WordPress attivi la riscrittura degli URL".

Risultato:

Il limite di memoria che hai impostato per il sito web è di circa 41MB, un limite molto basso, per poter funzionare NextGen chiedeva un incremento della memoria.

Ho impostato tale valore nel file wp-config.php:
define('WP_MEMORY_LIMIT', '64M');

Ho disinstallato e reinstallato una copia pulita di NextGen

Ho disattivato il plugin Social Essentials, in quanto passa alla funzione has_cap() degli argomenti deprecati. Puoi verificane i "notice" nel file debug.log.

Ho disattivato il plugin "ilMeteo" in quanto utilizza delle funzioni deprecate di WordPress

Ti consiglio di installarne sempre dei plugin aggiornati e compatibili con la versione di WordPress da te in uso.

January 5, 2015 at 5:36 pm #537397

Pietro

Ciao Selena e grazie mille per il tuo intervento risolutivo.

E anche per il dettaglio e cortesia delle spiegazioni e consigli, sempre graditi.

Tutto chiaro, grazie e Buon lavoro e Anno, Pietro.

The topic ‘[Closed] Salve, ho un problema di compatibilità tra WPML e NextGen, potere aiutarmi?’ is closed to new replies.