This thread is resolved. Here is a description of the problem and solution.

Problema: Se attivo WPML non riesco ad accedere al backend di WordPress Soluzione: Per risolvere attiva il plugin SG Optimizer, cancella la cache e disattiva la Memcache. In alternativa puoi utilizzare PHP 5.6

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 10 risposte, has 2 voci.

Last updated by Vincenzo 2 anni fa.

Assigned support staff: Vincenzo.

Autore Post
February 26, 2018 at 11:34 am #1529052

giulianaT

Buongiorno,
ho un problema d'accesso al backend di WordPress quando il plugin "sitepress-multilingual-cms" è attivo. In front-end tutto OK.
La cosa strana è che il problema sembra nato... così dal nulla...

Il sito web ha in attivo due lingue: ITA ed ENG. Entrambe le versioni risultano perfettamente funzionanti nel loro contenuto. Il problema, come scritto sopra, appare dopo aver dato l'OK nella pagina di login, la quale restituisce il seguente errore: "Non hai il permesso di accedere a questa pagina.". Disattivando via FTP il plugin il tutto torna a funzionare correttamente.

Ho fatto svariate prove: disattivato altri plugin, disattivata la SuperCache di Siteground, disattavato il servizio di Cloudeflare... ma niente, il problema sembra essere causato unicamente dall'attivazione o meno del plugin di WPML.

Avete qualche suggerimento?

February 26, 2018 at 11:42 am #1529059

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!
Mi occuperò di questo ticket.

Si tratta di un problema insolito.
Puoi dirmi se nel sito è stato installato un plugin per la modifica dei permessi degli utenti?
- Può anche capitare che i permessi di WPML siano sovrascritti da qualche altro plugin.
Per risolvere si può utilizzare lo script seguente: (aggiungerlo alla fine del file functions.php del tema attivo).

function wpmlsupp_1706_reset_wpml_capabilities() {
    if ( function_exists( 'icl_enable_capabilities' ) ) {
        icl_enable_capabilities();
    }
}
add_action( 'shutdown', 'wpmlsupp_1706_reset_wpml_capabilities' );

Rimuovere lo script una volta risolto il problema.

2. Prova inoltre a incrementare il valore di WP Memory Limit a 256M

Per incrementare il valore di WP Memory Limit aggiungi o modifica questa riga nel mezzo del file wp-config.php (dopo il tag di apertura del php)
❌ IMPORTANTE ❌ Non inserire la riga alla fine del file ma sempre prima del commento riguardo la fine delle modifiche):

define( 'WP_MEMORY_LIMIT', '256M' );

Il file wp-config.php si trova nella cartella principale di WordPress.

Puoi verificare quale sia il valore attuale di WP Memory Limit da WPML -> Assistenza nella sezione Info

Maggiori informazioni qui:
- https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Grazie

February 26, 2018 at 1:46 pm #1529245

giulianaT

Buongiorno Vincenzo e grazie per la velocissima risposta.

No, non ho installato nessun plugin che gestisca i permessi agli utenti.
L'unica cosa che avevo fatto era l'implementazione del plugin "Simple Google ReCaptcha" che poi ho disattivato ed eliminato pensando fosse l'imputato al problema.

Ho effettuato le seguenti prove suggerite:
- aumento del limite della memoria
- inserito lo script nel file functions del tema

Inoltre ho:
- provato ad installare nuovamente WPML via FTP

Purtroppo però la situazione non è cambiata: riesco ad effettuare il login solo ed esclusivamente se disattivo via FTP "sitepress-multilingual-cms".
Effettivamente è un problema insolito anche per me, visto che ho installato WPML praticamente su tutti i siti web realizzati e non ho mai riscontrato questo errore.

Se necessiti di ulteriori dati fammi sapere.

Grazie
Marco D.

February 26, 2018 at 3:09 pm #1529361

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve Marco,

potrebbe trattarsi di un problema nella cache del browser.

1. Hai provato a cancellare la cache del browser, a utilizzare una sessione di navigazione privata o un browser diverso?

2. Se fosse possibile adesso vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.
Se non vedi il modulo sottostante, non postare le credenziali perché risulterebbe visibili nel forum pubblico:
- hidden link

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

- Un BACKUP dei file e del database è fortemente consigliato -

Grazie

February 26, 2018 at 3:59 pm #1529435

giulianaT

Ciao Vincenzo,

anch'io pensavo ad un problema di cache perché non c'era altra spiegazione plausibile... Ho provato ad eliminare cronologia e cache ed il problema si è comunque ripresentato.

La sorpresa però l'ho avuta ora con la navigazione in "incognito": SONO RIUSCITO AD ENTRARE.

La cosa che però non mi spiego è come mai venerdì scorso non ho mai avuto nessun problema ed oggi stranamente sì.
Terrò monitorato il tutto, nel caso di ulteriori problemi mi rifarò vivo 😉
Non so, che dici, teniamo aperto questo ticket o nel caso ne apriremo un altro?

Grazie mille per il supporto

Marco D.

February 26, 2018 at 4:10 pm #1529445

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Marco,

sono contento che la situazione sia migliorata.

Credo sia utile tenere d'occhio la situazione per qualche giorno prima di confermare che il problema è risolto.

Metto il ticket in attesa di una tua conferma.

Buon lavoro

February 28, 2018 at 6:07 pm #1532183

giulianaT

Ciao Vicenzo,
ho monitorato il comportamento in questa giornata e mezzo. Purtroppo il problema persiste ed inoltre ho notato alcuni "strani" funzionamenti nel salvataggio di preferenze WPML.

Per quanto riguarda il "login" ho constatato che se si aspetta un arco di tempo "importante", io l'ho notato dalla sera alla mattina, il login viene effettuato regolarmente. Se poi si esce e si cerca di rientrare ecco che si genera l'errore. L'unico modo per rientrare è disattivare il plugin di WPML via FTP oppure, come scritto sopra, aspettare...

Sugli "strani" funzionamenti invece ho visto che se si riesce ad entrare, effettuando poi alcune modifiche sul setting di WPML (Lingue), anche salvando, queste, non vengono registrate. DAVVERO STRANO.
Ed oggi, andando a personalizzare i Custom CSS per ottimizzare la versione del sito per mobile, ho visto che le modifiche vengono recepite in lingua italiana e non in quella inglese.
Tutto questo disattivando i vari software di cache in precedenza attivi (Supercacher e cloudflare di Siteground)

Ho creato un utente di supporto nel caso tu riesca a dare un'occhiata più da vicino. Nel caso fammi sapere come inviarti le credenziali.

Eventualmente potrei anche aprire un ticket in Assistenza sul server di hosting, ma per non accavallarci forse meglio, credo, fare "uno alla volta".

Grazie e buona serata
Marco D.

March 1, 2018 at 6:41 pm #1533597

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Marco,

dalla descrizione dei "sintomi" sembra si tratti proprio di un problema di cache.

1. Puoi assicurarti che ogni forma di cache sia disattivata dal pannello di controllo del server?

2. Puoi dirmi se il problema si presenta anche utilizzando la versione 5.6.x di PHP?
- Ho un ticket simile e potrebbe essere utile una tua conferma al riguardo.

3. Se fosse possibile adesso vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.
Se non vedi il modulo sottostante, non postare le credenziali perché risulterebbe visibili nel forum pubblico:
- hidden link

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

Grazie

March 2, 2018 at 10:49 am #1534177

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Marco,

ho provato ad accedere ed il problema si è manifestato subito.

Per risolverlo ho attivato il plugin SG Optimizer, ho pulito la cache ed ho disattivato la Memcache che risultava ancora attiva.

Il problema sembra risolto.

Puoi verificare?

Grazie

March 2, 2018 at 2:37 pm #1534445

giulianaT

Ciao Vincenzo...
hai fatto bingo!!! Ora è tutto funzionante.

Vedrò nei prossimi giorni ma credo che il problema fosse proprio quello.
Io avevo disabilitato il plug di Sitegroung "SG Optimizer" e dal cPanel avevo disattivato le due cache di primo e secondo livello, le uniche di cui si può gestire singolarmente (gestiamo più siti web) l'attivazione tramite pannello. Rimaneva appunto la MEM CACHE...

Grazie per la disponibilità.
Marco

March 20, 2018 at 6:12 pm #1551416

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Marco,

il plugin SG Optimizer è appena stato aggiornato. L'aggiornamento contiene la soluzione al problema esposto in questo ticket.
https://wordpress.org/plugins/sg-cachepress/

Buon lavoro