This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 9 risposte, has 2 voci.

Last updated by Vincenzo 7 mesi, 3 settimane fa.

Assigned support staff: Vincenzo.

Autore Post
February 23, 2019 at 4:48 pm

alessandroS-3

Sto tentando di: inserire nel main menu il selettore lingue a tendina

Link a una pagina dove è possibile vedere il problema: hidden link

Mi aspettavo di vedere: nel backend ricordo di aver visto la possibilità di impostare un menu lingue a tendina mentre adesso vedo solo la possibilità di usare le bandierine in linea, occupandomi molto spazio

February 23, 2019 at 5:23 pm #3235584

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

WPML fornisce l'opzione per utilizzare un menu lingue a tendina. Puoi attivarla da WPML -> Lingue -> Menu del selettore della lingua.

Il problema è che c'è un conflitto nel sito che impedisce l'apertura delle opzioni del selettore (icona a forma di matita).

Per risolvere, credo sia necessario aggiornare il PHP ad una versione più recente ed aggiungere il "Set di caratteri Utf8mb4".
- Maggiori dettagli nella pagina WPML -> Assistenza

Prova inoltre a disattivare tutti i plugin eccetto WPML ed a modificare le opzioni del selettore lingue da WPML -> Lingue -> Menu del selettore della lingua.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

February 23, 2019 at 5:32 pm #3235593

alessandroS-3

Ciao Vincenzo,
grazie per avermi risposto subito.
Ho provato a fare come hai suggerito ma il click sulla matita (che avevo provato senza successo) non funziona.

Tra l'altro mi dà problemi anche l'attivazione del plugin "WPML Translation Management". Se tento di attivarlo mi viene restituita una pagina bianca. Non so se questo plugin è strettamente necessario e quindi l'ho lasciato disattivato. Credi che vada attivato? Può essere responsabile del problema? Oppure credi che il mancato funzionamento dipenda da PHP obsoleto?

Credi sia necessario un upgrade di php? (Immagino debba farlo il provider)

Grazie,
Alessandro

February 23, 2019 at 5:57 pm #3235627

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Alessandro,

se il click sulla matita non funziona nemmeno con tutti gli altri plugin disattivati, ci sono buone probabilità che entrambi i problemi dipendano dalla necessità di aggiornare il PHP e di aggiungere il "Set di caratteri Utf8mb4".

La versione di PHP in uso al momento non è sicura.
- hidden link
- hidden link

Per verifica, puoi anche provare a duplicare il sito su un altro server con una versione più recente di PHP.

Fammi sapere se hai bisogno di maggiori informazioni.

Grazie

February 24, 2019 at 8:33 am #3236349

alessandroS-3

Grazie Vincenzo,
ho chiesto al supporto tecnico di Aruba Business di procedere con l'aggiornamento di PHP e il set di caratteri suggerito.
Spero che lo possano fare in maniera indolore senza nessuna migrazione necessaria.
Ti tengo informato.

Sai darmi invece informazioni sul problema relativo al plugin "WPML Translation Management"? Se tento di attivarlo mi viene restituita una pagina bianca.

Grazie ancora,
Alessandro

February 25, 2019 at 11:44 am #3239474

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno Alessandro,

è possibile che il problema di Translation Management sia anch'esso causato dalla versione di PHP.

Per esserne sicuri, è necessario attivare temporaneamente la modalità di debug di WordPress.

Per attivare la modalità di debug di WordPress bisogna:

- aprire il file wp-config.php e cercare la riga:

define('WP_DEBUG', false);

Cambiarla in:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', false);

In questo modo gli errori verranno salvati nel file debug.log all'interno della cartella /wp-content/

Il file wp-config.php si trova nella root della tua cartella WordPress.

Una volta attivata la modalità di debug si deve provocare nuovamente l'errore, attivando Translation Management, in maniera da registrare il problema nel file di log.

A questo punto puoi disattivare la modalità di debug e postare il contenuto del file wp-content/debug.log qui sul forum o, se è troppo grande, su pastebin.com e postare qui il link al paste.

Documentazione relativa:
- https://wpml.org/it/documentazione/informazioni-per-gli-sviluppatori/eseguire-il-debug-di-wpml/
- https://wpml.org/documentation/support/debugging-wpml/
- http://codex.wordpress.org/Debugging_in_WordPress
- https://wpml.org/faq/500-error/

February 25, 2019 at 2:00 pm #3240175

alessandroS-3

[25-Feb-2019 13:54:39 UTC] WPE PHP Compatibility: startScan:
[25-Feb-2019 13:54:39 UTC] WPE PHP Compatibility: timeout: 60
[25-Feb-2019 13:54:39 UTC] WPE PHP Compatibility: lock:
[25-Feb-2019 13:54:39 UTC] WPE PHP Compatibility: scan status: 1
[25-Feb-2019 13:54:39 UTC] WPE PHP Compatibility: 5 plugins left to process.
[25-Feb-2019 13:54:39 UTC] WPE PHP Compatibility: Processing: WPML Multilingual CMS
[25-Feb-2019 13:54:39 UTC] WPE PHP Compatibility: Attempted scan count: 3
[25-Feb-2019 13:54:39 UTC] WPE PHP Compatibility: Skipped: WPML Multilingual CMS
[25-Feb-2019 13:54:39 UTC] WPE PHP Compatibility: Processing: WPML Sticky Links
[25-Feb-2019 13:54:39 UTC] WPE PHP Compatibility: Attempted scan count: 1
[25-Feb-2019 13:54:41 UTC] PHP Warning: tempnam(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs:/usr/local/psa/home/vhosts/mariosalvadori.it/tmp) in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 177
[25-Feb-2019 13:54:41 UTC] PHP Warning: fopen(): Filename cannot be empty in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 177
[25-Feb-2019 13:54:41 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:46 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:47 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:52 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:52 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:52 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:53 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:54 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:54 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:54 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:57 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:54:57 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:55:01 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:55:01 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:55:01 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:55:01 UTC] PHP Warning: fwrite() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 183
[25-Feb-2019 13:55:01 UTC] PHP Warning: stream_get_meta_data() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 242
[25-Feb-2019 13:55:01 UTC] PHP Warning: file_get_contents(): Filename cannot be empty in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 244
[25-Feb-2019 13:55:01 UTC] PHP Warning: fclose() expects parameter 1 to be resource, boolean given in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Reporting.php on line 245
[25-Feb-2019 13:55:01 UTC] WPE PHP Compatibility: Processing: WPML String Translation
[25-Feb-2019 13:55:01 UTC] WPE PHP Compatibility: Attempted scan count: 1
[25-Feb-2019 13:55:02 UTC] PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 128 bytes) in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/php-compatibility-checker/vendor/squizlabs/php_codesniffer/CodeSniffer/Tokenizers/PHP.php on line 1004
[25-Feb-2019 13:55:11 UTC] PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 12288 bytes) in /usr/local/psa/home/vhosts/mariosalvadori.it/httpdocs/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/TokenParser/Block.php on line 37

February 25, 2019 at 2:13 pm #3240253

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Grazie Alessandro,

il problema principale sembra essere il valore basso di WP Memory Limit.

Il valore di WP Memory Limit sembra infatti inferiore ai requisiti minimi di WPML che richiede almeno 128M.
- https://wpml.org/home/minimum-requirements/

Per incrementare il valore di WP Memory Limit aggiungi queste righe in mezzo al file wp-config.php (dopo il tag di apertura del php)

define( 'WP_MEMORY_LIMIT', '128M' );

❌ IMPORTANTE ❌ Non inserire la riga alla fine del file ma sempre prima del seguente commento riguardo la fine delle modifiche):

/* Finito, interrompere le modifiche! Buon blogging. */

Il file wp-config.php si trova nella cartella principale di WordPress.

Puoi verificare quale sia il valore attuale di WP Memory Limit da WPML -> Assistenza nella sezione Info

Maggiori informazioni qui:
- https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

February 25, 2019 at 2:49 pm #3240425

alessandroS-3

Grazie a te Vincenzo per il supporto.
Ho seguito le tue indicazioni ma il problema persiste. Probabilmente serve davvero un aggiornamento del PHP o che le modifiche al limite di memoria vengano fatte dal provider.
In assistenza trovo adesso queste info (vedi allegato)

February 25, 2019 at 3:07 pm #3240568

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Alessandro,

hai ragione. Anche se il WP Memory Limit è stato correttamente aumentato, il memory limit del PHP rimane sempre 64M. Questo Memory Limit può essere incrementato solo dal provider del servizio hosting.

Sarà necessario chiedere anche questo incremento per far funzionare il sito correttamente.

Fammi sapere se hai bisogno di maggiori informazioni.

Grazie