This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 10 risposte, has 2 voci.

Last updated by gilbertom 4 settimane, 1 giorno fa.

Assigned support staff: Noman.

Autore Post
April 16, 2019 at 10:18 am

gilbertom

Sto tentando di: Scegli il formato dell'URL per la visualizzazione dei contenuti in una lingua

Directory con lingue diverse ((hidden link - Inglese, hidden link - Tedesco hidden link Italiano)

Link a una pagina dove è possibile vedere il problema: hidden link

Mi aspettavo di vedere:

Invece ho ottenuto:Sembra che la creazione di directory diverse per ogni lingua non funzionerà. Dettagli

Questo può essere il risultato di entrambi:

WordPress è installato in una directory (non principale) e tu stai utilizzando i link predefiniti.
Il tuo server web non è abilitato alla riscrittura degli URL.
Il server web non è in grado di scrivere nel file .htaccess
Come risolvere il problema
Quando WPML accede a hidden link ottiene:

April 16, 2019 at 12:34 pm #3622063

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I am going to answer this in English, I hope that is ok, if you still need help in Italian please let me know.

I have checked your site and directory option is working good, it's a false-positive alert, you can ignore that alert in backend. Sometimes this can be a false positive so, if your site is working properly even with the error message being displayed, you can ignore this error message.

Thank you

April 16, 2019 at 2:22 pm #3622899

gilbertom

Hi, the problem is that I want to display hidden link and NOT hidden link

I would english language on hidden link, Italian on hidden link and German on hidden link

And If I change (like screenshot) English language disappear and redirect on hidden link

April 16, 2019 at 5:35 pm #3624271

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I am seening some php warnings on your site now, previously there was no errors on the site. Looks like you have changed something.

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

- Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

- If still issue persists, please enable error reporting at you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

This will create debug.log file in your site's wp-content directory. Please send me its contents.

Thank you

April 18, 2019 at 9:52 am #3637941

gilbertom

Doesn't work

April 18, 2019 at 9:54 am #3637953

gilbertom

I have 3 languages: en, it, de
I want hotelorologiocaorle.com in english (not hotelorologiocaorle.com/en)
I have try to change as you have tell me but with the same result

April 18, 2019 at 2:18 pm #3639893

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

April 20, 2019 at 9:57 am #3650003

gilbertom

---
I need to send you a private message with login and password

April 21, 2019 at 11:39 am #3652315

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have enabled private input box for your next reply, please send me WP-Admin and FTP Login info of your site.

=== Please backup your database and website ===

Thank you

April 23, 2019 at 9:17 am
April 23, 2019 at 3:38 pm #3665757

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and checked plugin conflict in your site. The issue is gone when I deactivated SEO Redirection Premium plugin.

Also I couldn’t find ‘SEO Redirection Premium’ plugin in our verified compatibility plugin list:
https://wpml.org/documentation/plugins-compatibility/

I recommend to please ask ‘SEO Redirection Premium’ plugin author so they can advise you on latest compatibility of their plugin and WPML, may be they have fix for it, so it should work fine with wpml.

Additionally, I have noticed that you have installed Advanced Custom Fields Multilingual, BuddyPress Multilingual, MailChimp for WordPress Multilingual and WooCommerce Multilingual plugins in your site. These plugins add multilingual features to other plugins but these plugins only needed when you install main plugins e.g. Woocommerce, Buddypress, Mailchimp for WordPress, Woocommerce respectively. So, you can remove these plugins.

Thank you

April 24, 2019 at 7:44 am #3669873

gilbertom

My issue is resolved now. Thank you!