This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 20 risposte, has 2 voci.

Last updated by Vincenzo 2 anni, 10 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
February 16, 2017 at 10:47 am #1209913

Renzo

Buongiorno,
quando setto WPML come in Fig.1, nelle pagine deI portfolio (hidden link) mi visualizza sempre e solo la 1a pagina, anche cliccando sui link delle altre pagine.
Per ovviare a questo inconveniente ho dovuto, per ora, dettarlo come in Fig.2.
Saprebbe dirmi perché succede questo?

Grazie,
Renzo Granzotto

February 16, 2017 at 11:42 am #1209990

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve Renzo, grazie per aver contattato il supporto WPML!
Mi occuperò di questo ticket.

1. Puoi mandarmi il link alla pagina due quando WPML è impostato come in fig. 1?
- Puoi ottenere il link originale avvicinando il cursore sopra il numero 2

2. Hai provato a salvare nuovamente i Permalink dovo aver impostato la configurazione come in fig. 1?

Grazie

February 16, 2017 at 11:56 am #1210013

Renzo

1. se setto WPML come in fig.1 il link sarà sempre e solo sulla pagina 1 (comunque se lo desideri, lo faccio volentieri…)
2. Ovviamente si devono SEMPRE ri-salvare i permalink, lo dice WPML stesso… 🙂

February 16, 2017 at 12:02 pm #1210018

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve,

mi chiedevo se il link verso le pagine successive fosse quello della pagina 1 anche prima di cliccarci sopra.

Potresti postarmi il link completo usando il tasto destro del mouse + Copia indirizzo link sul link alla pagina 2 quando WPML è impostato come in fig. 1?

Grazie

February 16, 2017 at 2:34 pm #1210215

Renzo

L'ho settato come volevi, così poi provarlo da te.
Comunque il link è giusto:
hidden link
ma non funziona….

February 16, 2017 at 2:43 pm #1210232

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve,

da quello che posso vedere il link parte correttamente ma successivamente viene effettuato un redirect 301 verso la prima pagina e questo accade in entrambe le lingue.

1. Prova questi passaggi:

❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌
- Disattiva WPML e i suoi addon.
Il problema si risolve?

2. Prova questi passaggi:
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌
- Disattiva tutti i plugin tranne WPML e i suoi addon
- Se il problema si risolve, comincia ad attivare i plugin uno alla volta finché il problema non torna.

- Puoi segnalarmi quando torna il problema?

3. Puoi verificare se ci sono regole di redirect impostate nel file .htaccess che si trova dentro la cartella principale del sito (oltre naturalmente quelle standard di WordPress contenute fra i tag # BEGIN WordPress e # END WordPress?

Grazie

February 16, 2017 at 3:29 pm #1210311

Renzo

1- Disattiva WPML e i suoi addon: Il problema si risolve?
Si risolve anche SENZA disattivare WPML, ma configurandolo come in Fig.2

3-
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

February 16, 2017 at 3:36 pm #1210330

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve,

il contenuto del file .htaccess sembra corretto.

I risultati dei passaggi 1 e 2 servono per capire la provenienza del problema.

Potresti effettuare i passaggi seguenti e riportarmi i risultati?
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

1. Disattiva WPML e i suoi addon.
- Il problema si risolve?

2. Disattiva tutti i plugin tranne WPML e i suoi addon.
- Se il problema si risolve, comincia ad attivare i plugin uno alla volta finché il problema non torna.
- Puoi segnalarmi quando torna il problema?

Grazie

February 16, 2017 at 4:49 pm #1210398

Renzo

1. Disattiva WPML e i suoi addon: Il problema si risolve? Si

2. Disattiva tutti i plugin tranne WPML e i suoi addon: Il problema si risolve? No

February 16, 2017 at 4:52 pm #1210406

Renzo

Da notare che il tema viene garantito WPML compatibile.
E in questo momento sono attivi solo i plugin del tema (senza i quali non si vedrebbe il sito) e WPML.

February 17, 2017 at 1:08 pm #1211100

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve Renzo,

Per proseguire nel debug del problema, senza compromettere il sito online, avrei bisogno di replicare il sito localmente nel mio server.

Per questo normalmente raccomandiamo il Plugin gratuito “Duplicator”
- http://wordpress.org/plugins/duplicator/

Istruzioni: hidden link

Usando i filtri di Duplicator puoi evitare di includere la cache, la cartella wp-uploads, i file media e gli archivi per ridurre la dimensione dell'archivio.

A me servono i due documenti che il plugin genera (archive e installer).

Puoi usare servizi come Google Drive o Dropbox per inviarmeli.

Ti attivo una risposta privata così puoi inviarmi i link dei file in maniera sicura.

Grazie

February 17, 2017 at 2:45 pm #1211184

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve,

ti allego uno screenshot dove ho segnato in rosso cosa premere per filtrare i contenuti (se necessario).

Ti attivo una risposta privata così puoi inviarmi i link dei file in maniera sicura.

Grazie

February 20, 2017 at 2:20 pm #1212631

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao Renzo,

puoi incollare il link ai file direttamente nella prossima risposta perché è privata.

Grazie

February 21, 2017 at 4:55 pm #1213862

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve Renzo,

ho potuto verificare il problema e si tratta di un problema conosciuto su cui i nostri sviluppatori stanno lavorando in questo momento.

Ti terrò aggiornato sugli sviluppi.

Nel frattempo puoi usare uno di questi 2 workaround.

1. Vai su WPML -> Lingue
- Attiva l'opzione "Directory con lingue diverse"
- Disattiva l'opzione "Usa la directory per la lingua predefinita"
- Salva
- Salva i Permalink

2. Effettua un downgrade alle versioni precedenti dei nostri plugin
- ❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌
⌥ Io uso spesso il plugin Duplicator per questo scopo.
Vedi: http://wordpress.org/plugins/duplicator/

Le versioni da utilizzare sono:
WPML Multilingual CMS 3.6.2
WPML String Translation 2.5.1
WPML Translation Management 2.2.6
WPML Sticky Links 1.4.0
WPML CMS Nav 1.4.19

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

February 22, 2017 at 7:40 am #1214223

Renzo

Buongiorno Vincenzo,
ho ricevuto la tua risposta ed ho capito che è un problema che WPML dovrà risolvere.
Posso fare anche il downgrade, ma, giusto per sapere, se lascio i settaggi come in fig.2 (come sono ora) che problemi ci sono? Ho degli svantaggi sul sito o è solo una questione di forma (directory /it per l'italiano e directory /en per l'inglese)?