This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 5 risposte, has 2 voci.

Last updated by Noman 3 mesi, 2 settimane fa.

Assigned support staff: Noman.

Autore Post
June 20, 2019 at 8:21 am #4057563

giulianoG-8

Hi,
I am translating few pages of my website, therefore I have news sections with post that won't show in the translated pages.

Is it possible to show all post in each language (even if the post are not translated) by default?

Thank you

June 20, 2019 at 8:35 am #4057693

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. You can display posts in default language by selecting ‘Translatable - use translation if available or fallback to default language’ option from WPML >> Settings >> Multilingual Content Setup > Post Types Translation. Which means, If a translation exists WPML displays it, otherwise, it displays content from the site’s default language.

Here is doc for more details:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/#displaying-original-content-for-whole-post-types

Thank you

June 20, 2019 at 12:11 pm #4059843

giulianoG-8

Hi, thank you for your reply, unfortunately it didn't work, I am using DIVI template and blog element and it only shows post in the main website language. Can you help? Thank you

June 23, 2019 at 12:57 pm #4073061

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Sorry for the delay, we ran into the weekend.

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- You are using an older version of WordPress on your site, please backup your site and update WordPress to it’s latest version 5.2.2.

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 26, 2019 at 10:06 am #4091259

giulianoG-8

Hi,
I did update and increased the memory as you said.
It didn't worked.
The only thing that worked is to translate every single post...problem is that translation changes the date of post and doesn't show the featured image...both of this are problems.
How to fix that? And why is this "Translatable - use translation if available or fallback to default language" option not working?

June 26, 2019 at 4:46 pm #4094147

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- You can copy the publishing date of a post to the translated post by following below steps:
1. Go to WPML >> Settings > Posts and pages synchronization.
2. Check the 'Copy publishing date to translations' option.
3. Save the settings.

However, please note that you might need to update your current original posts, which lets WPML sync their publishing dates to their translations.

- Please follow this doc for sync featured images:
https://wpml.org/documentation/getting-started-guide/media-translation/#media-translation-settings

- It might be some conflict or compatibility issue between WPML and blog element but we can make it sure by checking for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

If the issue is gone, activate one by one to see which one there is an interaction issue.

Thank you

The topic ‘[Closed] Show posts even if not translated’ is closed to new replies.