This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 risposte, has 2 voci.

Last updated by Laura 2 mesi, 4 settimane fa.

Assigned support staff: Laura.

Autore Post
July 17, 2019 at 9:14 am #4227961

sterneI

Buongiorno,
purtroppo dopo l'ultimo aggiornamento del plugin entrando su qualsiasi prodotto su Woocommerce e andando ad editare ad esempio la quantità del prodotto o delle singole varianti, le dà bloccate da un lucchetto a causa di WPML.
Andando però in Woocommerce multilanguage di tutti i prodotti realmente esistenti sul sito nè dà uno solamente, quindi mi viene da pensare che non sono più sincronizzati i prodotti.

Come è possibile risolvere?

Grazie

Cordiali saluti

July 17, 2019 at 11:06 am #4229159

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

Non mi è chiara la situazione. La lingua di default del sito è l'italiano, quindi se editi o crei un nuovo prodotto tutti i campi dovrebbero essere editabili. Oppure la lingua originale dei prodotti è un'altra?

Quanto al problema della sincronizzazione, vedo nelle informazioni di debug che ha l'opzione di fallback sulla lingua originale - quindi tutti i prodotti sono tradotti?

July 17, 2019 at 1:03 pm #4230239

sterneI

Guardi ho provato ad editarli in qualsiasi lingua e la situazione rimane invariata. Tutti i prodotti sono tradotti.

Forse si è corrotto qualcosa dopo l'ultimo aggiornamento.
La prego mi aiuti a risolverlo in qualsiasi modo.

Grazie mille

July 17, 2019 at 2:37 pm #4231339

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

OK, ma io ho fatto una domanda diversa. In che lingua sono stati creati originariamente i prodotti?

Se mi fornisci le credenziali provo a dare un'occhiata. Abilito una risposta privata.

July 17, 2019 at 4:43 pm #4232287

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

in che lingua sono stati creati i prodotti?

Se provo ad aprire un prodotto (in italiano) e ad editare la traduzione inglese, ricevo il messaggio "Il sito sta avendo problemi tecnici. Controlla la casella di posta dell'amministratore del sito per istruzioni." Cosa dice la mail?

Ti chiederei anche di abilitare il debug log di WordPress.
Per farlo inserisci queste righe all'inizio del file wp-config.php dopo il tag di apertura:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

dopodiché riproduci l'errore e dovresti trovare un file debug.log nella cartella wp-content.

Copia le ultime righe qui. Se necessario, rimuovi le informazioni sensibili.

July 17, 2019 at 5:51 pm #4232779

sterneI

Fatto, risolto il problema. Riprovi e mi faccia sapere. Grazie mille

July 18, 2019 at 7:44 am #4235789

sterneI

Buongiorno,
attendo sue nuove. Grazie mille

July 18, 2019 at 11:17 am #4237965

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

se provo ad accedere alle traduzioni ho nuovamente la stessa schermata di errore.

Ho bisogno che tu collabori con me nel risolvere il problema, perché al momento non riesco a capire quale sia.
E' arrivata una mail come da schermata? Se sì, cosa dice?
Hai attivato il debug.log? (come spiegato qui https://wpml.org/it/forums/topic/sincronizzazione-prodotti/#post-4232287) se sì, ci sono errori?
In che lingua sono stati creati originariamente i prodotti?

Io non posso accedere da sola a queste informazioni, ho bisogno che me le dica tu.
Altrimenti devo prendere una copia del sito su cui ho il controllo completo ma questo richiederà più tempo.

July 18, 2019 at 12:41 pm #4238707

sterneI

L'errore che dava era relativo ad un altro plugin che ho disabilitato. Originariamente i prodotti sono stati caricati in italiano. Il problema della mancata sincronizzazione dei prodotti non ha nulla che vedere con il problema che aveva il sito ieri che era dovuto ad un'altro plugin. Ho abilitato proprio adesso il debug.
In ogni caso la mail di ieri diceva questo:
Dettagli dell'errore
====================
Un errore di E_ERROR è stato causato nella linea 519 del file /home/lorenaan/web/lorenaantoniazzi.it/public_html/wp-content/plugins/elementor/includes/plugin.php. Messaggio di errore: Uncaught Error: Class 'Elementor\Editor' not found in /home/lorenaan/web/lorenaantoniazzi.it/public_html/wp-content/plugins/elementor/includes/plugin.php:519
Stack trace:
#0 /home/lorenaan/web/lorenaantoniazzi.it/public_html/wp-content/plugins/elementor/includes/plugin.php(465): Elementor\Plugin->init_components()
#1 /home/lorenaan/web/lorenaantoniazzi.it/public_html/wp-includes/class-wp-hook.php(286): Elementor\Plugin->init('')
#2 /home/lorenaan/web/lorenaantoniazzi.it/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#3 /home/lorenaan/web/lorenaantoniazzi.it/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#4 /home/lorenaan/web/lorenaantoniazzi.it/public_html/wp-settings.php(525): do_action('init')
#5 /home/lorenaan/web/lorenaantoniazzi.it/public_html/wp-config.php(91): require_once('/home/lorenaan/...')
#6 /home/lorenaan/web/lorenaantoniazzi.it/public_html/wp-load.php(37): require_once('/home/lorenaan/...')
#7 /home/lorenaan/web/lorenaantoniazzi.it/public

Mi faccia sapere appena possibile.
Grazie

July 18, 2019 at 1:28 pm #4239081

sterneI

Ho fatto come mi hai scritto nel messaggio privato, nella procedura nei vari campi da compilare non c'era la possibilità di inserire l'user del database e la relativa password.

July 18, 2019 at 1:28 pm #4239083

sterneI

PS: come faccio a rispondere in privato ad un messaggio privato?

July 18, 2019 at 1:36 pm #4239149

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

non tutti i campi sono necessari per iniziare la procedura. Li inseriamo comunque per completezza.

Gli utenti non possono attivare risposte private, possiamo farlo solo noi supporter.

July 18, 2019 at 1:52 pm #4239337

sterneI

Il sito è stato migrato, mi faccia sapere se è tutto ok.
Grazie

July 18, 2019 at 2:48 pm #4239761

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

puoi andare in WPML > Assistenza > risoluzione dei problemi e cliccare su tutti i pulsanti nella sezione "Pulizia"?

Questo ha risolto il problema nella mia copia del sito.

July 18, 2019 at 3:10 pm #4240045

sterneI

ok, ma nella sezione pulizia sul primo pulsante trovo un menù a tendina per scegliere una voce, poi sotto ci sono alcuni pulsanti semplice e altri o con scelte oppure con campi vuoti dove inserire qualcosa. Potrebbe per favore indicarmi scrivendomeli su quali pulsanti nella sezione pulizia devo cliccare ed eventualmente se ce ne fosse il bisogno quali o quale voce dal menù a tendina scegliere?

Grazie mille

The topic ‘[Closed] sincronizzazione prodotti’ is closed to new replies.