This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 7 risposte, has 2 voci.

Last updated by fabioT-6 4 anni, 4 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
February 29, 2016 at 12:57 pm #825964

fabioT-6

Ho la slide (Video) in homepage tradotta in 3 lingue, ed è visibile solamente nella lingua predefinita, in Italiano.

hidden link
hidden link
hidden link

Cosa può essere?

February 29, 2016 at 3:25 pm #826170

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML
Mi occuperò di questo ticket.

Come è inserita la slide video nelle pagine?
Come è stata tradotta?

February 29, 2016 at 3:42 pm #826217

fabioT-6

Ciao Vincenzo, grazie della velocissima risposta.
Il video è tra i Media, e si inserisce con l'URL nella slide tramite Nectar slider (tema Salient).
La slide è stata tradotta in tutte le lingue, come la homepage che la contiene.
Funzionava tutto fino a poco tempo fa.

February 29, 2016 at 4:42 pm #826281

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Puoi verificare se è stata effettuata la traduzione e duplicazione dei media da WPML -> Traduzione file multimediali? (Pulsante 'Avvia')

Ti allego la documentazione relativa:
- https://wpml.org/documentation/getting-started-guide/media-translation/

February 29, 2016 at 4:57 pm #826300

fabioT-6

Avevo già eseguito questa operazione ma niente.
Può essere successo qualcosa dal momento che ho cambiato la lingua predefinita dall'italiano all'inglese?
Al momento è impostata all'Italiano di nuovo.

February 29, 2016 at 5:26 pm #826334

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Se fosse possibile adesso vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

- Un BACKUP dei file e del database è fortemente consigliato -

Potrò dare un'occhiata domattina.

Privacy e Sicurezza:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

March 1, 2016 at 5:18 pm #827429

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Penso che il problema possa essere dovuto al fatto che le homepage in Inglese e Tedesco, sono dei duplicati della homepage in Italiano.

Questo comporta anche altri problemi.

Quando si aggiorna la homepage in lingua originale, vengono automaticamente sovrascritte anche le altre due homepage tradotte.

Per risolvere il problema, vai nelle traduzioni della homepage e premi il pulsante 'Traduci separatamente' a quel punto prova a modificare lo shortcode relativo alle slide e salva la pagina.

Fammi sapere se così risolvi.

Grazie

March 2, 2016 at 10:56 am #828006

fabioT-6

Ho provato a fare come dici ma ancora niente, come se le traduzioni non comunicassero con Nectar Slider, in ogni caso sono riuscito a risolvere raggirando il problema e inserendo la Slide Video tramite un'altra funzione del tema.
Grazie mille lo stesso!