Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

This topic contains 9 risposte, has 2 voci.

Last updated by Alejandro 1 mese fa.

Assigned support staff: Alejandro.

Autore Post
May 17, 2022 at 6:40 pm #11241053

francescaL-10

La ringrazio, questa soluzione può valere anche per le immagini caricate nelle pagine? Quei files trovati nella sezione media sono qualcosa di cui preoccuparsi?

Ho provato a fare una piccola modifica sia sulla homepage che il "chi siamo" italiano, ma le immagini non sono ancora visualizzabili (si tratta di pagine realizzate con WP Bakery page builder)

May 17, 2022 at 7:00 pm #11241119

Alejandro
Supporter

Languages: Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Il problema con l'immagine è che il sito è stato migrato da un altro posto e alune immagini hanno ancora questo link nel database.

Prova ad installare un plugin come questo: https://wordpress.org/plugins/better-search-replace/

Dopo prova a fare un "replace" di hidden link per il tuo sito visto che è questo il problema che hai nelle pagine come "chi siamo".

Provaci e fammi sapere come va.

May 18, 2022 at 5:44 pm #11250075

francescaL-10

Buonasera, abbiamo provato ma purtroppo non funziona abbiamo effettivamente effettuato l'attività indicata e ha trovato alcune voci che ha corretto ma purtroppo l'immagine sulla pagina ancora non è ancora visibile.

May 19, 2022 at 8:12 am #11253241

Alejandro
Supporter

Languages: Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Non avevo notato questo prima ma il directory dell'immagine nella parte tradotta è del 2018 mentre in italiano è del 2021.

Mi potresti dire se hai provato a tradurre l'immagine in qualunque modo in passato? mi sembra troppo strano che il directory dell'immagine sia TOTALMENTE diverso.

-------------------

Potresti provare a cancellare totalmente la pagina in inglese (cancellala permanentemente, quindi anche dal cestino) e poi prova a tradurlo di nuovo (non dovresti avere problemi visto che usi l'editor di traduzione avanzato, quindi non dovrai nemmeno tradurre ogni stringa tradotta in passato.

Prova a fare questo soltanto dopo aver fatto un backup e fammi sapere come va.

May 19, 2022 at 8:43 am #11254015

francescaL-10

Buongiorno

Il sito lo abbiamo preso in gestione da due mesi, ci risulta ci fosse installato solo il plugin di Gtranslate.

May 19, 2022 at 10:59 am #11255927

Alejandro
Supporter

Languages: Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Prova a fare quello che ti ho consigliato nella mia risposta precedente solo per la pagina del chi siamo (che useremo come riferimento) dopo un backup e fammi sapere se per caso così si sistema il problema.

Saluti.

May 24, 2022 at 12:51 pm #11292593

francescaL-10

Buongiorno, ho provato a eliminare la pagina in inglese (anche dal cestino). Anche se rigenerata non prende la foto.

May 24, 2022 at 2:37 pm #11293987

Alejandro
Supporter

Languages: Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi sa che hai un problema nel database ma il problema non è creato da WPML.

1) puoi per caso creare una specie di clone del tuo sito dove poter lavorare con tutto disattivato?

2) Che cambiamenti hai fatto nel sito a livello di database perché l'immagine neanche si duplica e se provi a duplicarla auomaticamente ottieni un errore e quasi sempre questo significa o un conflitto con un altro plugin oppure un problema di server (che magari non può scrivere nel directory delle immagini).

Ho fatto una prova caricando una nuova immagine e anche se si carica per il wp bakery è come se non esistesse

----------------

Prossimi passi:

- Chiedi all'autore del tema di passarti la versione 6.9.3 di WP Bakery perché quella che hai è troppo vecchia

- Prova a caricare una nuova immagine in Italiano e vedi se si duplica in inglese. (lo puoi fare da media > Libreria. per vedere la libreria tradotta, usa il selettore delle lingue che trovi nella topbar di WordPress)

Se non si duplica:

- Prova a disattivare tutti i plugin (inclusi WPML)
- Prova ad attivare un tema diverso, default di WordPress (twentytwentyone)
- Attiva soltanto WPML
- carica un'altra immagine (Deve avere un nome diverso di quelle caricate)
- Vedi se viene duplicata

Fammi sapere cosa succede.

May 27, 2022 at 10:36 am #11325147

francescaL-10

Buongiorno

Per quanto riguarda il componente, abbiamo contattato lo sviluppatore del tema e ci ha informato che sarà aggiornato nelle prossime release.

Abbiamo comunque proceduto a effettuare la prova indicata, le muove immagini si vedono correttamente sia nella parte italiana che nella parte inglese.

Il problema persiste sulle vecchie immagini caricate nelle pagine (nuove immagini funzionano)

May 27, 2022 at 3:02 pm #11328037

Alejandro
Supporter

Languages: Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Si, immaginavo che il problema era con le vecchie immagini. c'è qualcosa nel database che non va per quelle immagini. non so se in passato è stato cambiato qualcosa direttamente nel database per quanto riguarda Dominio, ecc, ma il problema principale è che le immagini che il sistema ha "registrato" come traduzione per le immagini vecchie sono sempre immagini vecchie del 2018, apparentemente che però non esistono.

quindi visto che non sembrano tante, ti consiglio di scaricarle e ricaricarle + riassegnarle per creare entrate nuove nel database e quindi avere tutto sistemato. poi puoi cancellare le immagini vecchie che non funzionano.

Potresti anche provare ad installare WPML Media translation e magari provare a caricare la stessa immagine per le lingue secondarie.
Una volta che avrai fatto questo ti comparirà una notifica dove ti si chiede se vuoi aggiornare il database e ti darà 2 opzioni. scegli l'opzione "lenta" e vedi se per caso questo ti aiuta.

Il problema è nel database ma non è stato creato per WPML, sembra che in qualche momento le entrate nel database, i riferimenti del directory sia stato cambiato ma solo per una lingua ed è per questo che non funziona nelle pagine vecchie ma solo nelle nuove.