This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.49 hours from now. Thank you for your understanding.

This topic contains 12 risposte, has 2 voci.

Last updated by Alejandro 3 mesi, 4 settimane fa.

Assigned support staff: Alejandro.

Autore Post
July 12, 2019 at 1:12 pm #4199177

enricoD-16

ciao,

ho un ultimo problema di layout che prima dell'update di WPML non era presente, e non è stato risolto dopo l'update di ieri.
Non è causato dal lavoro del ns developer, copio e incollo le sue parole:

"I don't add or remove code. I just change the way the code is loaded (async/defer), I implement caching, minification, compression and a few other items. I have turned all of this off and no speed optimization is currently present on your website. However, the white space persists. Does WPML allow for CSS in the page editor? This might be a good place to look".

I problemi sono diversi, come da screenshot allegati.
- differenze tra versione ENG e ITA del sito, in tutte le pagine relative alle città (sotto-pagine delle Location) e in tutte le pagine appartenenti a "Ruoli", i layout sono diversi. Come puoi vedere anche navigando sul sito, nella versione italiana manca la sidebar (dovrebbe esserci), c'è il title page (non dovrebbe esserci), e c'è un orribile spazio bianco sotto il titolo. La versione ENG presenta uno spazio bianco più piccolo che non dovrebbe esserci - e prima non c'era, ma per il resto è corretta.

- Spazi bianchi un po' ovunque nel sito, sotto gli header e in altre parti anche nella HOME sia in inglese che in italiano (vedere screenshot home e home2).

Importante: il nostro developer sta effettuando ottimizzazioni e dovrebbe aver finito in giornata. Vi prego di non effettuare alcuna modifica finché non vi dirò di farlo, più tardi, per non sovrapporvi al suo lavoro.

Attendo una soluzione.
grazie

Enrico

July 12, 2019 at 1:15 pm #4199193

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ho separato questo ticket perché qui il problema è molto probabilmente di configurazione del tema con WPML.

Molto probabilmente queste opzioni sono opzioni interne del tema (dalle opzioni del tema) oppure opzioni che si trovano nelle pagine stesse.

Se nella homepage, ad esempio, c'è una opzione "disabilita il titolo" o qualcosa del genere, allora dobbiamo cercare direttamente lì e la procedura è una molto semplice.

Se invece questa opzione si trova sulle opzioni del tema stesso (quindi una opzione globale) la procedura è diversa.

Mi potresti far sapere quale delle 2 menzionate sopra è il tuo caso?

July 12, 2019 at 1:33 pm #4199353

enricoD-16

ciao,
non capisco però perché l'update di WPML abbia modificato queste impostazioni. E' una cosa preoccupante, non trovi?

Il titolo della pagina così come la presenza della sidebar a destra sono due cose che si possono modificare all'interno delle pagine, a una a una.

Per quanto riguarda gli spazi bianchi non saprei, perché prima non c'erano, e non so perché abbiano invaso tutte le pagine del sito: in inglese sono più sottili, mentre in italiano spesso sono più grossi.

July 12, 2019 at 1:48 pm #4199447

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

In realtà il problema è l'opposto, non le ha modificati proprio e questo succede perché queste configurazioni devono essere "regolate" dall'autore stesso tramite un file wpml-config.xml sul tema, che o non esiste o non è completo (molte volte gli autori si dimenticano di queste configurazioni), quindi prenderà le opzioni per default del tema/pagina.

Visto che la configurazione esiste all'interno di ogni pagina, dovremo seguire questa procedura:

- Tutte quelle opzioni vengono commandate da "custom field" che potrai trovare nella stessa pagina, scendendo verso la fine della pagina, nella sezione "Multilingual content setup"

- Probabilmente troverai un sacco di campi e accanto a questi campi troverai le opzioni "do not translate, translate, copy, copy once" (non in questo ordine, però).

- Trova i campi giusti: i campi di solito hanno nomi abbastanza reconoscibili, quindi se c'è una voce "rimuovere titolo della pagina" ad esempio, probabilmente troverai un campo che avrà un nome simile a questo: [prefisso tema]_options_title o insomma nel campo troverai come minimo la parola "title"

- Cambia quella voce da "do not translate" a "copy" visto che vuoi che si copi esattamente nelle traduzioni.

- Premi Applica (il pulsante alla fine dell'elenco dei campi personalizzati/custom fields)

- Fai lo stesso per le diverse opzioni che ci sono. se ci sono opzioni con dei titoli da cambiare o da tradurre, allora cambia l'opzione a "translate", invece.

- Cambia un carattere nel titolo della pagina (o nel corpo, qualunque cosa che per WordPress significhi un aggiornamento della pagina) e poi salva la pagina, così potrai aggiornare la traduzione.

Aggiorna la traduzione perché il sistema rilevi le nuove modifiche e copi i campi che hai appena modificato.

Quello dovrebbe sistemare tutto o quasi tutto.

Provaci e dimmi se dopo anche gli spazi rimangono, per vedere come procedere a risolvere quel problema (ma prima finiamo di risolvere questo qui che è più grosso).

Saluti.

July 12, 2019 at 2:00 pm #4199519

enricoD-16

"In realtà il problema è l'opposto, non le ha modificati proprio e questo succede perché queste configurazioni devono essere "regolate" dall'autore stesso tramite un file wpml-config.xml sul tema, che o non esiste o non è completo (molte volte gli autori si dimenticano di queste configurazioni), quindi prenderà le opzioni per default del tema/pagina."

Scusami ma non ho capito. Prima dell'aggiornamento del plugin e degli add-on, il sito era perfetto sotto questo punto di vista. Quando copio una pagina dall'inglese all'italiano, solitamente la copia correttamente. Quello che mi preoccupa è che tutto è stato cambiato dopo l'aggiornamento del plugin. Al prossimo aggiornamento cosa succederà?

Per quanto riguarda la procedura che mi consigli, non c'è il tag title in nessun custom field. A questo punto è più veloce modificare a mano le pagine una per una, utilizzando le "Jupiter page options". Non è veloce, ma almeno sono sicuro che funzionerà.

Al momento comunque non posso fare modifiche, come scritto sopra, ma devo aspettare il via libera del developer.

Resterà poi da capire il perché degli spazi bianchi.

July 12, 2019 at 2:38 pm #4199911

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ho capito quello che intendi e si, vale la pena verificare perché prima funzionava e ora no, e sopratutto se i custom field hanno cambiato valore, il perché di questo è anche importante ma al momento è un po' difficile poter conoscere questi dettagli visto che non posso accedere al sito.

Se nel frattempo mi invii uno screenshot delle opzioni selezionate nella pagina e poi mi invii l'elenco dei multilingual content setup, forse posso trovare io il collegamento tra i custom field,

Se ci sono anche campi dei meta terms (sempre sulla stessa sezione "Multilingual Content Setup", inviami anche quelli).

A volte questi custom field possono essere categorizzati come "system custom field" quindi forse dovresti anche controllare se trovi il custom field premendo il link "show system fields" che trovi prima dell'elenco dei custom field.

Saluti.

July 15, 2019 at 9:22 am #4209019

enricoD-16

Buongiorno,
allego screenshots come da richiesta.

Il developer dovrebbe avere quasi finito, al massimo entro la serata. Dopodiché inizierò a sistemare manualmente tutte le pagine, tramite le opzioni di Jupiter, se non c'è un modo più veloce.
Resteranno i problemi degli spazi bianchi sparsi per tutto il sito, e dell'aggiornamento problematico di WPML che ha portato a tutti questi problemi.
bisognerebbe capire il perché, e come evitarlo in futuro.

July 15, 2019 at 1:47 pm #4211759

enricoD-16

Ho aggiustato il layout delle pagine. Rimangono gli spazi bianchi sotto la barra dei menu e nella home, ad esempio - screenshot.

Come risolviamo?

July 15, 2019 at 2:51 pm #4212381

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ho letto tutti i custom field.

Prima di tutto cominciamo con quelli che non sono system fields (cioè quelli che NON iniziano con l'underscore i.e: "_[field name goes here]" )

non so cosa fa il "textfalse" e sembra essere uno creato appositamente da un utente, quindi per ora quello lasciamolo come sta.

Lasceremo anche il campo "classic-editor-remember"

Tutti gli altri cambiali all'opzione "copy" e premi "Applica".

Poi cambia un carattere o fai un cambio qualunque alla pagina e poi aggiorna la traduzione. vedi se quello risolve il problema degli spazi.

Se non li risolvi, allora assicurati di vedere anche i custom field del sistema (premendo "show system field" come ti ho suggerito in una risposta previa) e cerca tutti quelli che contengano la parola "head" e cambiale a "copy"

Fai lo stesso per quelli che contengono la parola "body"

Di nuovo, premi applica e poi cambia un carattere o fai un cambio qualunque alla pagina originale e infine aggiorna la traduzione di nuovo.

Fammi sapere come va.

July 15, 2019 at 4:05 pm #4213187

enricoD-16

Ho provato, non risolve alcun problema come immaginavo.
Questo perché il problema non è visibile solo nelle pagine tradotte, ma in tutte quante, indipendentemente da inglese o italiano.

Altre soluzioni?
grazie

July 15, 2019 at 4:12 pm #4213209

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Penso di aver trovato il problema anche se non penso abbia a che fare con WPML per niente.

Se sistemi questo codice CSS:

.header-style-1 .mk-header-padding-wrapper, .header-style-2 .mk-header-padding-wrapper, .header-style-3 .mk-header-padding-wrapper {
    padding-top: 73px;
}

E sostituisci il valore "73px" per "48px" vedrai che il problema non c'è più.

Di preciso quel valore "73px" viene dalla classe

.header-style-1 .mk-header-padding-wrapper
}

Quindi puoi controllare la sezione Custom CSS del tuo tema o quella standard di WordPress (Appearance > Customize > Custom CSS) per vedere se è stata aggiunta manualmente.

Puoi anche provare a disabilitare WPML per vedere se il problema sparisce anche se probabilmente non sparirà (WPML non ha una classe simile a quella editata quindi non penso che stia sovrascrivendo il codice CSS menzionato sopra).

Saluti.

July 15, 2019 at 4:43 pm #4213407

enricoD-16

Purtroppo non trovo quel codice nel custom CSS, dunque non è stato aggiunto a mano.
A questo punto provo ad aprire un ticket con Artbees e vediamo se lo risolvono loro. La cosa strana è che prima dell'update di WPML tutti questi problemi non si erano verificati..

July 16, 2019 at 7:52 am #4217253

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Sinceramente non so cosa dirti, ma fammi sapere cosa dice artbees, perché se loro riescono a trovare qualcosa che punta a WPML, allora certamente dobbiamo vedere cosa succede.

Per ora, possiamo fare una prova semplice. se carichi il tuo tema (Jupiter e poi il child Jobbami) su questo sandbox: hidden link

Dovremo vederlo subito. in questo sandbox ho già configurato WPML ma al momento l'ho disattivato, così possiamo vedere se il problema compare sin da subito.

In teoria dovremo vederlo prima con il Jupiter (quindi senza il child theme) e poi con le modifiche aportate nel child theme (se ci sono) per vedere le differenze.

Se non sbaglio il header si costruisce tramite le opzioni del tema quindi dovresti importare queste opzioni nel sandbox, appena avrai caricato il tema Jupiter.

Che ne dici?

The topic ‘[Closed] Split: problemi update del plugin e add on String & translation management’ is closed to new replies.