This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Autore Post
July 9, 2019 at 2:28 pm #4171861

Luca Fazio

Grazie.
Sono riuscito.
Adesso però ho bisogno di supporto perchè il sito da quando ho installato WPML è lentissimo.
Ho visto tramite il plugin Query Monitor che questo plugin mi rallenta parecchio il sito: wpml-string-translation
A cosa serve? Posso risolvere in qualche modo o lo cancello?
Grazie

July 9, 2019 at 2:31 pm #4171879

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Allora, io ti consiglierei di provare a disattivarlo e vedere se il sito funziona bene.

String translation molte volte è richiesto dai temi e plugin per avere una compatibilità completa al 100%.

Comunque il problema viene causato quasi sempre quando ci sono tante stringhe registrate nel database.

Più o meno entro fine mese rilasceremo un aggiornamento che eliminerà la lentezza causata da questo plugin, visto che abbiamo cambiato totalmente il modo come questo plugin funziona.

Se desideri aspettare posso cambiare lo stato di questo ticket per poterti avvisare appena uscirà, se invece il sito è troppo lento, puoi darmi accesso al tuo sito e io ti posso fare alcune modifiche temporanee che elimineranno questo rallentamento.

Saluti.

July 10, 2019 at 5:37 am #4176185

Luca Fazio

Ciao Alessandro.
Avvertimi pure.
Intanto lo disinstallo così da verificare se ho dei miglioramenti. Per il resto come potremmo muoverci? Accessi a che livello? E se condividessi con te lo schermo e facciamo un check insieme? Grazie

July 10, 2019 at 3:26 pm #4182159

Luca Fazio

Ciao Alessandro,
oggi ho provato a lavorare con questo nuovo plugin WPML ma sto avendo un mare di problemi.
Non capisco come sia possibile che se accedo come amministratore a questi due link:
hidden link
hidden link
il risultato è il seguente:
Oops! That page can’t be found.
Se invece accedo senza inserire credenziali, da visitatore risultano alimentati (allego le immagini)
Indicami gentilmente dove trovo sul sito questi contenuti che li cancello...non sono riuscito a trovarli in nessuna pagina di wordpress e nemmeno in woocommerce WPML.
Attendo tue istruzioni
Grazie

July 10, 2019 at 3:59 pm #4182455

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Probabilmente la lentezza e questi errori sono collegati.

Se hai riscontrato questo problema è perché probabilmente c'è qualcosa (tema o plugin) che non vuole giocare bene con WPML.

Purtroppo non possiamo fare condivisioni di schermi ma posso sempre accedere al tuo sito e con le tue istruzioni cercare di riprodurre il problema.

Mi servirebbero delle credenziali di accesso al sito (preferibilmente come amministratore, così posso fare delle prove più approfondite), così posso dare una occhiata al sito, vedere cosa succede e procedere a cercare di trovare una soluzione.

A questo punto se puoi darmi anche accesso FTP meglio ancora (così, se crasha qualcosa mentre guardo una pagina o creo una modifica ad una pagina di test, posso sempre rimediare e non faccio andare in tilt il sito)

Ho attivato di nuovo i campi appositi, aggiungi tutto in questi campi per mantenere le credenziali e altri dati privati e sicuri.

Saluti.

July 10, 2019 at 4:06 pm #4182475

Luca Fazio

Ciao.
Se provassi a disinstallare tutti i plugin WPML torna tutto come prima o rischio qualcosa?
Disinstallo, e reinstallo tutto che ne pensi?

Grazie alessandro

July 10, 2019 at 4:24 pm #4182577

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Puoi provare e non rischi niente facendolo.

Al momento hai chiuso il ticket quindi forse non riceverò più i messaggi che mi invii ma se riscontri qualche problema, procedi ad aprirlo o ad aprire un altro ticket (potrai anche assegnarlo a me) e ti aiuterò volentieri.

Saluti.

July 10, 2019 at 4:28 pm #4182637

Luca Fazio

Ciao.
Se provassi a disinstallare tutti i plugin WPML torna tutto come prima o rischio qualcosa?
Disinstallo, e reinstallo tutto che ne pensi?

Grazie alessandro

July 10, 2019 at 4:31 pm #4182647

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao, non rischi niente con disinstallarlo e installarlo di nuovo quindi provaci e fammi sapere come va.

Una cosa che vedrai quando disattiverai WPML sono un sacco di pagine duplicate. non ti preoccupare, è una cosa normale (sono le pagine tradotte che sembrano duplicate ma non lo sono)

Appena attiverai di nuovo WPML, si sistemerà tutto.

Fammi sapere come va.

July 10, 2019 at 5:18 pm #4183167

Luca Fazio

Ciao Alessandro,
non ho risolto nulla:-(
Ho disinstallato e reinstallato tutto...inizialmente con le pagine duplicate...poi ho ripercorso il tutto ed è tornato tutto come prima senza riuscire a risolvere il problema che ti dicevo prima:

"Ciao Alessandro,
oggi ho provato a lavorare con questo nuovo plugin WPML ma sto avendo un mare di problemi.
Non capisco come sia possibile che se accedo come amministratore a questi due link:
hidden link
hidden link
il risultato è il seguente:
Oops! That page can’t be found.
Se invece accedo senza inserire credenziali, da visitatore risultano alimentati (allego le immagini)
Indicami gentilmente dove trovo sul sito questi contenuti che li cancello...non sono riuscito a trovarli in nessuna pagina di wordpress e nemmeno in woocommerce WPML.
Attendo tue istruzioni
Grazie"

Non posso purtroppo fornirti gli accessi...devi provare a dirmi come faccio a risolvere facendomi fare dei passaggi; anche lavorando tramite filezilla.
Attendo tue direttive...se hai dubbi scrivimi.
Grazie
ps hai un telefono che provo a chiamarti?

July 11, 2019 at 3:00 pm #4191265

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi potresti dare accesso al sito per poter controllare da vicino cosa succede?

Così posso fare diverse prove (che ovviamente non faranno niente alla tua configurazione) per cercare di risolvere questo problema più velocemente, perché senza essere loggato, come ben dici, non si riesce a vedere bene il problema.

Ho attivato i campi necessari per le credenziali sotto alla tua prossima risposta.

Saluti.

July 11, 2019 at 3:07 pm #4191421

Luca Fazio

Ciao Alessandro,
come già detto non posso fornirti gli accessi.
Non so se sono stato chiaro nella precedente spiega del mio problema.
Se sei in grado di darmi delle dritte step by step su come posso risolvere se no mi dici con chi posso confrontarmi in merito.
Grazie

July 11, 2019 at 5:22 pm #4192267

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Scusami, sinceramente non avevo proprio letto la parte che mi dicevi che non mi potevi fornire accessi prima (solo la parte dei passi step by step).

Ho visto che il directories per entrambe le lingue esiste il che mi dice che potrebbe esserci un problema in WPML > Languages > URL Format.

Visto che usi il URL per directories, potresti dirmi se hai segnato l'opzione "Use directory for default language" ?

Se è segnata potresti temporaneamente disabilitarla, poi salvare l'opzione e poi andare su Settings > Permalinks e salvare i permalinks?

Poi, prova a pulire il cache del sito e del navigatore e controlla se ora funziona tanto come loggato come senza.

July 12, 2019 at 7:25 am #4195953

Luca Fazio

Ciao Alessandro.
Adesso sembra funzionare. Grazie!
Andando avanti vorrei chiederti come sistemare alcune cose ricordandoti che in attesa che esca la versione nuova, ho disabilitato "WPML String Translation" perchè mi rallentava in modo spaventoso (attendo che mi avverti quando potrò avere la nuova versione).
La domanda adesso è la seguente:
Al momento ho tradotto la home page, ma se clicco sulla bandiera in inglese certe parti della pagina rimangono in italiano:-( non riesco a trovare la sezione dove posso procedere alla traduzione
Riesci ad indicarmi come fare? Le sezioni a cui mi riferisco che rimangono in italiano sono le seguenti:
Prossimamente
Pulsante (Accedi/Registrati)
Prodotti Consumer
SCEGLI I TUOI PRODOTTI
ULTIMI PRODOTTI CONSUMER
Termini e condizioni
Trovaci sulla mappa

Attendo tue
Luca

July 12, 2019 at 11:44 am #4198259

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi sapresti dire da dove vengono queste sezioni? è possibile che vengano da una stringa registrata direttamente sul tema e se è così, in teoria avresti bisogno di String Translation.

Per ora però se vuoi una alternativa, so che alcuni dei nostri utenti usano un plugin chiamato "Loco Translator" che lavora in un modo simile (anche se più semplice) di String Translation.

Potresti provare a vedere se trovi quelle stringhe usando quel plugin e da lì stesso lo potrai tradurre.

Una volta che String Translation verrà aggiornato potrai poi fare il passaggio da Loco translator a String Translation e in quel momento basta che me lo chiedi e ti spiegherò meglio come fare.

Fammi sapere se questo ti aiuta o se anche dopo aver seguito il mio suggerimento non riesci a risolvere il problema.