This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 17 risposte, has 2 voci.

Last updated by Andrés 2 mesi, 1 settimana fa.

Assigned support staff: Andrés.

Autore Post
August 5, 2019 at 8:31 am #4338999

federicoB-38

good morning,
I haven't solved the problem, now I have a new alert telling you to contact WPML support, what should I do?
"Some taxonomies in your site are forced to be untranslatable. This is a problem when you're trying to run a multilingual site."

A plugin or the theme are probably doing this.

What you can do:

1. Temporarily disable plugins and see if this message disappears.

2. Temporarily switch the theme and see if this message disappears.

It's best to contact WPML support, tell me you're getting this message and offer to send a Duplicator copy of the site. We will work with the theme / plugin author and fix the problem for good. In the meanwhile, we'll give you a temporary solution, so you're not stuck. "

August 5, 2019 at 8:33 am #4339005

Andrés
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Francese (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

As this is a new issue I have created a new ticket for you.

Could you please tell me what you found after executing the procedure recommended on your Dashboard?

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

Best regards,
Andrés

August 5, 2019 at 8:51 am #4339119

federicoB-38

grazie!
Laura

August 5, 2019 at 9:07 am #4339165

Andrés
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Francese (Français )

Timezone: Europe/Paris (GMT+02:00)

Prego! 🙂

August 5, 2019 at 9:20 am #4339221

federicoB-38

have you received my debug?

August 5, 2019 at 12:36 pm #4340585

Andrés
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Francese (Français )

Timezone: Europe/Paris (GMT+02:00)

Yes, I have received it, thank you. 🙂

1. Could you please tell me what you found after following your alert instructions?

1. Temporarily disable plugins and see if this message disappears.

2. Temporarily switch the theme and see if this message disappears.

2. Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:
- MemoryLimit 256M
- WP Memory Limit 40M

Add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

August 5, 2019 at 1:10 pm #4340721

federicoB-38

Thank you
-1) If you disable WPML plugins the message disappears
2) If I change the template the message is still visible
I increased the memory, but the message is still present, what can I do?
thank you
laura

August 5, 2019 at 1:47 pm #4341041

Andrés
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Francese (Français )

Timezone: Europe/Paris (GMT+02:00)

Sorry for the misunderstanding, Laura, but the idea is to deactivate all your plugins and let WPML activated. Does the message disappear under those circumstances ?

August 5, 2019 at 2:19 pm #4341291

federicoB-38

sorry I didn't understand.
I have disabled all the plugins, only the WPML ones are active.
I changed the theme.
adersso what should i do?

August 5, 2019 at 4:12 pm #4341935

Andrés
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Francese (Français )

Timezone: Europe/Paris (GMT+02:00)

I'm sorry but I want to be sure that I understand because your messages are contradictory:
- You have switched to a WordPress default theme.
- You have deactivated all your plugins but you left WPML activated.
Under this scenario, the message disappeared?

August 6, 2019 at 10:44 am #4346553

federicoB-38

Good morning,
I did tests.
The message appears when the Spring Plant Theme is active. Version: 2.1.
How can I solve it?

August 6, 2019 at 1:11 pm #4347699

Andrés
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Francese (Français )

Timezone: Europe/Paris (GMT+02:00)

Perfect, you have identified that your theme Spring Plant is modifying some settings that it shouldn't. This theme is not in our compatibility list, however it doesn't necessarily imply that it is not compatible, just that our team has not tested yet.
https://wpml.org/documentation/theme-compatibility/

Now, the idea now would be to identify taxonomies settings in WPML > Configuration > Taxonomies and setting them correctly. Could you verify them?

Otherwise, I have created a test website with a clean WordPress install. You can access it through this link:
hidden link

Please upload your theme Spring Plant to this test install and setup it the same way as in your website. In this way we can check if this is a compatibility issue.


Please note that we only need your theme, you don't need to setup a entire website or clone your existing site.

August 6, 2019 at 3:01 pm #4348919

federicoB-38

Good evening, I installed the theme and its plugins on the site you created me.
Now you can see the message.
Thank you

August 6, 2019 at 4:24 pm #4349549

Andrés
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Francese (Français )

Timezone: Europe/Paris (GMT+02:00)

Thank you for your help.

After following the instructions provided on my previous answer, I have detected that the following fields has been modify for your theme. Once you set them right, the message disappears.

- Go to WPML > Configuration > Taxonomies Translation.
- Click on the Lock button next to each setting and change them to:
x Product categories (product_cat) > Translatable - only show translated items
x Product tags (product_tag) > Translatable - only show translated items
x Product shipping classes (product_shipping_class) > Translatable - only show translated items
In our test site it worked.

Does it help?

August 7, 2019 at 4:38 pm #4356913

federicoB-38

You can send me the screenshot because otherwise I can't understand. Thank you