Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 7 risposte, has 2 voci.

Last updated by Laura 1 mese fa.

Assigned support staff: Laura.

Autore Post
October 25, 2021 at 10:10 am #9855907

simoneM-8

Buongiono,
sul sito in oggetto sto usando il plugin Search & Filter che è compatibile con WPML (ho seguito queste istruzioni hidden link) .

Ho creato un form di ricerca in italiano, qui hidden link e il suo corrispettivo in inglese, qui hidden link.
Tutto sul momento bene, se non fosse che, se si salva l'italiano, la versione inglese risulta mancante di tutte le località, e viceversa se l'ultima ad essere salvata è la versione inglese succede l'inverso, è la versione italiana ad essere mancante delle località da filtrare nel menu a tendina.
Quale può essere il problema e soprattutto la soluzione?
Grazie, saluti
S.M.

October 25, 2021 at 1:53 pm #9858021

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve,

grazie per averci contattato.

Se hai già verificato che il problema persiste se
1. disinstalli tutti i plugin tranne WPML e Search & Filter e il tema
2. utilizzi il formato "directory per lingua" invece del parametro

Prova a riprodurre il problema qui hidden link così possiamo eventualmente inviarlo al team di compatibiltà.

October 26, 2021 at 3:16 pm #9865979

simoneM-8

Salve e grazie,

stranamente non mi è arrivata la mail di notifica che avevate risposto (ho guardato anche nello spam).

Ho intanto fatto la prova n° 2, ma non è cambiato nulla.
Per quanto riguarda la 1. devo attendere il momento giusto perchè il sito è online, spero di farlo a breve o al massimo nel prossimo fine settimana.

Non è facile riprodurre il problema su quel sito di testing, dovrei intstallare plugin vari...
Vediamo prima di percorrere altre strade.

October 26, 2021 at 4:58 pm #9867007

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ok, aspetto notizie.

October 29, 2021 at 7:15 am #9889079

simoneM-8

Buongiorno,
tenete ancora aperto questo ticket per favore. Sto lavorando con gli sviluppatori del plugin per individuare la causa del problema. Se dovesse risultare che è da indagare lato WPML vi ricontatto.
Grazie, Simone

October 29, 2021 at 9:18 am #9889993

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

i ticket vengono chiusi automaticamente dopo 2 settimane, non ci è possibile modificare questo comportamento. Dovesse chiudersi, puoi semplicemente aprirne un altro indicando questo come riferimento.

November 5, 2021 at 8:19 am #9931401

simoneM-8

Salve,
allora, dopo aver creato un sito di staging il supporto del plugin Search & Filter ha fatto in modo che le due versioni, italiano ed inglese funzionassero bene,
si veda
hidden link

hidden link

Il problema è che non riesco ad applicare sul sito live quanto mi suggeriscono, ovvero:
"...you would need to do enable the Slug Translations option from the WPML settings"

Credo di avere attivato l'opzione, ma sul sito live il comportamento delle versione inglese non è cambiato..

hidden link

hidden link

Potete darci un'occhiata?
Grazie, saluti

November 5, 2021 at 11:20 am #9932931

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Mi servirebbe sapere

1. cos'hanno fatto sul sito di staging per "far funzionare tutto"
2. cos'hai fatto tu sul sito esattamente, perché solo guardando le pagine non vedo nessuna differenza.

L'unica cosa che rilevo è l'utilizzo della directory invece del parametro, che peraltro ti avevo già suggerito.

The topic ‘[Closed] Strano problema con plugin Search & Filter’ is closed to new replies.