This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This thread is resolved. Here is a description of the problem and solution.

Problem: la stringa "read more" presente nel modulo Blog & News non appare nel Translation Editor Solution: una soluzione definitiva sarà in una prossima versione di WPML. Vedi Relevant Documentation per un workaround Relevant Documentation: https://wpml.org/it/forums/topic/stringa-in-template-elementor/#post-3861113

Etichettato: 

This topic contains 4 risposte, has 2 voci.

Last updated by massimilianoM-11 5 mesi, 3 settimane fa.

Assigned support staff: Laura.

Autore Post
May 17, 2019 at 11:30 am #3833927

massimilianoM-11

Laura, funziona.
Restando però nello stesso sito, come posso tradurre la riga "LEGGI L'ARTICOLO" che è presente dentro uno degli elementi del template "Blog & News"? Nelle stringhe non la trovo.

May 18, 2019 at 7:46 am #3838467

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

potresti ridarmi le credenziali del sito? Quando un ticket è risolto vengono cancellate automaticamente quindi non le posso prendere dal ticket precedente.

May 21, 2019 at 3:14 pm #3856543

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

il ticket è scalato al secondo livello, ti faccio sapere il prima possibile

May 22, 2019 at 6:11 am #3861113

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

una soluzione al problema dovrebbe essere presente nella prossima versione di WPML.
Se vuoi risolverlo prima, puoi procedere in questo modo:

- fai un backup del sito e del database
- apri il file wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/class-wpml-elementor-translatable-nodes.php
- cerca questo array

 'menu-anchor' => array(
                'conditions' => array( self::TYPE => 'menu-anchor' ),
                'fields'     => array(
                    array(
                        'field'       => 'anchor',
                        'type'        => __( 'Menu Anchor', 'sitepress' ),
                        'editor_type' => 'LINE'
                    ),
                ),
            ),

- dopo di esso, aggiungi questo codice

'archive-posts' => array(
                'conditions' => array( self::TYPE => 'archive-posts' ),
                'fields'     => array(
                    array(
                        'field'       => 'archive_cards_meta_separator',
                        'type'        => __( 'Cards: Separator Between', 'sitepress' ),
                        'editor_type' => 'LINE'
                    ),
                    array(
                        'field'       => 'archive_cards_read_more_text',
                        'type'        => __( 'Cards: Read More Text', 'sitepress' ),
                        'editor_type' => 'LINE'
                    ),
                    array(
                        'field'       => 'nothing_found_message',
                        'type'        => __( 'Nothing Found Message', 'sitepress' ),
                        'editor_type' => 'AREA'
                    ),
                    array(
                        'field'       => 'pagination_prev_label',
                        'type'        => __( 'Previous Label', 'sitepress' ),
                        'editor_type' => 'LINE'
                    ),
                    array(
                        'field'       => 'pagination_next_label',
                        'type'        => __( 'Next Label', 'sitepress' ),
                        'editor_type' => 'LINE'
                    ),
                    array(
                        'field'       => 'archive_classic_meta_separator',
                        'type'        => __( 'Classic: Separator Between', 'sitepress' ),
                        'editor_type' => 'LINE'
                    ),
                    array(
                        'field'       => 'archive_classic_read_more_text',
                        'type'        => __( 'Classic: Read More Text', 'sitepress' ),
                        'editor_type' => 'LINE'
                    ),
                ),
            ),

dopodiché dovresti trovare la stringa in Traduzione Stringhe. Se non appare, visita la pagina "Blog" nel frontend per la registrazione.

Fammi sapere se così risolvi o se hai bisogno di ulteriore assistenza.

May 27, 2019 at 4:00 pm #3899503

massimilianoM-11

My issue is resolved now. Thank you!