This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 12 risposte, has 2 voci.

Last updated by Alejandro 1 mese, 1 settimana fa.

Assigned support staff: Alejandro.

Autore Post
September 2, 2019 at 5:12 pm #4499365

marcoB-114

Surfing by mobile if I am visiting the blog page ( hidden link ) and I will click on the Russian language, it doesn't change the language.

I saw that by mobile it load a different URL not the URL as I set in the admin panel.
How I can solve?

September 3, 2019 at 11:32 am #4504005

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Per capire meglio come procedere a risolvere questo problema, potresti inviarmi le informazioni di debug della tua istallazione, gentilmente?
Per farlo, basta seguire questi semplici passi: http://wpml.org/faq/provide-debug-information-faster-support/

September 3, 2019 at 2:03 pm #4505143

marcoB-114

Eccolo! grazie mille!
In pratica da mobile non cambia lingua.. l'ho notato nella pagina blog.. xche richiama un URL sbagliato...

September 3, 2019 at 3:23 pm #4505797

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Quel menu lo sta aggiungendo il tema, mi sa (questo giudicando dal codice CSS che sta caricando, che è un po' diverso dal nostro, e anche dalle bandiere che usa), cerca nelle impostazioni del tema se per caso trovi delle opzioni per modificarlo o per cambiarlo.

Nel frattempo mi sai dire se per caso per il mobile il language switcher è uno diverso da quello desktop (se ci sono opzioni per il mobile, probabilmente lo è) ?

September 3, 2019 at 3:38 pm #4505891

marcoB-114

le bandierine sono un'opzione di WMPL per personalizzarle.... e nel menù in uso: Off Canvas Navigation Menu non c'è nessun langua switcher. Le bandierine sono comparse con l'installazione del WPML.
L'errore è comparso quando ho modificato questo parametro: Language URL format

da Language name added as a parameter (hidden link - Russian)

a

Different languages in directories ((hidden link - English, hidden link - Russian))

September 4, 2019 at 12:55 pm #4511217

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Si, queste bandierine si attivano alla presenza di WPML (è una regola inserita dallo sviluppatore)

Questo errore l'ho visto anche nella homepage del desktop, solo che in questo caso non si rovina l'url perché è molto più semplice.

Comunque prova ad andare su WPML > Assistenza > Risoluzione di problemi (troubleshooting) > Disabilita i template di stilo del selettore di lingue (il primo pulsante nella pagina di troubleshooting)

e poi, prova a cancellare il cache di WPML (secondo o terzo pulsante in quella stessa pagina).

Per ultimo cancella il cache del sito se c'è (e del server se c'è, per questo dovrai chiedere al supporto del hosting).

e per ultimo, vai su Impostazioni > Permalinks > Premi il pulsante per salvare i permalinks.

Fammi sapere se questo risolve il problema.

September 9, 2019 at 9:26 am #4535263

marcoB-114

ciao,
ho seguito tutte le tue istruzioni ma il problema persiste... cosa posso fare?

September 9, 2019 at 1:07 pm #4537383

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi potresti dare accsso al tuo sito, per cercare di capire perché sta succedendo questo problema?

Ho appena attivato i campi appositi per l'inserimento delle credenziali di cui ho bisogno. Questi campi sono privati quindi soltanto noi due potremo vederle e accedervi.

Suggerisco di creare un utente temporaneo, segnarlo come amministratore e poi inserire le credenziali nei campi appositi appena attivati.

September 9, 2019 at 5:17 pm #4539277

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Potresti ricontrollare le credenziali? mi dice che l'utente non esiste.

September 10, 2019 at 12:06 pm #4545053

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

è strano. sembra che il tema abbia caricato una modifica al selettore delle lingue per il mobile, visto che il codice è diverso dal nostro. però mi sa che hanno aggiunto la compatibilità soltanto per il formato URL per parametri.

Potresti caricare il tema qui: hidden link

e poi provare a configurare la pagina in modo che possa vedere questo language switcher nel mobile come lo vedo sul sito? (non devi caricare tutti i plugin. basta il tema e la configurazione che penso si possa esportare dal tema.)

Se ci sono passi particolari per configurare il tema, ti chiedo di scriverli qui, in modo di poter inviarglielo ai nostri sviluppatori in caso confermi che si tratti di un problema di compatibilità.

Con questo test voglio verificare se si tratta di un problema di compatibilità ma voglio anche capire se le configurazioni del server sono corrette perché su settings > Health check ho notato alcune irregolarità che non dovrebbero avere a che fare con il language switcher ma vorrei acertarmi lo stesso di questo.

Grazie in anticipo.

September 11, 2019 at 5:10 pm #4555427

marcoB-114

ma io vorrei farlo senza caricare altri temi perché il sito è in uso.
E il tema non è stato modificato, ma acquistato e messo online.
Avremmo urgenza di risolvere....

September 11, 2019 at 8:35 pm #4556403

marcoB-114

Ho risolto!!!! almeno parzialmente!
Ho reinstallato il tema che probabilmente l'azienda prima di noi aveva modificato ed ora funziona!!!
grazie mille!

September 12, 2019 at 5:44 am #4558499

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ecco. grazie mille per l'aggiornamento!

Lascerò questo ticket aperto per un'altra settimana. se non risponderai si chiuderà automaticamente tra una settimana.

Se vedi che il problema ricompare, scrivilo qui, altrimenti puoi lasciare il ticket inattivo!

Saluti.