Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

Tutti possono leggerlo, ma solo i clienti di WPML possono pubblicare qui. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 12 risposte, has 2 voci.

Last updated by Alejandro 6 mesi, 3 settimane fa.

Assigned support staff: Alejandro.

Autore Post
February 20, 2020 at 10:31 am #5531751

niccoloP-4

Hi,

I'm trying to translate the invictuscorse.it website using WPML and with the BeTheme theme installed.

I've installed the plugin but when I try to translate a page it shows an empty BeTheme Builder page, the content is gone. I tried to use the import / export function of the BeTheme builder and like this it works but of course is not the best solution. Can you help me out? 🙂

Thank you!

February 20, 2020 at 3:18 pm #5534211

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Mi sa che non stai usando l'editor di traduzione, ed ecco perché devi eseguire quella procedura.

Prova ad andare alla pagina principale (quella nella lingua in cui hai creato la prima pagina), poi assicurati che ci sia lo switch attivo (quello che si trova sotto la sezione "Lingue" nella sidebar della pagina).

Poi, vai su WPML > Translation management e assicurati di essere tanto un traduttore come un gestore di traduzione

Per ultimo ritorna alla pagina e ora dovresti poter accedere all'editor di traduzione e tradurre soltanto i testi e non tutta la struttura.

Fammi sapere come va.

February 21, 2020 at 9:43 am #5538903

niccoloP-4

Hi,

If I follow your instruction I can see only some parts of the page (mainly, the images and titles) and not the actual text, I think this is a problem related to the BeTheme theme I'm using.
I can provide a test access to the WP admin if you like, so that you can see for yourself.

Thank you!

February 21, 2020 at 1:57 pm #5541247

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

the builder you're using with the theme is "Muffin Builder" right? and yes, i have enabled the credential fields so you can add them there in your next answer.

Regards.

February 21, 2020 at 7:52 pm #5543595

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Vediamo.

Ho aggiornato la pagina (aggiungendo un carattere al titolo per vedere poi la traduzione aggiornata) e ho poi aggiornato la traduzione.

Ci sono alcune cose strana che non sono sicuro che sia corretto, nell'editor di traduzione si vedevano tanti campi che normalmente non si devono vedere.

Una cosa che ho fatto è attivare l'editor avanzato su WPML > Impostazioni > Come tradurre articoli e pagine.

e poi ho provato a tradurre la pagina, ho copiato tutti i campi della home ma la pagina si è creata correttamente.

Il problema principale è il fatto che non avevi raggiunto i requisiti minimi di WPML, ti mancava la memoria che ho aumentato per te.

Prova a tradurre correttamente la homepage e fammi sapere se è apposto anche nel front-end.

Saluti.

February 24, 2020 at 9:55 am #5552723

niccoloP-4

Ho provato ad usare l'editor avanzato di traduzione (cliccando la matita di fianco al nome della pagina per l'inglese) e ho completato la traduzione delle parti testuali ma anche salvando, la home rimane la stessa in italiano. Appare in compenso l'header che ho nascosto nella versione italiana, immagino di doverlo modificare "switchando" all'inglese nella pagina dell'editor di BeTheme.

Come si può fare? Nonostante la traduzione appaia completata, non si vede passando alla lingua inglese e la home rimane in italiano.

Grazie,

February 24, 2020 at 12:05 pm #5554095

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ho il sospetto che ci sia una incompatibilità con questo builder. ho inviato una richiesta al nostro team di compatibilità per vedere se ci sono problemi conosciuti a riguardo. Ti terrò aggiornato.

February 24, 2020 at 12:55 pm #5554487

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Could you pleas ask the BeThemes' support what is "WPML Installer" supposed to do? it's found under: si trova in BeTheme > Theme Options > Translate > WPML Installer.

Apart from that, there is something weird with all the different information that is showing in the editor, but i created a new page and it worked correctly.

what i did was that i first created the section, then a wrapper, then the elements were added in the wrapper, it looks as the same thing you did, but can you try duplicating the page and translating it to see if it shows correctly again? do not set it as a homepage, because i'd like to see if the problem is coming from somewhere else.

Let me know how it goes.

February 24, 2020 at 12:56 pm #5554491

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Oh, by the way, this is the test page: hidden link

i left it private so you can see it and see if you can spot any difference from yours, you can delete it when you do.

Regards.

February 24, 2020 at 1:16 pm #5554635

niccoloP-4

hi,

I'm not sure i'm still covered by BeTheme assistance since I've installed and registered the theme many months ago. Did you by any change deactivated the Wordfence Firewall? It looks like the tester user I've created for you at WPML did that, just to confirm.

I'm not sure what should I do with the page you've created, do you mean that I have to duplicate it using the BeTheme editor export function?

Thank you!

February 24, 2020 at 4:16 pm #5556189

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Oh i might've done so for a moment when i briefly deactivated the plugins to test for something. i actually turned all the plugins on right afterwards but i'm not sure if the firewall from wordfence had to be manually reactivated.

About the test page, i just asked you to check it out, it works there so don't duplicate the test page but duplicate the homepage that didn't work before. then translate it again (on the duplicate page) and see if by any chance it works because it could be one of these 2 problems:

1) The homepage is not "translatable" (very difficult to happen but not impossible)
2) The page is corrupt so that's why some or all the page is not translated correctly.

Try it and let me know so i can know what to do with the results that you let me know.

Thanks.

February 25, 2020 at 10:51 am #5561505

niccoloP-4

I tried using the "export function" of the BeTheme builder and it exported also the translation I've done before, here is the test page and is translated correctyl:

hidden link

What should I do for the other pages?

February 25, 2020 at 2:53 pm #5563497

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hm, ok so if it's translated correctly, then let's try the next step. set that new homepage as the front-end and make a change to the page, maybe add a new column or element at the end of the page and change the title a little bit.

save it and translate what you just added and see if it keeps being translated or not. if it does, then you are dealing with corrupt pages, so duplicate the others, delete the old ones and replace the permalinks of the new pages with the old permalinks (to keep your SEO and internal links correct)

Let me know how it goes.

The topic ‘[Closed] The BeTheme page content does not appear / not translatable’ is closed to new replies.