This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Autore Post
October 26, 2018 at 12:44 pm

alessandro-francescoB

Messaggio di errore:
There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you.

non riesco a creare le traduzioni dei prodotti. Escono messaggi di "fatal error"

October 26, 2018 at 1:59 pm #2853211

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

Per risolvere il problema, uno dei nostri supporter installerà temporaneamente il plugin ARI Adminer nel sito.
Una volta corretto il problema nel database, il nostro supporter risponderà in Inglese per comunicarti il completamento dell'operazione.

Grazie

October 26, 2018 at 2:12 pm #2853223

George Botsev
Supporter

Languages: Inglese (English )

Timezone: Europe/Sofia (GMT+03:00)

Salve!
Sorry, I am not fluent in Italian.
I patched your site database and you should be good to go.
Please let me know if there is a problem with this issue again.

October 26, 2018 at 2:19 pm #2853236

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

il database è stato corretto.

Fammi sapere se il problema è risolto o se hai bisogno di maggiori informazioni.

Grazie

October 26, 2018 at 2:49 pm #2853388

alessandro-francescoB

Grazie ma purtroppo continuo ad avere lo stesso problema.
Non mi è in alcun modo possibile attivare i due plugin WPML String Translation e WPML Translation Management perché persiste il seguente messaggio:

Il plugin non può essere attivato perché genera un errore fatale.
Fatal error: Cannot redeclare wpml_init_language_switcher() (previously declared in /web/htdocs/www.tecnosorg.com/home/wp-content/plugins/sitepress-multilingual-cms-2/sitepress.php:256) in /web/htdocs/www.tecnosorg.com/home/wp-content/plugins/sitepress-multilingual-cms/sitepress.php on line 262

Grazie

October 26, 2018 at 3:04 pm #2853448

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Dal messaggio d'errore sembra che il plugin WPML Multilingual CMS sia installato 2 volte nello stesso sito.

Puoi verificare se nella cartella /wp-content/plugins/ ci sono più versioni di WPML e dei suoi plugin?

Se fosse così, puoi rimuovere i plugin doppi?

Assicurati inoltre di avere le ultime versioni dei nostri plugin.
Puoi verificare quali siano le ultime versioni andando su "Conto -> Download" su questo sito.
- https://wpml.org/account/downloads/

Se necessario, queste sono le istruzioni per l'aggiornamento:
- https://wpml.org/it/faq/come-installare-wpml/

❌ Assicurati d'avere un backup del sito prima di procedere! ❌

Grazie

October 26, 2018 at 3:34 pm #2853535

alessandro-francescoB

Grazie mille, siamo riusciti ad aggiornare!

Ora però ho un altro problema: nella pagina di woocommerce multilingual mi dice che mi mancano quali tutte le traduzioni in inglese, invece nella pagina dei prodotti nel ho 109. Non capisco quale sia il problema. é presente anche un altro avviso che però non riesco a capire come risolvere.

aleggo screenshot

Grazie Vincenzo

October 26, 2018 at 4:12 pm #2853636

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Per quanto riguarda il messaggio seguente:

WPML non dispone di alcuni record delle tabelle delle lingue e non può funzionare integralmente finché questo problema non sarà risolto.
Per risolvere questo problema, vai alla pagina Risoluzione dei problemi e clicca su "Cancella le informazioni sulle lingue e immetti queste ultime nuovamente".

Si trattava di un avviso che era rimasto bloccato a causa dei problemi precedenti. Lo si capiva perché l'indirizzo della pagina di troubleshooting faceva riferimento alla vecchia cartella di WPML.

tuosito.com/wp-admin/admin.php?page=sitepress-multilingual-cms-2/menu/troubleshooting.php

Per risolvere, ho semplicemente rimosso l'avviso.

Per l'altro problema invece, visto che il problema originale è risolto, posso chiederti di chiudere questo e aprire un nuovo ticket?
- La politica di assistenza prevede che si posti un solo problema per ciascun ticket.
Puoi farlo da questo indirizzo: https://wpml.org/it/forums/forum/supporto-in-italiano/
- Ti basta cliccare su "Apri un nuovo ticket di assistenza"

Questo aiuterà altri utenti con problemi simili a trovare le soluzioni quando cercano nel forum.

Grazie

October 30, 2018 at 8:36 am #2860829

alessandro-francescoB

My issue is resolved now. Thank you!