This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I have translated all the pages of my site but the layout and page title is not same as the layout of original page.

Solution: I have logged in to your site and opened ‘Servizi’ page in edit mode and set custom fields as ‘Copy’ and pressed the Update button and now both pages have similar layout as you can see in the attached screenshot: https://cdn.wpml.org/wp-content/uploads/2019/07/4305625-custom_fields_set_as_copy.jpg?x20381

If you want to keep exact page layout on all languages: - Either you can duplicate original page to secondary language and then translate text of secondary page. - Or you can mark page settings fields to as copy from WPML >> Settings >> Multilingual Content Setup >> Custom Fields Translation so that it will maintain the same value in both pages.

This topic contains 5 risposte, has 2 voci.

Last updated by biancaS-6 2 mesi, 3 settimane fa.

Assigned support staff: Noman.

Autore Post
July 29, 2019 at 8:21 am #4297707

biancaS-6

Hi,

i've translated all the pages of the webiste leucosya.eu from Italian to English via the Translation Editor.

Everything looks fine, apart from the top of the page.
As you can see, it seems that the Editor add the Title Page before the main image.

For example, you can give a look to:
hidden link [Italian version]
hidden link [Englis version]

Then, i attach you also an image that hightlights the differences between the two versions.

How can i do in order to solve the problem?

July 29, 2019 at 9:26 am #4298127

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

July 29, 2019 at 1:03 pm #4299965

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for login details. I have logged in to your site but I am not able to access posts and pages as you can see in the attached screenshot. Could you please upgrade my role to Administrator so that I can fix this issue.

Thank you

July 30, 2019 at 7:07 am #4305127

biancaS-6

Hi Noman,

sorry about that.

Now you are Administrator.

Thank you so much for your help

July 30, 2019 at 8:12 am #4305625

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and opened ‘Servizi’ page in edit mode and set custom fields as ‘Copy’ and pressed the Update button and now both pages have similar layout as you can see in the attached screenshot.

If you want to keep exact page layout on all languages:
- Either you can duplicate original page to secondary language and then translate text of secondary page.
- Or you can mark page settings fields to as copy from WPML >> Settings >> Multilingual Content Setup >> Custom Fields Translation so that it will maintain the same value in both pages.

Please let me know if this resolves your issue or you need further assistance.

Thank you

July 30, 2019 at 8:57 am #4305899

biancaS-6

My issue is resolved now.

Thank you so much, Noman!!

Your support was so precious: very fast and fully effective!!!