This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 11 risposte, has 2 voci.

Last updated by Vincenzo 1 anno, 5 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
May 4, 2018 at 6:48 am #1969284

interacom

Ciao.
sito in questione: hidden link ora in "maintenance mode"
In rispota alla tua richiesta Vincenzo, Vorrei accedere allo spazio privato per inviarvi gli accessi /wp-admin e ftp per potervi fare una copia del sito e capire perche non riesco ad avere la versione del sito in inglese con tutte le opzioni personalizzati del sito dei fogli . i stili in italiano non vengono uguali nella versione inglese, sopratutto la testa, i font, il footer.
Allego il thread che mi hai inviato ultimanente ( non ho ripsoto perchè stavo bene di salute ). C'e qualcosa che posso fare . Duplicator non mi fa una copia perchè i file sono tropo grandi anche escludendo media, immagini, ecc . Mi serve veramente un help da voi. Grazie mille davvero

May 4, 2018 at 7:24 am #1969643

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao, grazie per aver contattato il supporto WPML!

Se fosse possibile vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per scaricarne una copia.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.
Se non vedi il modulo sottostante, non postare le credenziali perché risulterebbe visibili nel forum pubblico:
- hidden link

Grazie

May 4, 2018 at 11:14 am #1973894

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

ho scaricato una copia del sito sul mio server locale.

Ti aggiorno non appena ho delle novità.

Grazie per la pazienza

May 5, 2018 at 3:58 pm #1991718

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

questi sono i passaggi che ho effettuato nella versione locale del tuo sito per copiare le impostazioni Italiane del tema su quelle Inglesi.

- Vai su Avada -> Theme options -> Import/Export
- Seleziona la lingua Italiana nella bacheca utilizzando il selettore lingue nella barra in alto
- Premi il pulsante "Download Data File" e salva una copia delle opzioni per sicurezza
- Premi il pulsante "Copy Data"
- Copia il testo che appare (CTRL +C)
- Cambia la lingua della bacheca su Inglese
- Premi il pulsante "Import contents from File"
- Incolla il testo precedentemente copiato nel box che appare (CTRL +V)
- Premi il pulsante "Import"
- Attendi il completamento dell'operazione di importazione.

Verifica nel sito che le opzioni del tema siano state correttamente copiate dall'Italiano all'Inglese.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

May 7, 2018 at 8:26 am #2005407

interacom

Grazie Vincenzo per il tuo supporto. Ho fatto tutto quello che mi descritto.
Ora però, il problema rimane nel menu e la sincronizzazione. In pratica quando ho una pagina tradotta tipo " PALAZZO" se sono sulla pagina in ITALIANO, e voglio vedere la lingua inglese, clicco sul selettore di lingua , mi porta sempre alla lingua italiana.
Quando sono nella versione Inglese e voglio passare da una pagina ad un altra dal MENU, mi apre sempre la pagina equivalente in italiano. Devo sempre andare sul selettore di lingua per poter leggere i contenuti in inglese.
Possiamo sistemare questa ?
Grazie

May 8, 2018 at 8:06 am #2024940

interacom

Ciao Vincenzo. Hai ricevuto la mia ultima ? Grazie veramente

May 8, 2018 at 9:48 am #2026858

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

sono contento che il problema principale sia risolto.

Per quanto riguarda i menu, prima di tradurre le voci del menu devi tradurre il contenuto a cui fanno riferimento, cioè le pagine e gli articoli.

Da quello che posso vedere nella mia copia del sito, la pagina "Palazzo" non è ancora stata tradotta.

Una volta che tutto il contenuto richiamato dai menu sarà stato tradotto, puoi utilizzare la sincronizzazione del menu per tradurre i menu in maniera veloce (Opzione 2).

In alternativa puoi tradurre manualmente i menu (Opzione 1)

Ti allego la documentazione relativa alla traduzione dei menu che spiega le due opzioni.

Documentazione relativa:
https://wpml.org/it/documentazione/guida-introduttiva/tradurre-i-menu/

May 9, 2018 at 11:13 am #2050804

interacom

Ciao Vincenzo e grazie per il supporto.
Molte pagine sono state tradotte. Ma perchè non si riesce a navigare il sito dopo il switch all'inglese. Mi riporta sempre alla versione italiana. Solo dopo che ho aperto una pagina in italiano, faccio switch dal selettore posso vedere il contenuto in seconda lingua. Non mi pare che deve essere cosi. La traduzione del menu l'ho fatta correttamente con la sincronizzazione.
Faccio un esempio: Sono nella home in italiano. Faccio switch della lingua e vado in inglese. E fino qua va bene, la Home passa all'inglese. Quando clicco su una voce del menu in INGLESE, mi riporta in italiano. Da cosa dipende secondo te.
Grazie e ancora e porta pazienza. E la prima volta che incontro problemi con wpml

May 10, 2018 at 4:31 pm #2077095

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

ho provato a riprodurre il problema nella mia copia locale ma non ci sono riuscito.

Inoltre non ho più accesso alla versione online e quindi non posso vedere il problema che descrivi.

Puoi controllare che quando il mouse è sopra la voce del menu, il link mostrato nella barra di stato è quello in Inglese e non quello in Italiano?

In alcuni casi, specialmente con le voci personalizzate del menu, il link non viene tradotto con la sincronizzazione ed è richiesta la traduzione manuale.
https://wpml.org/it/documentazione/guida-introduttiva/tradurre-i-menu/#opzione-1-traduzione-manuale-dei-menu

Puoi verificare?

May 17, 2018 at 8:50 am #2170503

interacom

Ciao Vincenzo. Tutte le pagine sono state tradotte ed ho verificato anche posizionando il mouse i link che compaiono e sono giusti . Ad esempio la pagina HOME da ITALIANO a INGLESE arriva quando fascio switch lingua e posiziono il mouse si vede il link in basso a sinistra (come da allegato), ma quando clicco sulla voce del menu in questo THE PALACE, STORY o GALLERY mi porta sempre alla versione in ITALIANO invece di INGLESE. Ma questo lo fa su tutte le pagine tradotte. Non mi spiego perchè. Ti devo mandare gli accessi al sito online cosi vedi. Mi mandi in area privata cosi posso metterli.
Grazie mille davvero se mi aiuti a risolvere questo problema.

May 17, 2018 at 10:23 am #2173528

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

da quello che vedo nello screenshot l'indirizzo non sembra corretto. L'indirizzo mostra due volte la cartella /new/
Puoi verificare?

Se così non risolvi, vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.
Se non vedi il modulo sottostante, non postare le credenziali perché risulterebbe visibili nel forum pubblico:
- hidden link

Grazie

May 17, 2018 at 3:39 pm #2179110

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

ho dato un'occhiata al sito e sembra tutto corretto.

L'unica cosa che potrebbe causare un problema simile è il valore del campo "SSL Host" in HTTPS -> General Settings

Al momento il campo "SSL Host" ha il valore "www.TUOSITO.it" mentre forse dovrebbe essere "www.TUOSITO.it/new/"

Prova inoltre a premere il tasto Purge cache sempre nella stessa sezione.

Puoi anche provare a disattivare temporaneamente il plugin WordPress HTTPS per vedere se il problema si risolve.

Potrebbe essere utile pulire la cache dal menu performance e salvare i Permalink dopo ognuna di queste prove.

Grazie