This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.96 hours from now. Thank you for your understanding.

This topic contains 23 risposte, has 2 voci.

Last updated by andrea-giovanniF 1 anno, 7 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
October 13, 2017 at 9:10 am #1400033

andrea-giovanniF

Buongiorno,

vi sottopongo un problema.

Sto duplicando i prodotti integrando traduzioni in inglese. Ho già tradotto categorie e attributi.

Ho un problema però con i campi personalizzati.

Nello screen shot "blocco dati tecnici" vi mostro il blocco "DATI TECNICI" che prevede l'inserimento di testo (anche html). Questa sezione va tradotta in inglese.

Io duplico l'elemento e come mostrato in "Blocco dati tecnici traduzuzione" provo a copiare e incollare del codice html - o anche cambiare testo - ma non mantiene il salvataggio.

Mi potreste indicare come posso risolvere il problema?

Grazie.

Andrea Fumagalli

October 13, 2017 at 9:14 am #1400045

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno Andrea,

puoi verificare come è stato impostato quel campo personalizzato in WPML -> Gestione traduzioni -> Impostazioni contenuto multilingua?

Se il campo personalizzato è impostato su "Copia" quel comportamento è normale. L'impostazione corretta in questo caso è "Traduci".

Puoi fornirmi le Informazioni di debug nell'apposito campo qui sotto?
- https://wpml.org/it/faq/come-fornire-le-informazioni-di-debug-per-unassistenza-piu-rapida/

Grazie

October 17, 2017 at 1:35 pm #1403443

andrea-giovanniF

Vincenzo buongiorno.

Chiedo scusa riapro questo ticket.

Sto cercando di tradurre i prodotti woocommerce.

Non riesco però a visualizzare dei campi personalizzati presenti nel prodotto in italiano.

In allegato ti indico quali sono i campi.

Il campo SCHEDA PERSONALIZZATA TITOLO è una stringa che potrebbe essere tradotta in inglese, il campo invece TABELLA PERSONALIZZATA 1 CONTENUTO dovrei poter decidere in fase di creazione lingua inglese, se copiarlo oppure mettere il mio contenuto.

Non riesco a visualizzare il contenuto di quei campi però.
Sono in ritardo con il progetto...e avrei necessità di un tuo supporto diretto (con accesso per capire meglio di cosa si tratta e di come risolverlo).

Grazie mille in anticipo.

Andrea Fumagalli

October 17, 2017 at 1:54 pm #1403474

andrea-giovanniF

Vincenzo scusami non riesco neppure a duplicare le immagini ed è tutto attivato.

Attendo in un tuo immediato riscontro.

Grazie mille.

Andrea Fumagalli

October 17, 2017 at 2:40 pm #1403552

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

per il problema delle immagini ti chiedo di aprire un altro ticket.
- Sarebbe utile aggiungere al nuovo ticket una descrizione dettagliata dei passaggi che effettui per riprodurre il problema.

se fosse possibile adesso vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.
Se non vedi il modulo sottostante, non postare le credenziali perché risulterebbe visibili nel forum pubblico:
- hidden link

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

- Un BACKUP dei file e del database è fortemente consigliato -

Privacy e Sicurezza:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

October 17, 2017 at 7:52 pm #1403948

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve Andrea,

ho dato un'occhiata ai campi in questione e non vedo il problema.

Sono correttamente impostati su "Traduci" e quindi il contenuto non viene copiato nella traduzione ma viene lasciato vuoto per permetterti di inserire la traduzione.

Se desideri che il contenuto originale venga copiato anche nella traduzione ma poi sia possibile anche la traduzione, puoi provare una di queste soluzioni.

1. Imposta i campi in questione su "Copia una volta".
- In questo modo il valore dei campi sarà copiato all'atto della traduzione ma successivamente non sarà più sincronizzato/sovrascritto.

2. Lascia i campi su "Traduci" ma effettua una duplicazione iniziale quando traduci un prodotto.
- Nella maggior parte dei casi, quando si duplica un post, tutti i campi vengono copiati a prescindere dall'impostazione.

Per quanto riguarda le immagini dipende a quali ti riferisci.
Se ti riferisci alla galleria immagini, verifica l'impostazione del campo _product_image_gallery nella sezione Impostazioni contenuto multilingua in fondo alla pagina di modifica del prodotto.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

October 18, 2017 at 8:11 am #1404315

andrea-giovanniF

Vincenzo buongiorno.

Ti chiedo la gentilezza di provare a verificare il comportamento degli articoli che sono riuscito a modificare fino ad ora.

Articolo XGAS 232 per esempio.

Noto che a seguito di duplicazione ha aggiunto nello slug la dicitura in inglese xgas-232__trashed (non so perchè).

Cliccando sulla matita ed accedendo di nuovo alla scheda di modifica, ho provato ad inserire nel primo campo personalizzato TECHNICAL DATA, ma non lo salva.

Non solo cliccando sulla modifica visualizzo (come potrai vedere anche tu) degli errori, che ho già sottoposto al tuo collega Francesco. Ho eseguito tutte le operazioni di pulizia db, ma non è cambiato nulla.

Please help me...devo inserire i prodotti in inglese entro mezzogiorno!

Grazie

A presto.

Andrea Fumagalli

October 19, 2017 at 8:56 am #1405603

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno Andrea,

di solito lo slug _trashed indica che il post o la sua traduzione si trovavano nel cestino.
- Puoi cambiarlo facilmente.

Per proseguire nel debug del problema, senza compromettere il sito online, avrei bisogno di replicare il sito localmente nel mio server.

Per questo normalmente raccomandiamo il Plugin gratuito “Duplicator”
- https://wordpress.org/plugins/duplicator/

★ Istruzioni:
hidden link
https://wpml.org/it/faq/come-fornire-ai-supporter-una-copia-del-vostro-sito/

Se il file risultante è troppo grande (maggiore di 250 MB) si possono utilizzare i filtri di Duplicator per evitare di includere la cache, la cartella wp-uploads, i file media e gli archivi per ridurre la dimensione dell'archivio.

A me serve il file archive che il plugin genera. Puoi incollare il link al file nella prossima risposta.

Puoi usare servizi come Google Drive o Dropbox per inviarmelo.

Ti attivo una risposta privata così puoi inviarmi il link al file in maniera sicura.

Fammi sapere se hai bisogno di aiuto nel creare il duplicato.

Grazie

October 21, 2017 at 2:20 pm #1407753

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno Andrea,

ho installato il sito su di un server locale ed ho effettuato dei test.

Sembra che i campi personalizzati custom_tab_title1, custom_tab_content1, etc., non vengano visualizzati nell'editor di traduzione.
Le impostazioni di quei campi personalizzati in WPML -> Gestione traduzioni -> Impostazioni contenuto multilingua sono corrette perché se traduco il prodotto utilizzando l'editor manuale, la traduzione avviene correttamente.

Non capisco però come mai i campi in questione non appaiano nell'editor di traduzione.
Noto però che nel tuo primo post l'immagine "Blocco Dati tecnici traduzione.png" mostra quei campi correttamente visualizzati.

1. Puoi dirmi se è stata fatta qualche modifica particolare che potrebbe aver provocato il problema?

2. Puoi dirmi dove e come sono impostati questi campi personalizzati?

Grazie

October 22, 2017 at 3:12 pm #1408046

andrea-giovanniF

Ciao Vincenzo.

Una cortesia. E' possibile sentirci via skype o telefonicamente per velocizzare la risoluzione del problema? Per me sarebbe essenziale per la finalizzazione del progetto.
Domani 23/10 hai disponibilità?

Grazie mille.

Andrea Fumagalli

October 23, 2017 at 8:35 am #1408359

andrea-giovanniF

Buongiorno Vincenzo.

Come anticipato mi piacerebbe fare quattro chiacchiere a voce con te su questi problemi.

Il progetto deve essere consegnato a breve al cliente e vorrei capire come muovermi.

Grazie mille.

Andrea Fumagalli

October 23, 2017 at 8:42 am #1408372

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno Andrea,

come puoi leggere nella nostra pagina "Politica di assistenza", Tutta l’assistenza tecnica viene fornita attraverso il nostro forum.
- https://wpml.org/it/purchase/politica-dellassistenza/
Non è consentito usare altri strumenti.

Se ci sono informazioni che non vuoi condividere nel forum pubblico, fammelo sapere e ti attivo una risposta privata.

Grazie

October 23, 2017 at 11:08 am #1408539

andrea-giovanniF

Ciao Vincenzo.

Non ho nulla da tenere riservato, avevo piacere di velocizzare la cosa visto che avendo tanta operatività in questo progetto faccio molta fatica a dettagliare il tutto.

Nel dettaglio tutto è partito da qui, questo sito di sviluppo hidden link.

La versione del tema installata era instabile e per tale motivo lo sviluppatore del tema "Porto" ci ha preparato un'installazione "pulita" con ultima versione 4.0.2 su questo sito (quello di cui ti ho fatto il backup hidden link)

Avendo fatto gran parte del lavoro sul vecchio server di sviluppo abbiamo caricato i contenuti sul nuovo (solo i contenuti).

Allo stato attuale i problemi per me bloccanti sono:

Quello già evidenziato che i campi personalizzati custom_tab_title1, custom_tab_content1, etc., non vengano visualizzati nell'editor di traduzione. Come posso comunque risolvere il problema secondo te? Non utilizzando il nuovo strumento di traduzione ma quello standard? Se si ti prego di indicarmi come fare. In fase così avanzata io posso solo mettere mano a quanto già inserito e non effettuare altre operazioni...

Ho notato che questo prodotto duplicato in inglese come glia altri ha visualizzato il TITOLO e IL CONTENUTO del tab in questione.

hidden link

In più tutte le traduzioni inserite nelle descrizioni complete dei prodotti, non vengono visualizzate se effetto switch in lingua inglese:

hidden link
hidden link

In allegato il dettaglio della configurazione del prodotto nel backend (che potrai visualizzare anche tu in locale)

Attendo tuo riscontro.

Grazie.

Andrea Fumagalli

October 23, 2017 at 4:48 pm #1409084

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Andrea,

se, da come vedo nella copia in locale, le traduzioni in Inglese non sono ancora state completate, puoi provare questi passaggi:

- Vai su WooCommerce -> WooCommerce Multilingual -> Impostazioni
- Attiva l'opzione "Schermata di editing dei prodotti WooCommerce nativa"
- Salva le modifiche
- Vai a modificare un prodotto in Italiano.
- Clicca sull'icona a forma di matita
- Traduci il prodotto utilizzando l'interfaccia standard di WordPress/WooCommerce.
Se dovesse apparire il messaggio "Warning: You are trying to edit a translation using the standard WordPress editor but your site is configured to use the WPML Translation Editor", premi sul pulsante "Edit anyway".

Si tratta di un avviso che che compare perché è stata selezionata l'opzione "Usa l'editor di traduzione" in WPML -> Gestione traduzioni -> Impostazioni contenuto multilingua.

Il metodo migliore in questo caso è quello di creare un prodotto in Italiano, salvarlo e poi duplicarlo utilizzando l'apposito checkbox nel widget Lingua alla destra della pagina di editing del prodotto.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

October 24, 2017 at 9:25 am #1409745

andrea-giovanniF

Ciao Vincenzo,

un'informazione per cortesia. Impostando come da tua indicazione la:

"Schermata di editing dei prodotti WooCommerce nativa Sincronizzazione dei prodotti "

al posto di "Editor di traduzione di WPML"

E mantenendo le due opzioni qui di seguito attive, mantengo comunque attiva la sincronizzazione delle categorie anche se gestisco le traduzioni separatamente? E' corretto?

Sincronizza la data di pubblicazione per i prodotti tradotti.
Sincronizza prodotti e ordine tassonomia prodotti

Grazie.

Andrea