Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 29 risposte, has 2 voci.

Last updated by raffaeleM-4 4 settimane, 1 giorno fa.

Assigned support staff: Laura.

Autore Post
June 28, 2022 at 8:38 am #11557121

raffaeleM-4

- Spiegaci cosa stai tentando di fare.
Buongiorno e grazie in anticipo per l'aiuto. Il sito che vi ho segnalato è stato fatto con Elementor e JetEngine (quindi con la relativa creazione di CPT).
La logica impostata è questa: il cpt "Veicoli" ha quattro categorie che sono "Pesanti", "Medi", "Rimorchi / Semirimorchi" e "Gru". La pagina "Vehicles" nella versione eng viene vista dal breadcrumb con il suo nome italiano nonostante sia stata correttamente tradotta e il relativo link corretto.

- Stai seguendo qualche documentazione?
La documentazione seguita è quella ufficiale di WPML.

- Esiste un esempio simile che possiamo vedere?
A scanso di equivoci vi faccio vedere questo link per farvi capire meglio quanto segnalato = hidden link

- Qual è il link al tuo sito?
hidden link

Immagine 2022-06-28 103740.jpg
June 28, 2022 at 9:55 am #11558107

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato. Non ho abbastanza elementi per rispondere alla richiesta.

Per favore inviami le informazioni di debug
https://wpml.org/it/faq/come-fornire-le-informazioni-di-debug-per-unassistenza-piu-rapida/

June 28, 2022 at 10:19 am #11558247

raffaeleM-4

ok eccole qui, serve altro?

June 28, 2022 at 12:02 pm #11559517

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Prova ad aumentare il WP Memory Limit e vedi se il problema si risolve - dovrai risalvare le traduzioni
https://wpml.org/it/faq/checklist-before-opening-a-ticket-in-wpml-support/#how-to-increase-your-sites-memory-limit

June 28, 2022 at 12:54 pm #11559775

raffaeleM-4

effettuando questa operazione andrei a perdere tutte le traduzioni?

June 28, 2022 at 5:23 pm #11561899

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

No, stai solo aumentando la memoria di WordPress, non vai neppure a toccare le impostazioni di WPML. In ogni caso un backup non fa mai male prima di certe operazioni.

June 29, 2022 at 3:57 pm #11569875

raffaeleM-4

ok perfetto, grazie Laura per la disponibilità!
Provvederò a seguire il tuo consiglio.
Buon lavoro

June 30, 2022 at 10:41 am #11575197

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Fammi sapere se così risolvi o se dobbiamo provare altro.

July 1, 2022 at 8:12 am #11582927

raffaeleM-4

ciao Laura, purtroppo non si è risolto questo problema nonostante l'aumento del memory limit..
Rimango in attesa di un tuo riscontro,

Carlo

July 1, 2022 at 11:21 am #11584587

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Il breadcrumb come lo inserisci? Magari c'è un problema di compatibilità

July 1, 2022 at 1:04 pm #11585223

raffaeleM-4

il breadcrumb che uso è quello di Yoast Seo. Ho provato anche quello fornito con Crocoblock ma non è cambiato nulla.

July 1, 2022 at 1:24 pm #11585351

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Vedi se risolvi con questo, sembra lo stesso problema
https://wpml.org/errata/yoast-seo-on-breadcrumb-post-category-links-to-the-wrong-language/

July 4, 2022 at 7:49 am #11595209

raffaeleM-4

Ciao Laura, non ho visto cambiamenti dopo il cambio di codice all'interno del file segnalato dal tuo link. Non capisco quale sia il problema, ho correttamente cambiato il nome del template e del relativo URL ma continua a darmi VEICOLI e non VEHICLES..

July 4, 2022 at 12:03 pm #11597341

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

A questo punto possiamo solo provare a riprodurre il problema. Installa qui Yoast e il plugin con cui crei i CPT e nient'altro, e vedi se è possibile ricreare l'errore
hidden link

July 5, 2022 at 9:26 am #11603575

raffaeleM-4

Ok Laura, ti chiedo di avere un attimo di pazienza in quanto sto consegnando altri due siti con clienti diversi.
Conto di fare questa cosa entro fine settimana. Non riesco a fare diversamente, scusami per le tempistiche così lunghe.
Ti avviserò non appena avrò concluso.
Grazie per la comprensione!