This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.32 hours from now. Thank you for your understanding.

This topic contains 4 risposte, has 3 voci.

Last updated by Alejandro 3 mesi, 3 settimane fa.

Assigned support staff: Alejandro.

Autore Post
June 18, 2019 at 8:58 am #4041603

alessandroS-16

Sto tentando di: tradurre pagine contenenti immagini con link e bottoni

Link a una pagina dove è possibile vedere il problema: hidden link

Mi aspettavo di vedere: che i link venissero cambiati con quelli alle relative pagine tradotte

Invece ho ottenuto:I link non vengono tradotti e devo entrare a modificare la pagina tradotta a mano. I testi delle immagini e dei bottoni sono tradotti/traducibili correttamente i rispettivi link no.

June 18, 2019 at 3:24 pm #4044777

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

In effetti i link interni dovrebbero essere tradotti automaticamente. Come sono aggiunti i link, usi un page builder?

Puoi provare ad aumentare il WP Memory Limit? Aggiungi questo snippet all'inizio del file wp-config.php, dopo il tag di apertura <?

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

Il file wp-config si trova nella root del sito, è lo stesso file che contiene la configurazione del database. Per modificarlo ti servirà un accesso FTP o SFTP. Per controllare il valore registrato del WP Memory Limit puoi andare in WPML -> Assistenza
Ulteriori informazioni:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

Dopodiché prova con l'opzione in WPML -> Settings -> Translate link targets (prima effettua un backup) e vedi se il problema si risolve.

June 19, 2019 at 7:33 am #4048893

alessandroS-16

Si, uso il page builder fornito nel tema Goodlayers
Proverò ad alzare il memory limit, ma avendo già fatto ricalcolare i link senza alcuna segnalazione di errore non credo che si risolva, ma non si sa mai.

June 19, 2019 at 7:58 pm #4054441

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Visto che Laura non è attualmente disponibile, prenderò il suo posto qui nel forum, se non è un problema per te.

Può anche essere così ma siccome è un requisito per l'uso di WPML, è sempre buono averlo.

Comunque, se dopo che fai tutto non funziona, mi potresti far vedere il sito (cioè fornendomi credenziali di accesso?)

Ho attivato i campi appositi, ti chiedo di aggiungere li' le credenziali, così saranno sicure e private

Grazie mille e ti saluto.

June 21, 2019 at 8:32 am #4065493

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Ho controllato con i nostri sviluppatori e in effetti ci sono alcuni problemi di compatibilità con goodlayers.

Ho creato un sandbox che poi invierò ai nostri sviluppatori per vedere se mi possono dire come registrare questi campi mancanti.

Ti chiedo di installare good layers e di cercare di creare 2 pagine:

1) in uno crea una row e aggiungi il link nella row
2) in un altro crea una row con diverse column, e aggiungi il link in una delle column

Mi pare che al momento soltanto in quelle 2 hai i link quindi forse con quelle basta, ma se le hai aggiunte anche nelle immagini, allora, fai la stessa procedura con l'immagine (sempre in pagine diverse)

Così invio tutto al team di compatibilità e cerchiamo di risolvere il problema.

Ecco la pagina di sandbox: hidden link

Saluti.

The topic ‘[Closed] traduzione link’ is closed to new replies.