This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.32 hours from now. Thank you for your understanding.

This topic contains 8 risposte, has 3 voci.

Last updated by Vincenzo 4 mesi, 2 settimane fa.

Assigned support staff: Vincenzo.

Autore Post
December 4, 2018 at 11:47 am #2966204

martaM-13

Sto tentando di tradurre le pagine create con Elementor. Ma le traduzioni non vengono applicate (poco tempo fa riuscivo a farlo).
Nella pagina dei plugin c'è in alto la schermata che invita ad abilitare l'editor di traduzione ma cliccando il bottone ottengo l'immagine in allegato.

December 4, 2018 at 2:37 pm #2966918

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Per caso hai aggiornato il plugin recentemente?

Questo messaggio che vedi, di solito compare la prima volta che hai aggiornato o attivato il plugin, ma non vuol dire che se non si riesce ad abilitare l'editore di traduzione non potrai continuare a tradurre, soltanto significa che, automaticamente, non si è riuscito ad attivare l'editore di traduzione, che non è necessario se ti trovi comodo con il metodo con cui traduci il contenuto attualmente.

Se invece vuoi attivare il suddetto Editore, devi andare su WPML >Impostazioni > Come tradurre gli articoli e le pagine > Seleziona "Usa l'editor di traduzione classico"

Saluti,

Alejandro.

December 5, 2018 at 9:23 am #2969356

martaM-13

Buongiorno Alejandro.
Grazie per la tua risposta.
In effetti ho sempre effettuato le traduzioni manualmente fino ad ora.
Sicuramente ho fatto degli aggiornamenti del plugin recentemente, ma l'ho installato un anno fa e ho già tradotto tutte le pagine dall'italiano all'inglese. Ho notato questo avviso per la prima volta l'altro giorno perché sto tentando di tradurre i testi in cinese. Tuttavia succede una cosa strana: creo la pagina nella relativa lingua (traducendola separatamente), inserisco tutti i testi in cinese con Elementor, salvo il tutto e poi anche se la relativa pagina in cinese esiste e mantiene titolo (in cinese) e slug corretti, tutto il testo all'interno - il contenuto dentro Elementor - è in italiano come se non l'avessi tradotto. Quindi, non riesco a capire il problema. Mi puoi aiutare?

December 5, 2018 at 10:54 am #2969710

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Certamente,

Vedo che hai il plugin "Duplicate Post" e sembra proprio che questo sia il problema, ma prima dobbiamo verificarlo.

Mi puoi confermare che questa pagina l'hai creata duplicando una pagina che già esisteva?
Di solito questo plugin fa fin troppo bene il suo lavoro (duplica tutto) e quando si creano le pagine usando il pulsante "duplica", le pagine finiscono per sempre creare duplicati invece di tradurre le pagine e anche se le modifichi, finiscono per cambiare allo stato duplicato.

Se è questo il problema prova a scaricare un altro plugin che duplichi le pagine e prova di nuovo a fare il tutto. So che puo' essere tedioso ma è il miglior modo di evitare che succeda una cosa del genere nel futuro.

Se questo non è il caso allora forse è il caso di chiedere credenziali di accesso per il tuo sito, in modo di controllare la configurazione della pagina.

Nel frattempo mi potresti dare i passi effettuati per questa pagina in cinese? più dettagli ho, meglio e più velocemente potrò risolvere questo problema.

Fammi sapere.

December 5, 2018 at 11:22 am #2969801

martaM-13

Ciao Alejandro,
in realtà non sto usando il comando "Clona" fornito dal plugin "Duplicate Post" per fare le traduzioni.
Il procedimento che ho sempre adottato col vostro plugin è il seguente:
apro la pagina in italiano e dalla barra laterale creo la copia nella lingua che mi serve, il Cinese in questo caso, coi diversi step fino al bottone "Traduci separatamente". Quando ho dunque la pagina in lingua entro nell'editor di Elementor e traduco pezzo per pezzo. Salvo su Elementor e poi aggiorno la pagina. Accedendo al sito potrai vedere da te che alcune delle pagine che risultano tradotte (ad esempio Pietra I Cutting) i realtà, aprendo Elementor, non lo sono.
Fammi sapere dove posso scriverti le credenziali.
Al momento la lingua cinese è visibile solo per gli Amministratori.

Grazie.

December 6, 2018 at 10:54 am #2973490

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Si,

Come ho spiegato prima, quella funzione "clona" che menzioni al momento non ti permette di tradurre niente, anche se tu scegli di tradurre l'articolo, ti cambierà subito ad un clone di una pagina della lingua originale.

Ti consiglio di cambiare quel plugin e poi provare a riffare la pagina che hai appena clonato, in modo tale che non esista nessuna traduzione o, insomma, nessun contenuto tradotto assegnato per quella pagina.

Comunque ho attivato i campi dove puoi inserire le credenziali, così posso dare una occhiata se è necessario.

Fammi sapere.

December 7, 2018 at 12:56 pm #2977943

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve, mi chiamo Vincenzo.
Attualmente Alejandro non è disponibile. Sarò io a sostituirlo.
Spero che non sia un problema.

Dalla tua descrizione, sembra si tratti del problema descritto in questo articolo:
- https://wpml.org/errata/cannot-edit-page-builder-translations-with-the-native-wordpress-editor/

Per verificarlo, puoi provare a disattivare temporaneamente il plugin WPML Media Translation durante il salvataggio delle pagine?

Grazie

December 7, 2018 at 4:39 pm #2978735

martaM-13

Salve Vincenzo, oggi purtroppo ho avuto modo di dare solo una veloce occhiata alla questione: effettivamente disattivando il Media Translation sembrerebbe mantenere la traduzione anche se la pagina ha perso tutta la formattazione di Elementor.
Quindi mi riservo di verificare meglio lunedì ed eventualmente chiudere il thread.
Grazie.

December 7, 2018 at 4:41 pm #2978750

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Perfetto,

allora metto il ticket in stato di attesa.

Buon fine settimana

The topic ‘[Closed] Traduzione pagine Elementor e mancata attivazione translation editor’ is closed to new replies.