This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 9 risposte, has 2 voci.

Last updated by Alejandro 3 settimane, 2 giorni fa.

Assigned support staff: Alejandro.

Autore Post
January 25, 2020 at 8:52 am #5361065

leandroD-2

Salve, vorrei che questo ticket venisse assegnato ad Alejandro.
Ho avuto già esperienze passate con lui e mi sono trovato molto bene.
Grazie

Nel mio sito ho due lingue e funziona con ultimate member plugin.
I form profilo sono tradotti correttamente in inglese e tedesco e collegati.
Anche le directories membri sono tradotte e sincronizzate.
Il problema è che nelle directories membri, indipendentemente dalla lingua, le stringhe selezionabili nelle listbox sono in tedesco e chiaramente questo si riflette nel frontednd.

Le stringhe non sono contenute nella sezione String Translation.

Ho notato che andando in Translate texts in admin screens »
le stringhe sono presenti nella sezione "um_field"s ma registrate in tedesco, anche se i campi originariamente sono stati creati nel form profilo in inglese.
Selezionandole e facendo clic su Applica un messaggio dice che sarà possibile tradurle nella sezione String Translation ma in realtà non risultano in elenco.

Ho necessità di aiuto per risolvere questo problema.

Grazie anticipatamente

January 27, 2020 at 4:03 pm #5371165

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Proprio poco fa abbiamo rilasciato una documentazione a riguardo, forse ti viene utile:
https://wpml.org/documentation/getting-started-guide/theme-localization/translating-options-coming-from-themes-and-plugins/

Provala insieme a questa documentazione: https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Questo ti dovrebbe aiutare a registrare correttamente le stringhe per poi vederle su WPML > String Translation.

Provaci e fammi sapere come va per conoscere come procedere.

January 27, 2020 at 4:09 pm #5371239

leandroD-2

Ciao Alejandro, la documentazione non aiuta...

January 27, 2020 at 4:13 pm #5371283

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

ok, allora ti chiedo di:

1) lasciarmi i passi per trovare tanto nel front-end come nel wp-admin le stringhe che non funzionano

2) Ti chiedo accesso al sito per poter dare una occhiata da vicino così da poter capire come registrare queste stringhe. Puoi farlo tramite i campi appositi che ho attivato per te.

3) Prima di darmi accesso, per favore ti chiedo di fare un backup, tanto per sicurezza.

Io porverò a vedere cosa sta succedendo e dove si trova il problema per vedere come risolverlo, ok?

Grazie in anticipo.

January 28, 2020 at 2:13 pm #5378007

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

Ho visto che i campi che dici che sono tedeschi, compare infatti una opzione tedesca. ho provato a cambiare questa opzione a "facebook" per vedere se si cambiava anche in tedesco e non si è cambiata, quindi prova a selezionare l'opzione nella lingua giusta e vedi se nel front-end si vede il cambiamento.

Non ho visto io come si vedevano le cose (se si vedevano i campi diversi) nel front-end perché non saprei dove guardare.

Provaci e fammi sapere come va (e scusami se non sono più specifico, è un po' difficile esserlo se non posso nominare le sezioni, campi, ecc)

January 28, 2020 at 2:19 pm #5378025

leandroD-2

Ciao Alejandro, Le lingue sono tradotte correttamente nei vari form ma le stringhe non vengono riconosciute bene perchè, secondo me, memorizzaate solo in una lingua.

Nei form "Member Directories" essendo uno in inglese e uno in tedesco le stringhe dovrebbero essere recuperate dal relativo form in inglese o tedesco di appartenenza.

Per capire meglio prova a guardare in:
String Traslation - Translate texts in admin screens e poi scorri fino a um_fields e aprilo.

Il problema credo sia qui.

Se apri ad esempio "city" (metakey "city") il Title è City. City è quello che verrà visualizzato indifferentemente in tutte le lingue.

Se apri ad esempio "specialization" (metakey "specialization") il Title è Fachrichtung. Fachrichtung è quello che verrà visualizzato indifferentemente in tutte le lingue-

Manca la traduzione della prima o seconda lingua in um_fields

Cosa ne pensi?

Come risolviamo questa cosa?

Se mi mandi il link per rendere privato il messaggio ti spiego in dettaglio meglio il tutto.
Ho necessità di risolvere questo problema.
Grazie

January 28, 2020 at 2:57 pm #5378315

leandroD-2

Guarda le immagini Alejandro. Il campo che viene visualizzato nel frontend è "label". Se spunto label e faccio clic su Appliva cercando di aggiungerlo a String Translation mi dice OK ma poi nella lista delle stringhe non è presente. Quindi...non tradotto

January 28, 2020 at 3:26 pm #5378653

leandroD-2

AGGIORNAMENTO:
Ho quasi risolto il problema aggiungendo le traduzioni mancanti in String Translation con la funzione "Auto register string for translation".
Ora...devo solo invertire la lingua delle due stringhe selezionate in foto e tradurle ma il pulsante "Change language of selected strings" non funziona.
Mi puoi aiutare Alejandro?
Grazie anticipatamente.

January 28, 2020 at 3:53 pm #5378945

leandroD-2

Ho risolto il problema, in modo un po' complicato ma ho risolto.
Rimane la domanda del perchè il pulsante "Change language of selected strings" non funziona.

January 28, 2020 at 5:19 pm #5379645

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

se non funziona è probabile che sia colpa di qualche plugin o anche il tema, che sta disabilitando alcuni pulsanti. prova a disabilitare temporaneamente i plugin e vedi se ora funziona. se funziona allora prova ad abilitare ad uno ad uno i plugin per vedere qual'è il colpevole.

se invece non funziona ancora, cambia il tema per un attimo e prova a controllare se ora funziona.

se invece niente funziona, ti prego di darmi accesso di nuovo per poter controllare cosa succede.

Saluti.

The topic ‘[Closed] Translate texts in admin screens’ is closed to new replies.