This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Non riesco a tradurre i link interni delle colonne di visual composer / WP Bakery

Solution: Aggiungi questo codice su WPML > Impostazioni > Codice XML Personalizzato

<wpml-config>
  <shortcode>
            <tag>vc_column</tag>
            <attributes>
                <attribute type="vc_link">link</attribute>
            </attributes>
  </shortcode>
</wpml-config>

Relevant Documentation: https://wpml.org/documentation/support/language-configuration-files/overriding-language-configuration-files/

This topic contains 11 risposte, has 3 voci.

Last updated by sergioC-29 5 mesi fa.

Assigned support staff: Alejandro.

Autore Post
May 14, 2019 at 2:02 pm #3807847

sergioC-29

Buongiorno gentile staff di WPML, vi contatto perchè non riesco a risolvere un problema relativo al link che inserisco all'interno delle colonne del visual composer, ho trovato questo file hidden link utilissimo per tutti gli oggetti, ma non riesco ad implementarlo aggiungendo la possibilità di mostrare nel editor visuale il link presente all'interno delle colonne.

Il sito è: hidden link

May 15, 2019 at 11:31 am #3815653

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I am going to answer this in English, I hope that is ok, if you still need help in Italian please let me know.

I have noticed that you are using an older version ( 5.8.1 ) of Impreza theme and latest version of Impreza theme is 6.0.4, please update the theme and see if this resolves your issue.
hidden link

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please send me screenshot where link is showing in frontend.

Thank you

May 16, 2019 at 10:30 am #3824773

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for the login info. I am working on this issue and get back to you with my findings.

Thank you for your cooperation and patience.

May 16, 2019 at 10:57 am #3825153

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Just for info, usually we don't debug issues with older version of themes / plugins. But I will do quick debug to see if I can find anything to resolve it.

Thanks

May 16, 2019 at 12:02 pm #3825681

sergioC-29

Thank you so much for your support, if you don't have any good result, please send me a mail, and next week I see if I can update the theme.

See you soon!

May 16, 2019 at 7:11 pm #3829125

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have created a new page for testing VC custom heading element and it working correctly in newly created page as you can see here:
hidden link

Then I tried to modify link in home page custom heading element but it still showing old link as you can see in the attached screenshot. Looks like there is something wrong in home page custom heading element or there might be some server side cache involve in your site that causing this issue.

Could you please clear your site cache and try to update the link again and let me know how it goes?

Thank you

May 20, 2019 at 7:28 am #3844159

sergioC-29

Dear Noman,
thank you for your work and sorry for my late reply. What you are saying is right, infact the custom heading is working correctly but my problem involves links within the column settings. As you can see on the images attached we have a custom heading with no link but we have attached a link to the column instead: you can modify it by clicking on the "modify button" of the "column settings". We recommend you to open directly the page that you created "VC link test": we have updated the row that you created with a link to the column and deleted the link to the custom heading.
The WPML editor doesn't show this link so i cannot translate it. Maybe we could resolve this issue by setting the tag to the link within the column in the XML custom code?

May 20, 2019 at 2:42 pm #3848089

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao, sono Alejandro e mi prenderò cura del tuo ticket, visto che Noman non è disponibile al momento.

Spero non sia un problema per te.

Ho provato a cambiare il link della colonna usando questo codice:

<shortcode>
            <tag>vc_column</tag>
            <attributes>
                <attribute type="vc_link">link</attribute>
            </attributes>
        </shortcode>

e ora lo vedo nel editor di traduzione.

Basterebbe aggiornare le pagine dove vuoi tradurre il link e poi vedrai che ti comparirà il link per la traduzione.

Saluti.

May 20, 2019 at 3:02 pm #3848171

sergioC-29

Grazie Alejandro, però non riesco proprio a capire, la tua pagina la vedo funzionare correttamente, con il codice che hai inserito.. nella homepage invece la colonna "HOTEL" che è settata come la pagina test link, non funziona... non ne vedo proprio la differenza; tu puoi fare un controllo relativo alla home??

May 21, 2019 at 12:18 pm #3855011

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Prova adesso,

non c'era nessun problema, solo mancava qualcosa che facesse aggiornare le traduzioni, in questo caso ho aggiunto un carattere al titolo e ho salvato. poi l'ho tolto il carattere del titolo e ora puoi vedere tutto (questo "trucco" puoi usarlo per forzare l'aggiornamento di ogni traduzione, in qualsiasi momento)

Fammi sapere come va.

May 21, 2019 at 1:25 pm #3855503

sergioC-29

Grande Alejandro!!! funziona tutto correttamente, sei stato gentilissimo, non avevo idee di dover aggiornare così la traduzione, pensavo bastasse semplicemente accedere dalla matita!!!

perfetto ti ringrazio moltissimo ancora e chiudo il ticket!!

Buona giornata e buon lavoro

May 21, 2019 at 1:26 pm #3855511

sergioC-29

My issue is resolved now. Thank you!