This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This thread is resolved. Here is a description of the problem and solution.

Problema: Ricevo questo errore nel sito: Warning: debug_backtrace() expects at most 1 parameter, 2 given Soluzione: Aggiornare il PHP ad una versione recente Documentazione utile: http://php.net/supported-versions.php

Etichettato: ,

This topic contains 2 risposte, has 2 voci.

Last updated by Nicola Mariucci Exprimo Design 1 anno fa.

Assigned support staff: Vincenzo.

Autore Post
October 26, 2018 at 9:34 am #2852596

Nicola Mariucci Exprimo Design

Buongiorno, da alcuni giorni abbiamo una serie warning sulla colonna destra degli articoli in corrispondenza dei box relativi alle traduzioni.

Warning: debug_backtrace() expects at most 1 parameter, 2 given in /home/web/www.cittadicastelloturismo.it/www/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-debug-backtrace.php on line 93

Non ricordiamo di aver attivato alcun debug, non ci serve vorremmo diattivarlo.

Grazie

October 26, 2018 at 10:07 am #2852716

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve e grazie per aver contattato il supporto WPML!

Il problema è quasi certamente causato dal fatto che il server dispone di una versione PHP non aggiornata.
- hidden link

Vedi anche WPML -> Assistenza sul sito per avere maggiori dettagli sullo stato del server.

L'aggiornamento del PHP, oltre a risolvere il problema in questione, renderà il sito più sicuro e migliorerà notevolmente le performance del sito.

In attesa dell'aggiornamento, puoi provare a disabilitare ogni messaggio di debug aprendo il file wp-config.php, impostando WP_DEBUG su false (se fosse impostato su true) e aggiungendo questa riga nel mezzo del file wp-config.php

@ini_set('display_errors',0);

❌ Note importanti ❌
- Non copiare il codice dalla email. Usare il codice visualizzato nel forum.
- In alcune configurazioni del server, questa riga può causare un errore 500. In questo caso, rimuovere la riga e rivolgersi al supporto del servizio di hosting per impostare la direttiva display_errors su 0 tramite il file php.ini

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

October 26, 2018 at 10:19 am #2852736

Nicola Mariucci Exprimo Design

My issue is resolved now. Thank you!