Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 8 risposte, has 2 voci.

Last updated by Laura 1 mese, 2 settimane fa.

Assigned support staff: Laura.

Autore Post
June 24, 2022 at 7:51 am #11536197

martinaB-19

Salve,
ho riscontrato due problemi.
1. avevo impostato un selettore verticale laterale delle lingue seguendo le vostre istruzioni ed era tutto funzionante, oggi vedo che il selettore non è più presente, come mai?
hidden link

2. ho aggiunto un utente come traduttore (quello segnato in rosso nell'immagine), ho inviato alla traduzione le pagine da tradurre, ma io le vedo mentre lui non le vede come mai?

Attendo gentile risposta

traduttore.png
June 24, 2022 at 2:09 pm #11538609

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

La nostra policy è un problema per ticket, quindi per ora rispondo alla prima domanda. Puoi aprire un altro ticket per l'altra questione oppure possiamo dividerlo una volta risolto questo.

Cosa intendi con "selettore verticale laterale"?
Quali sono le impostazioni attuali dei selettori di lingua in WPML > Lingue?

June 24, 2022 at 2:58 pm #11538955

martinaB-19

Io ho seguito le istruzioni come da vostre specifiche al seguente link
https://wpml.org/it/documentazione/guida-introduttiva/configurazione-della-lingua/selettore-di-lingua-personalizzato/

Compariva il selettore come nell'immagine allegata.
Ora le impostazioni sono quelle dell'immagine; ma aprendo la pagina non compare più.

impostazioni.png
Immagine.png
June 24, 2022 at 4:32 pm #11539699

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Tieni presente che quello descritto qui https://wpml.org/it/documentazione/guida-introduttiva/configurazione-della-lingua/selettore-di-lingua-personalizzato/ è un esempio, che va adattato alle caratteristiche del tuo sito. Potrebbe esserci una qualche conflitto sul sito, ma non possiamo fare debugging di codice custom.

I selettori di lingua non custom si vedono?

June 25, 2022 at 11:48 am #11542957

martinaB-19

Ho fatto esattamente quello che c'era scritto lì. Funzionava tutto correttamente, poi improvvisamente non si vede più. Non abbiamo messo altri selettori di lingua, volevamo avere solo quello.

Quindi come faccio a capire cosa ha generato il problema?

June 27, 2022 at 10:16 am #11549189

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Prova a disattivare tutti i plugin (tranne WPML) e il tema e verifica se è visbile.
Aggiungendo un altro selettore nel menù o nel footer si vede?

June 29, 2022 at 9:19 am #11565443

martinaB-19

Ho fatto come indicato e non è cambiato nulla.
Su questo sottodominio sono installati solo plugin di WPML.
La pagina non ha un menù è una landing page, non ha nemmeno un footer.
Può accedere direttamente al backend e verificare dov'è il problema?Non vorrei dover rifare la procedura di configurazione altre volte.

June 30, 2022 at 10:34 am #11574909

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Dalle informazioni di debug si vede che non ci sono solo i plugin di WPML. Hai cambiato il tema con uno di default? Se funziona con tema della serie Twenty Twenty non è un problema che possiamo risolvere.

Io posso accedere al sito ma posso già dirti che non sono in grado di dirti dov'è il problema - sempre ammesso che non sia un problema di codice custom - perché non rientra nelle mie competenze, eventualmente è qualcosa da inviare al secondo livello. Avrò comunque bisogno di disattivare plugin e tema per fare dei test.

June 30, 2022 at 5:12 pm #11579537

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Il codice dello switcher dove dovrebbe essere? In function.php non c'è, senza il codice come fa ad apparire?

Non è che avete aggiornato il tema ed è stato sovrascritto? Tutte le modifiche apportate a temi e plugin vengono cancellate dopo gli aggiornamenti, è per questo che nel tutorial scriviamo di utilizzare un tema figlio.

Puoi riaggiungere il codice e vedere se funziona?