This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.55 hours from now. Thank you for your understanding.

This topic contains 4 risposte, has 2 voci.

Last updated by Alejandro 2 settimane, 5 giorni fa.

Assigned support staff: Alejandro.

Autore Post
October 3, 2019 at 2:08 pm #4688535

gianfrancoF-3

Abbiamo un sito e-commerce per un cliente (WordPress + WooCommerce) nel quale gestiamo le lingue con WPML (e quindi anche Woocommerce Multilingual) e nel quale abbiamo installato WooCommerce Smart Coupons per la gestione delle gift cards.

Abbiamo notato oggi uno strano comportamento in fase di checkout.

Come si nota nell'immagine allegata quando viene utilizzata una gift card in fase di checkout il totale del carrello viene correttamente aggiornato ma quando si sceglie di pagare con carta di credito e si atterra sulla pagina del gateway di pagamento il totale non risulta più decurtato del valore della gift card.

Abbiamo fatto un po' di test ed abbiamo scoperto che se disattiviamo WooCommerce Multilingual tutto funziona perfettamente e nel gateway di pagamento il totale è corretto (quindi con lo sconto applicato).

Abbiamo fatto una prova anche con il tema Twenty-Ninteen e il problema si presenta ugualmente.

Come vedrete nelle informazioni di debug il sito è completamente aggiornato come anche tutti i plugin utilizzati.

Potete aiutarci a risolvere il problema?

Grazie mille

October 3, 2019 at 6:13 pm #4690647

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Proviamo a fare 2 cose:

1) Vai su wp-content/plugins/woocommerce-multilingual/inc/class-wcml-orders.php
e trova questa riga:

        add_action('updated_post_meta', array($this,'update_order_currency'), 100,4);

cambiala per

        //add_action('updated_post_meta', array($this,'update_order_currency'), 100,4);

e vedi se per caso il problema continua.

Se continua, allora ti chiedo gentilmente di

2) caricare il plugin qui: hidden link

e poi prova a riprodurre il problema anche lì.

Inoltre, ti chiedo di scrivere qui i passi per poter riprodurre il problema visto che mi sarà richiesto al momento d'inviare questo caso al nostro team di compatibilità.

Saluti.

October 4, 2019 at 8:19 am #4693897

gianfrancoF-3

Grazie Alejandro,
ho provato quanto indicato al punto 1 ma il problema persiste.

Ho caricato al sito indicato il plugin per smart coupon, ho generato alcuni coupon per poter fare i test e anche lì ho potuto verificare il problema.

Gli step per replicarlo sono i seguenti:
- mettere un prodotto nel carrello (es: Hoodie with Logo - 45$)
- entrare nel carrello e passare al checkout
- nel campo apposito inserire un codice coupon per ottenere lo sconto (es: 91vu5gn49sfot - 10$)
- il totale del checkout viene aggiornato con lo sconto del coupon (es: diventa 35$)
- procedere con il pagamento
- nella pagina di conferma dell'ordine è indicato come totale 45$ anzichè 35$

In woocommerce > orders potete verificare il mio ordine che di fatto mostra l'utilizzo di un coupon (nell'area dei totali sulla sinistra) ma mostra un importo totale di 45$ anzichè 35$

Per contro in woocommerce > coupons vedere che la giftcard utilizzata è stata portata a 0 in quanto risulta utilizzata per l'ordine in questione.

Spero di avere dettagliato tutto nel miglior modo possibile.
Se servono ulteriori informazioni non esitate a chiedere.

Grazie ancora

October 4, 2019 at 10:54 am #4694989

gianfrancoF-3

Ciao Alejandro,
abbiamo risolto il problema!

Avevamo mandato una segnalazione anche al supporto di Smart Coupons perchè non eravamo certi di dove fosse il problema ed è saltato fuori che si risolveva con una configurazione sul loro plugin.
In particolare, se potesse interessarti, la soluzione è questa:
1. Go to WooCommerce > Settings > Smart Coupons
2. Look for the setting "Apply before tax", enable this setting
3. Now check whether the issue is resolved or not

Mi spiace avervi disturbato per niente.

Grazie comunque del supporto.

October 4, 2019 at 3:07 pm #4696825

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Bellissimo (e non è stato un disturbo, per niente, figurati)!

Grazie mille per aver condiviso con noi come si risolve il problema! sono sicuro che tanti dei nostri lettori ve ne saranno grati!

Saluti.