This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.98 hours from now. Thank you for your understanding.

Etichettato: 

This topic contains 9 risposte, has 3 voci.

Last updated by fabrizioT-4 1 anno fa.

Assigned support staff: Vincenzo.

Autore Post
September 25, 2018 at 8:57 am #2763073

fabrizioT-4

Hello,
i have some problem with the new custom attributes added as “dropdown selection” data in the development tab of WP Property.
It seems that slugs of attributes area displayed instead of the values in the property single page.

I have the last version of wp-property and the problem exist using both the default property.php and a custom page.

I noticed that if i deactivate WPML Multilingual CMS the problem is solved.

Do you have any suggestion?
Thank you in advance

Gianluca

September 26, 2018 at 11:45 am #2767021

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

Sembra si tratti di un problema di compatibilità con la nuova versione del tema.

Prima di passare questo ticket al nostro Compatibility team, è necessario riprodurre il problema su un'installazione nuova di WordPress, usando i file del tema senza alcuna modifica.

Questo è il link ad un'installazione nuova di WordPress creata appositamente:
hidden link

Cliccando sul link il login avverrà automaticamente.

Puoi riprodurre il problema su questa installazione e mandarmi una lista dettagliata dei passaggi necessari per riprodurre e verificare il problema?

Grazie

September 26, 2018 at 1:14 pm #2767417

fabrizioT-4

Salve Vincenzo, grazie per il rapido supporto.
Ho replicato il problema nell'installazione da lei fornita e ne ho riscontrato il problema segnalato.
Questi i passaggi da me svolti per riprodurre il problema:
1. Aggiunta ed attivazione del plugin Wp-Property (2.3.6), scaricabile anche dal sito dello sviluppatore (hidden link)
2. Aggiunta di un attributo personalizzato seguendo i passaggi sotto indicati.
Menù WP > Properties > Settings > Tab "Developer" > Attributes > Aggiunta di una riga (ad esempio "contratto" con check su "searchable", search imput di tipo dropdown selection, data entry di tipo "dropdown selection" con aggiunta di almeno 2 valori testuali separati da virgola (uno per riga).

Nel test da me eseguito, sulla pagina hidden link si vede il campo contratto che riporta il medesimo slug "contratto" (e non il valore "vendita" come da inserito in area admin).

Rimanendo in attesa di un vostro cenno vi saluto cordialmente

September 28, 2018 at 10:11 am #2773208

fabrizioT-4

Buongiorno Vincenzo,
avete potuto verificare il problema segnalato?
Grazie

September 28, 2018 at 11:27 am #2773529

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno Gianluca,

grazie per i dettagli.

Sono riuscito a riprodurre il problema ed ho inoltrato tutti i dettagli, e la copia del sito, al nostro Compatibility Team.

Aggiornerò questo ticket non appena avrò novità. Nel frattempo, per accelerare il processo, potresti contattare anche il supporto del plugin chiedendogli di mettersi in contatto con noi per risolvere il problema insieme.

Grazie per la pazienza

September 28, 2018 at 3:01 pm #2774274

UsabilityDynamics

Hello, All.

The team of WP-Property is also working on that issue. Please let us know your comments in this issue - hidden link

Thanks

September 28, 2018 at 5:27 pm #2774516

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello Maria,

I added your link to our internal ticket and informed the Compatibility team about your message.

Thank you

October 1, 2018 at 3:29 pm #2778642

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno Gianluca,

sembra che il team di WP-Property abbia trovato una soluzione al problema:
hidden link

Il nostro Compatibility team ha provato la soluzione e sembra funzionare.

Puoi provare ad effettuare la modifica al file indicato e verificare se il problema si risolve?

Fammi sapere se hai bisogno di maggiori informazioni sull'applicazione della soluzione.

Grazie

October 2, 2018 at 5:38 am #2780354

fabrizioT-4

Buongiorno Vincenzo,

ho apportato la modifica al file indicato ed ora sembra funzionare tutto correttamente.
Grazie ancora per l'ottimo supporto (e grazie al team di WP-Property).

Buona giornata
Gianluca

October 2, 2018 at 5:39 am #2780355

fabrizioT-4

My issue is resolved now. Thank you!