This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.90 hours from now. Thank you for your understanding.

This topic contains 16 risposte, has 2 voci.

Last updated by Diego Pereira 6 mesi, 3 settimane fa.

Assigned support staff: Diego Pereira.

Autore Post
March 16, 2019 at 12:25 pm #3360233

massimilianoA-4

Hello there.

I post and article in english (main lang) with links to a product.
When I trasnlate the post, now wpml doesn't "translate" (I dunno how to say properly) the link anymore. Before, it used to, automatically, link to the product of the same language (in the french the link to the french product, italian to the italian product etc.. Now, all the links in the other languages link always to the english product. And this is new, it's happening after the update of the new version of wpml and addons.

Any idea?
Thanks a lot
best regards

March 16, 2019 at 7:13 pm #3361331

Diego Pereira
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Portoghese, Brasile (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @massimilianoa-4, welcome to the WPML support Forum!

Do you have the WPML Sticky links extension? If not, please download from here and install on your website: https://wpml.org/it/account/downloads/

After that, go to the edit screen of the page, do a small modification and save. Then update the translation.

Please let me know if it worked for you.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.
NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

All the best,
Diego

March 17, 2019 at 10:24 am #3363139

massimilianoA-4

Hello there!
sorry to say the plugin didn't work. The problem was not broken links.
I just pasted the debug information up here.
hope it helps
thanks a lot

March 18, 2019 at 7:13 pm #3372601

Diego Pereira
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Portoghese, Brasile (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I sent some instructions to replicate the website through a private message (previous answer).

Please let me know if it worked for you. If so, please send us clear instructions on how to see/reproduce the issue.

Kind regards,
Diego

March 18, 2019 at 9:49 pm #3373693

massimilianoA-4

Ok cool!
thanks a lot
I will do everything tomorrow
I will let you know when it's done.
thanks

March 19, 2019 at 4:45 pm #3381581

Diego Pereira
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Portoghese, Brasile (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks, please let me know if it worked.

Kind regards,
Diego

March 19, 2019 at 5:36 pm #3382027
massimilianoA-4

hello Diego.
I did the migration, everything seemed ok. the site is thebridgebio.com
I prepared for you 2 posts in draft:

- the post PROVA: you will see that I put in single image (product pack and label LEARN MORE) the custom links to the product in english (which is QUINOA DRINK). I tried to traslate it in french (you will find the traslation in french in draft) and if you click the images, the link is still to the english product. Before updating to the last wpml, I didnt have to touch the links, they just re-direct bythemselves to the product in french, italian, etc...once I translated the posts. not anymore.

-post PROVA2: another issue, after updating to the last version of wpml, I used to use the image packs in the size 600x570px and set MEDIUM in single image row. and it worked beautifully (as you can see in all the posts recipes in the blog); now, the very same images, I f I set MEDIUM, they are huge. But it happens only with images pack with 600x570px size.

Thanks a lot

I nuovi thread creati da Diego Pereira e collegati a questo sono elencati di seguito:

https://wpml.org/it/forums/topic/split-wpml-doesnt-translate-the-link-anymore/

March 20, 2019 at 4:35 pm #3390723

Diego Pereira
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Portoghese, Brasile (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

It seems that the link of the iamge shortcode is not registered for translation. Please add the following code to WPML > Settings > Custom XML Configuration:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>vc_single_image</tag>
            <attributes>
                <attribute encoding="allow_html_tags">title</attribute>
                <attribute type="media-ids">image</attribute>
                <attribute type="link" encoding="vc_link">link</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>				

After that do a small modification on the post content (original language), save, then update the translation.

It worked on the test site: hidden link

Please let me know if it worked for you.

Regarding the issue #2, I will open a new ticket for this new issue. I will reply in the new ticket

Kind regards,
Diego

March 21, 2019 at 10:22 am #3398005

massimilianoA-4

ok thanks.
I will try the code.

Sorry but in the test site I only see the post in english. I dont see it in other languages...
thanks

March 21, 2019 at 3:29 pm #3409855

massimilianoA-4

Hello there.
I did what you told me:
- I pasted the code in custom xml
- I made a small change in post PROVA.
- I updated the french translation and the screenshots 1263 and 1264 are the risults. the 1264 is the screenshot in the french post, after I updated the translation.
Then I did differently:
- I cancelled the code
- I re-pasted the code
- I did a new post called PROVA3
- I translated it in french.
Results: no more weird links but anyway it didnt change anything. still the image of the french post links to the english product.

I noticed something else, I dunno if it could be useful: when I click in visual composer single image settings "ON CLICK ACTION --> OPEN CUSTOM LINK" automatically shows http in image link and not anymore https like it used to do before. (see screenshot attached. I dunno if it could be linked.) Obviously, I cancel it and I paste the link I need with https but I thought to mention this detail.
It s really strange this is working in your side. could you leave the post translated in the migrated site, cause you told me this code worked but I can only see the post in english in the test site.

Could it be something related to the permalinks settings? I didn't set this website, it was another web designer so when I "inherited" it, I simply left the way it was, I didnt change anything.
It seems just very strange that only updating a plugin which used to work beautifully can cause such a thing.
Thanks

March 21, 2019 at 9:03 pm #3423297

Diego Pereira
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Portoghese, Brasile (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

That's odd because it worked on the test site. This is the link: hidden link

Could you send us access to your WordPress dashboard (website URL, login and password) and a link to a post that I can use to test? - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.

Kind regards,
Diego

March 22, 2019 at 9:52 am #3438923

massimilianoA-4

sorry, but the link you sent me is to the preview of the post, as you can see in the url (the part p=15057). if you send me the link to a preview, it's normal I see this: see screenshot.
Can you send me the link to the french post published?Otherwise I will never see....

March 22, 2019 at 10:05 am #3439007

massimilianoA-4

sorry, could you send me again the private answer option, so I send you the admin and pass of a site test similar to the live site? thanks

March 22, 2019 at 3:39 pm #3442025

Diego Pereira
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Portoghese, Brasile (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Sure, I enabled the private field. Please let me know if it worked.

Kind regards,
Diego

March 24, 2019 at 7:28 pm #3449035

Diego Pereira
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Portoghese, Brasile (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. I made a small adustment at the XML code:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>vc_single_image</tag>
            <attributes>
                <attribute encoding="allow_html_tags">title</attribute>
                <attribute type="media-ids">image</attribute>
                <attribute type="link">link</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>     

I added the code to WPML > Settings > Custom XML Configuration, did a small modification on the page content (original language), then updated/published the FR translation. Now the link is working as expected:
- hidden link
- hidden link

Please let me know if ti worked for you.

Kind regards,
Diego