Este é o fórum de suporte técnico para o WPML, o plugin para WordPress multilíngue.

Qualquer um pode ler, mas apenas clientes do WPML podem postar aqui. A equipe do WPML responde no fórum 6 dias por semana, 22 horas por dia.

Nenhum atendente de suporte está disponível para trabalhar hoje no fórum Portuguese. Fique à vontade para abrir tickets e iremos tratar deles assim que estivermos online. Obrigado pela compreensão.

This topic contains 18 respostas, has 2 vozes.

Last updated by Diego Pereira 7 meses atrás.

Assigned support staff: Diego Pereira.

Autor Posts
março 19, 2019 às 6:06 pm #3382333

VH FP

Diego, e o problema do checkout (em portugues) conseguiste perceber o que era?
"2. Quando faço uma reserva em PT, no "cart" aparece o valor certo, e no "checkout" o valor aparece errado. Muito estranho. Nas outras linguas aparentemente parece-me ok.
(ver imagens em anexo: "no cart aparece assim (PT)" "no checkout aparece assim (PT)"
"
Abraço

março 19, 2019 às 6:09 pm #3382337

Diego Pereira
Supporter

Languages: Inglês (English ) Espanhol (Español ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá, como este é um problema diferente do original, criei este novo ticket.

Eu fiz um teste na cópia do website, neste produto: hidden link

No meu teste ele funcionou normalmente. Você poderia verificar se o mesmo problema ocorre neste site de testes e em qual produto? Eu irei verificar.

Atenciosamente,
Diego

março 19, 2019 às 6:55 pm #3382805

VH FP

Boas Diego, na tua cópia esse erro nao acontece realmente.
Mas no original acontece.
Vi o teu print mas não é ai que acontece, é no checkout hidden link
carbooking.com/pt-pt/checkout/

Vai ao site e faz uma simulação, tenta não passar do checkout(ou seja, tenta só nao confirmar a reserva). O valor altera-se para o valor de um dia apenas. repara na imagem anexo sff

Abraço

março 19, 2019 às 7:28 pm #3383041

VH FP

Diego, aqui vai a ocorrência em video: hidden link

Abraço

março 20, 2019 às 6:44 pm #3392597

Diego Pereira
Supporter

Languages: Inglês (English ) Espanhol (Español ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Aparentemente o tema está desatualizado no test site (e provavelmente no seu website também). Você poderia atualiza-lo para a versão mais recente e ver se o problema continua? Talvez o desenvolvedor já tenha solucionado na nova versão.

Caso o problema persista, por favor nos envie a ultima versão do tema para que possamos verificar o código.

Atenciosamente,
Diego

março 20, 2019 às 7:58 pm #3393059

VH FP

Boas Diego, não vou atualizar ainda porque pode não ser necessário, e pode dar para o torto.
"You have version 1.6.5 installed. Update to 1.6.6."
Podes testar na versao testes?
tema tá aqui : hidden link

Abraço

março 21, 2019 às 6:45 pm #3417783

Diego Pereira
Supporter

Languages: Inglês (English ) Espanhol (Español ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Atualizei o tema no site de testes, você poderia testar?
hidden link

Porém, como o problema já não ocorria nesta cópia de testes, seria legal testar em seu website. Recomendo fazer um backup e caso ocorra algum problema, restaura-lo.

Atenciosamente,
Diego

março 22, 2019 às 1:57 pm #3440899

VH FP

Boas amigo, fiz o que pediste, atualizei o tema e tudo o resto e o problema no PT mantem-se.
Isto só acontece no PT, muito estranho!

Abraço

março 25, 2019 às 3:18 pm #3455383

Diego Pereira
Supporter

Languages: Inglês (English ) Espanhol (Español ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Como o tema utiliza AJAX para fazer o checkout, acredito que possa estar relacionado. Eu encaminhei este ticket para nossa equipe de compatibilidade para que eles possam analisar o código do checkout. Te enviaremos um feedback em breve.

Atenciosamente,
Diego

março 25, 2019 às 3:23 pm #3455399

VH FP

Ok amigo Diego. Mete como prioritário sff pois isso está a originar dúvidas nos clientes.
Abraço

abril 3, 2019 às 6:16 pm #3529651

Diego Pereira
Supporter

Languages: Inglês (English ) Espanhol (Español ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá Vitor,

Nossa equipe fez a verificação e não conseguiu reproduzir o problema. Eu também fiz um teste no site original e o preço funcionou normalmente.

Como o problema não ocorre em nosso servidor, acreditamos que talvez o problema esteja relacionado com o cache. nossa sugestão é entrar em contato com o hosting e pedir para desabilitar os caches de servidor.

Por favor também ative a opção "Language filtering for AJAX operations" em WPML > Languages > Language filtering for AJAX operations. Este cookie é importante para que as operações AJAX funcionem corretamente.

Atenciosamente,
Diego

abril 4, 2019 às 12:45 am #3531011

VH FP

Boas amigo Diego,
isto não é problema do host, pois o problema só acontece na versão em portugues. O francês e o inglês estão ok.

Já ativei a opção que me disseste mas infelizmente não vi qualquer diferença.
O Problema também duvido que seja das caches do servidor pois por acaso nem ativei a cache no php neste site (em outros sites por acaso tenho).

" Eu também fiz um teste no site original e o preço funcionou normalmente." Testaste no meu site original? impossível, eu já testei em vários PC's, em vários dispositivos, em várias internets e acontece sempre este erro lol

Tem que haver alguma explicação lógica para isto só me acontecer na versão em Português 🙁

Abraço amigo

abril 4, 2019 às 12:46 am #3531013

VH FP

Aqui está o que tenho selecionado no php

Abraço diego

abril 4, 2019 às 12:57 am #3531071

VH FP

Amigo, de qualquer das formas mandei agora email ao suporte do Host.

Abraço

abril 5, 2019 às 2:18 pm #3544967

VH FP

Amigo Diego,
Reparei agora em mais um pormenor que vos pode ajudar a solucionar este problema,
no checkout quando eu altero os dados (nome, morada etc) ele volta a colocar o preço certo.
Se habilitares o campo privado poderei mandar um video a mostrar.

Abraço