Este é o fórum de suporte técnico para o WPML, o plugin para WordPress multilíngue.

Qualquer um pode ler, mas apenas clientes do WPML podem postar aqui. A equipe do WPML responde no fórum 6 dias por semana, 22 horas por dia.

Our next available supporter will start replying to tickets in about 4.20 hours from now. Thank you for your understanding.

This topic contains 7 respostas, has 2 vozes.

Last updated by pabloZ-2 4 meses, 3 semanas atrás.

Assigned support staff: Bruno.

Autor Posts
maio 27, 2019 às 2:19 pm

pabloZ-2

Estou tentando: Ativar o plugin WPML Multilingual CMS

Link de uma página em que o problema pode ser visto: o erro acontece na página de administração de plugins.

Espero ver: Espero que o plugin seja ativado corretamente.

Em vez disso, o que acontece é: Fatal error: COLLATION 'utf8_general_ci' is not valid for CHARACTER SET 'utf8mb4' in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/sitepress-multilingual-cms/inc/setup/sitepress-schema.php on line 359

Não consigo fornecer informações de depuração pois o plugin não é ativado.

maio 27, 2019 às 9:34 pm #3901107

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Obrigado por nos contactar. Por favor, você poderia verificar qual é a versão do PHP e do MySQL que você está usando?

Também, qual é a versão do WordPress e WPML que você está usando? Por favor, verifique se você estiver usando a versão mais recente do WPML olhando na nossa página de downloads: https://wpml.org/account/downloads/.

Se você estiver usando uma versão mais antiga, por favor, remova-a e faça o download da versão mais recente.

Obrigado.

maio 28, 2019 às 11:57 am #3906469

pabloZ-2

Bom dia,

Segue as informações:
PHP: 7.2.13
MySQL: 8.0.13
WordPress: 5.2.1
WPML: 4.2.6

maio 29, 2019 às 4:56 am #3911735

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Obrigado. Para que eu possa verificar o seu banco de dados, por favor, eu poderia instalar o plugin Adminer?

Com o plugin Adminer eu posso olhar no banco de dados para saber se existe alguma inconsistência.

Obrigado.

maio 29, 2019 às 4:27 pm #3917383

pabloZ-2

Pode instalar sim, fique a vontade.

maio 30, 2019 às 12:47 am #3919239

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Obrigado. Isso parece que está acontecendo de fato por algumas inconsistencias no seu banco de dados. Eu vou anexar uma imagem para você ver.

Provavelmente o problema está acontecendo porque algumas das duas tabelas - incluindo o wp_posts está com um collation incorreto.

Eu tentei alterar isso diretamente pelo Adminer, mas eu não fui capaz de alterar porque aparece uma mensagem de erro.

Por favor, você poderia contactar o seu host e pedir para que eles alterem o collation da tabela wp_posts para "utf8mb4_unicode_ci" e depois tentar novamente ativar o WPML e verificar se o problema ainda persiste?

Obrigado.

maio 30, 2019 às 12:30 pm #3922921

pabloZ-2

Bom dia,

Eu alterei o collation de todas as tabelas que estavam diferentes e o plugin foi ativado corretamente.

Obrigado pela ajuda.

maio 30, 2019 às 12:31 pm #3922925

pabloZ-2

My issue is resolved now. Thank you!