Este é o fórum de suporte técnico para o WPML, o plugin para WordPress multilíngue.

Qualquer um pode ler, mas apenas clientes do WPML podem postar aqui. A equipe do WPML responde no fórum 6 dias por semana, 22 horas por dia.

Our next available supporter will start replying to tickets in about 7.41 hours from now. Thank you for your understanding.

Marcado: 

This topic contains 8 respostas, has 2 vozes.

Last updated by Bruno 2 anos, 3 meses atrás.

Assigned support staff: Bruno.

Autor Posts
julho 26, 2017 às 12:07 pm #1327515

Softexpert software S.A.

adicionei outro idioma em meu site, mas ainda nao tenho um dominio disponível para ele. quando configurei o idioma estava conseguindo fazer posts nele, mas não conseguia visualizá-los. depois usei uma url que foi criada internamente na minha empresa para homologação, mas a mesma apresentou alguns problemas e fez com que o admin do idioma não funcionasse mais. existe alguma maneira de voltar pra a configuração anterior para que eu possa continuar criando os posts? obrigada.

julho 26, 2017 às 12:18 pm #1327530

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Obrigado por nos contactar.

Isso depende de como o seu site está configurando e como os posts estão sendo criados. Pelo que eu entendi, como você ainda não configurou o segundo domínio, talvez a única forma de visualizar esses posts seja enquanto o post esteja como rascunho ("draft").

Dessa forma o WordPress ainda não vai ter gerado uma URL para o post e você deveria conseguir visualizar o conteúdo.

Sobre o problema interno, eu não estou certo o porque não está funcionando agora. Alguma mensagem de erro está sendo exibida? Por favor, você poderia me dizer mais detalhes quais os passos que você está seguindo e qual erro está acontecendo?

Obrigado.

julho 26, 2017 às 12:30 pm #1327538

Softexpert software S.A.

minhas urls estao setadas como no print, quando clico para editar o post aparece uma mensagem de erro

Esta página não está funcionando

Redirecionamento em excesso por softexpert.com.br

porém quando eu habilitei o plugin eu conseguia editar os posts, tem alguma url interna de vocês para configurar?

julho 26, 2017 às 12:54 pm #1327559

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Obrigado pela screenshot. É necessário ver o porque esse redirecionamento está sendo feito na página de edição. Apenas para ter certeza, você está usando o editor interno do WordPress para fazer essas edições?

Por favor, como teste você poderia desativar todos os plugins diferentes do WPML e alternar para o tema padrão apenas para ver se o problema persiste?

Obrigado.

julho 26, 2017 às 12:59 pm #1327572

Softexpert software S.A.

Sim, estou usando o admin para fazer as publicações. Infelizmente não posso alterar o tema nem desativar os outros plugins para testar. tem alguma outra maneira?

julho 26, 2017 às 2:08 pm #1327651

Softexpert software S.A.

eu só preciso voltar pra url padrão que o plugin cria, vi que era de.(minha url), mas quando coloco isso tenho erro de DNS, acredito que algum cache ou alguma configuração no banco que esteja registrando isso. pode me auxiliar? nao posso desabilitar o plugin nem limpar banco, pois esse é meu site em produção já

julho 26, 2017 às 2:20 pm #1327673

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Certo. Então anteriormente você estava usando um subdomínio.

Se você tenta configurar o subdomínio de.seu-site.com e isso não funciona, provavelmente é porque foi removido diretamente do seu servidor ou o DNS não está configurado corretamente.

Você deveria criar novamente um subdomínio - ou verificar se ele ainda está criado, e configurar novamente o DNS para que o subdomínio de.seu-site.com volte a funcionar. Depois você deverá configurar isso no WPML.

Note que antes de configurar isso no WPML, isso deve estar configurado corretamente no seu servidor e no DNS.

Por favor, verifique se o subdomínio está criado e se o DNS está configurado corretamente. Se você não souber como fazer isso você deveria contactar o seu host.

Após seguir esses passos, por favor, deixe-me saber se o problema persiste.

Obrigado.

julho 26, 2017 às 7:10 pm #1327951

Softexpert software S.A.

oi, foi criado o subdominio, agora quando clico para editar ele redireciona para a home br

julho 26, 2017 às 7:35 pm #1327966

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Você deve criar o subdomínio sem usar o recurso de redirecionamento. Basicamente esse subdomínio deve ser um alias do idioma principal.

No momento em que você está criando o subdomínio você deve usar o mesmo diretório da instalação padrão do WordPress, de forma que, acessando o subdomínio seja carregada a tela do idioma padrão sem redirecionamentos.

Note que dependendo da sua hospedagem, além de criar o subdomínio você deve configurar o DNS também. Você pode ver um passo a passo na nossa documentação: https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Depois é só configurar o WPML para usar esse subdomínio.

Obrigado.