Este é o fórum de suporte técnico para o WPML, o plugin para WordPress multilíngue.

Qualquer um pode ler, mas apenas clientes do WPML podem postar aqui. A equipe do WPML responde no fórum 6 dias por semana, 22 horas por dia.

Nenhum atendente de suporte está disponível para trabalhar hoje no fórum Portuguese. Fique à vontade para abrir tickets e iremos tratar deles assim que estivermos online. Obrigado pela compreensão.

This topic contains 4 respostas, has 2 vozes.

Last updated by Marcos Vinicios Barreto 4 meses, 2 semanas atrás.

Assigned support staff: Marcos Vinicios Barreto.

Autor Posts
junho 6, 2019 às 4:13 pm

growingoldU

Estou tentando:

Link de uma página em que o problema pode ser visto:

Espero ver:

Em vez disso, o que acontece é:
I´ve installed WPML on my website and I´m having an issue related to the content in the Portuguese version (see image). What´s happening, is that some specific Portuguese characters get substituted by this no-related characters, like in the picture. How can I solve this?

Thank you.

junho 7, 2019 às 1:09 am #3972595

Marcos Vinicios Barreto
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It seems there's some sort of encoding in your database. Please, try the following:

1 - In the wp-config.php file of your WordPress installation, place the code below:

define('DB_CHARSET', 'utf8');

2 - Temporary disable the WPML related plugins from your WordPress Dashboard > Plugins settings.

3 - Open the page where you see the encoding issues and see if the issue is fixed, if so, activate the WPML related plugins again.

Please, let me know if it helps. Have a nice day.

junho 7, 2019 às 1:12 am #3972597

Marcos Vinicios Barreto
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Bahia (GMT-03:00)

Ticket Status Update.

junho 7, 2019 às 9:56 am #3975455

growingoldU

Eu alterei o código no ficheiro wp-config.php mas continuo com o mesmo problema.

Isto aconteceu depois de fazer migração do site para um novo domínio. No wp-config.php aparecia `ut8mb4´e alterei para utf8. Mas sempre que faço uma atualização dos conteúdos das páginas, tudo o que é cedilhado e acentuado, assume este charset estranho.

junho 7, 2019 às 6:09 pm #3978381

Marcos Vinicios Barreto
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Bahia (GMT-03:00)

Olá,

Obrigado pelos detalhes. Eu gostaria de acessar os seus arquivos via FTP para dar uma olhada mais detalhada nesse problema. Pra isso, eu gentilmente peço que nos forneça algum acesso FTP para que possamos prosseguir com o nossos esforços em fornecer uma solução. Uma reposta privada está habilidade para que você possa fornecer esses detalhes com segurança. Por favor, não se esqueça de mencionar os detalhes de como podemos replicar esse erro no seu site. Tenha um ótimo dia!

O tópico ‘[Fechado] Issue with content on Portuguese Version’ está fechado para novas respostas.