Este é o fórum de suporte técnico para o WPML, o plugin para WordPress multilíngue.

Qualquer um pode ler, mas apenas clientes do WPML podem postar aqui. A equipe do WPML responde no fórum 6 dias por semana, 22 horas por dia.

This thread is resolved. Here is a description of the problem and solution.

Problema:
Depois de remover manualmente as tabelas do WPML diretamente no banco de dados, meu site não está funcionando corretamente.

Solução:
Como as tabelas foram removidas diretamente, será necessário remover as opções da instalação anterior do WPML. Para isso, siga os passos abaixo

Por favor, abra o seu gerenciador de banco de dados e na tabela _options ( por exemplo wp_options), faça a sequinte consulta:

SELECT * FROM `wp_options` WHERE `option_name` LIKE '%icl_%'

No exemplo acima, é usado o prefixo padrão do WordPress "wp_". Se você tiver alterado isso na instalação do WordPress, altere na linha de cima também.

Depois, remove os registros que forem encontrados.

Note: os passos acima devem ser seguindos apenas se você tiver removido as tabelas do WPML manualmente e se você já fez o backup do seu banco de dados.

This topic contains 29 respostas, has 2 vozes.

Last updated by Softexpert software S.A. 2 anos, 4 meses atrás.

Assigned support staff: Bruno.

Autor Posts
julho 20, 2017 às 2:35 pm #1323744

Softexpert software S.A.

Bom dia, comprei a licença do WPLM estou tentando configurar o mesmo, só que quando instalo ele, ele não cai na aba de configurações, vai direto para pagina do plugin e não da para adicionar idiomas, aparece tudo em branco.

julho 20, 2017 às 2:46 pm #1323765

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Obrigado por nos contactar.

Quando você vai ativa o WPML pela primeira vez, eu vou anexar uma imagem da tela esperada. Essa tela não é exibida para você?

Você está usando os requisitos mínimos do WPML, como por exemplo, a memória com mais de 128M? Você pode ver na nossa página de requisitos mínimos: https://wpml.org/home/minimum-requirements/

Se o problema persistir, apenas como um teste, por favor, você poderia desativar todos os plugins e ativar apenas o WPML para ver se o problema persiste?

Obrigado.

julho 20, 2017 às 2:56 pm #1323782

Softexpert software S.A.

Bom ele estava instalado, eu tive que remover por algumas questões, quando tirei tudo relacionado a ele, e instalei de novo, a tela ficou da seguinte forma, conforme o print. Detalhe não posso remover todos os plugins, está em meu site de produção.

julho 20, 2017 às 3:05 pm #1323795

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Obrigado pela screenshot. Por favor, siga os passos abaixo e veja se isso resolve o problema:

- Clique em WPML > Support > Troubleshooting
- Localize a seção "Clean up" e clique nesses botões:
-- Clear the cache in WPML
-- Remove ghost entries from the translation tables
-- Fix element_type collation
-- Set language information
-- Fix post type assignment for translations

Se o problema persistir, veja se o botão "Clear language information and repopulate languages" estiver disponível e clique-o. Note que é recomendado fazer um backup do seu banco de dados antes de de seguir esse passo.

Após seguir esses passos, por favor, deixe-me saber se o problema persiste.

Obrigado.

julho 20, 2017 às 4:52 pm #1323902

Softexpert software S.A.

É normal demorar para executar o Fixes the collation of the element_type column in icl_translations in case this setting changed for your posts.post_type column.?

julho 20, 2017 às 5:05 pm #1323922

Softexpert software S.A.

Esta quase meia hora carregando o topico Fix element_type collation e matou os posts, normal essa demora?

julho 20, 2017 às 5:11 pm #1323927

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Não. Quando você removeu o WPML isso pode ter, dependendo de como foi feito, corrompido o banco de dados.

Eu vou solicitar acesso temporário ( WP Admin e FTP ) para acessar o seu site - preferencialmente, se você tiver um site de testes, isso deveria ser melhor.

Você pode encontrar os campos necessários abaixo do campo de comentários, quando você se loga para deixar a sua próxima resposta. A informação vai estar em um campo privado e apenas você de eu podemos ver.

*** Faça o backup completo do seu sites antes de adicionar as suas credenciais.

Privacidade e Segurança ao fornecer informações de debug para suporte: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Obrigado.

julho 20, 2017 às 5:28 pm #1323939

Softexpert software S.A.

Quando acessar peço por gentileza que me deixe aqui uma reposta

julho 20, 2017 às 5:31 pm #1323943

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Eu vou acessar o seu site neste momento. Em breve eu vou contactar você.

Obrigado.

julho 20, 2017 às 5:33 pm #1323946

Softexpert software S.A.

Beleza, obrigado. Fico aguardando

julho 20, 2017 às 5:34 pm #1323950

Softexpert software S.A.

Amigo deu problema nos dados que te forneci para acessar wordpress, favor disponibilize para mim para lhe informar de forma privada novamente

julho 20, 2017 às 5:35 pm #1323952

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Quando eu tento usar as credenciais que você postou, aparece essa mensagem: ERROR: Invalid username. Lost your password?

Eu notei que na sua mensagem acima você usou o usuário como "SuporteWPLM", eu tentei com o "SuporteWPML" também, mas não funcionou. Aparece que o usuário é inválido.

Por favor, você poderia verificar? Você pode editar a sua mensagem acima, que deve estar destacada como privada.

Obrigado.

julho 20, 2017 às 5:38 pm #1323958

Softexpert software S.A.

Pronto, fiz o ajuste, da mesma forma quando conseguir entrar por favor pode dar um retorno? Fico no aguardo.

julho 20, 2017 às 5:40 pm #1323965

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Obrigado. As credenciais do WordPress estão funcionando. Agora eu consigo acessar o seu site. Em breve eu vou contactar você.

Obrigado.

julho 20, 2017 às 5:41 pm #1323969

Softexpert software S.A.

Fico no aguardo.