Este é o fórum de suporte técnico para o WPML, o plugin para WordPress multilíngue.

Qualquer um pode ler, mas apenas clientes do WPML podem postar aqui. A equipe do WPML responde no fórum 6 dias por semana, 22 horas por dia.

This topic contains 6 respostas, has 2 vozes.

Last updated by Marcos Vinicios Barreto 5 meses, 1 semana atrás.

Assigned support staff: Marcos Vinicios Barreto.

Autor Posts
maio 15, 2019 às 7:31 pm

luisH-3

I activate WPML but it is being deactivated automatically.
Can it be license problem?

Same problem at hidden link (same theme)

maio 16, 2019 às 1:06 am #3820753

Marcos Vinicios Barreto
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I took a detailed look in your website and noticed your WPML related plugins are properly activated and registered. Please, let me know the details of your request and if you still need any assistance from our side. Thank you for your collaboration, have a nice day.

maio 16, 2019 às 8:54 am #3823395

luisH-3

Thank you for your assistance.
Yes, plugin are ok, i know.
But for webpage visitor (hidden link) language selector is not there. Just get hidden. Same for hidden link. Why??

maio 16, 2019 às 5:00 pm #3828209

Marcos Vinicios Barreto
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look in your website frontend and noticed the language switcher is working properly as you can see from the attached screenshot. In your case it most likely happens due a cache in your browser, server or even your third party cache plugin. Please, make sure to clear any cache you might have in order to see your language switcher working. Please, let me know if you need any further help, have a nice day.

maio 16, 2019 às 5:46 pm #3828513

luisH-3

Hi
thank you once more..... but you are providing me basic answer, for basic users.. I have tried that, and also tried to deactivate all plugins. Besides that, i do have more websites (www.webfarus.com, for instance) with same cache plugins and no problem at all.
Can you please be more specific, technician, helpful?

Can you read portuguese?

Thank you

maio 16, 2019 às 6:08 pm #3828699

luisH-3

I have activated error log, then i will be sending error log file to you....
Thank you

maio 17, 2019 às 3:35 pm #3835769

Marcos Vinicios Barreto
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Let me try give you some more details, your had some issues with your language switcher not being displayed in your website, I took a look at both: hidden link and hidden link and noticed in both cases the language swithcer is being displayed properly, so we don't have this issue in our tests.

I saw you are using a cache plugin, in some cases when your browser serves a cached copy of the website in a state where you still didn't have the language switcher on place and this should be the cause of your apparent issue. This is why I asked you to disable any cache you might have either disabling your cache plugin from your WordPress > Plugins settings or cleaning all your browser cache.

I also recommend you to access the mentioned websites using another browser, internet connection and device. In short, I am not able to replicate your mentioned issues.

Yes, I speak portuguese, so you are free to keep the conversation in portuguese if you need. Please, let me know if you still need any additional clarifications. Have a nice day.