Este é o fórum de suporte técnico para o WPML, o plugin para WordPress multilíngue.

Qualquer um pode ler, mas apenas clientes do WPML podem postar aqui. A equipe do WPML responde no fórum 6 dias por semana, 22 horas por dia.

Nenhum atendente de suporte está disponível para trabalhar hoje no fórum Portuguese. Fique à vontade para abrir tickets e iremos tratar deles assim que estivermos online. Obrigado pela compreensão.

This topic contains 13 respostas, has 2 vozes.

Last updated by Bruno 1 mês, 2 semanas atrás.

Assigned support staff: Bruno.

Autor Posts
setembro 19, 2019 às 1:49 pm #4605667

José

Hello

I'm trying to translate de tags of a post as usual but tags are being displyed as numbers, despeite correctly translated o the taxonomy translation area.

example: these are the original tags in portuguese hidden link

and this is they are showing in english: hidden link
Also, when I go to the tags area I see this: hidden link (altought I can search and find all my text tags there too). I don´t know where these tags are coming.

This is only happening now. Previous posts are showing all tags correctly. I guess is related with the last update of your plugins that I made some days ago.

I can give you access to wp backend but not ftp. How can I share it with you safely?

Plese provide a fix, it´s urgent.
Thank you

setembro 20, 2019 às 1:04 am #4608541

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. Please try to follow the steps below:

- Backup your database
- Click on the WPML > Support > Troubleshooting
- Look for "Clean up" and click on the "Synchronize posts taxonomies"

This will sync the tags between languages. Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

setembro 20, 2019 às 12:30 pm #4612175

José

Hello,

Will I not get in trouble by doing that? I may have different tags for different languages on some posts?

Thanks

setembro 20, 2019 às 11:29 pm #4614499

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

This will sync the tags between languages. If you have different tags for each language, then it would not be recommended to use this approach.

In this case, I should suggest that you access the translated content directly in the backend and then see how the tags are being displayed.

That is, at the back end, go to the secondary language page with the incorrect tags and see if you can remove them and then add the correct tags.

Note: these number tags may have been created using some tag generation plugin. Normally WordPress doesn't require a tag, so for those tags, I believe they were created either using some plugin for it or even through some import.

Thank you.

setembro 21, 2019 às 9:32 am #4615695

José

Hello,

"That is, at the back end, go to the secondary language page with the incorrect tags and see if you can remove them and then add the correct tags."

This was the first thing I tried, before contacting WPML. I can change the tags but when I click save they revert to displaying numbers both on backend and frontend. You can see the problem live on the different translations of this post: hidden link

The tags added were the same: translations of the tags added in the portuguese version.
Older posts don´t have the problem. This issue started after updating WPML plugins. I'm not using any tag generating plugin.

Can you please have look at the backend? I'm sure this would be solved much faster... I can share the details.
Thank you

setembro 23, 2019 às 1:45 pm #4624659

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sure. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

setembro 24, 2019 às 1:04 pm #4631785

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. This seems to be a compatibility issue with "The7 WPBakery Page Builder". After disabling this plugin the tags were saved correctly.

I will contact 2nd tier support so they can see. This may be some other configuration issue. As soon as they respond I'll keep you updated.

Thank you.

setembro 25, 2019 às 11:19 am #4638173

José

Hello, I need help here...
I need to create new post but can´t having the tags displaying like this.....

thanks

setembro 25, 2019 às 2:25 pm #4639889

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

As I explained above, this seems to be a compatibility or configuration issue and I am contacting 2nd tier support.

You can currently disable the "The7 WPBakery Page Builder" or "WPML Media" and check if the tags will be displayed correctly. As soon as 2nd tier support verifies this, I will contact you.

Thank you.

setembro 26, 2019 às 4:26 pm #4648873

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Our compatibility team has encountered the issue and is suggesting the workaround:

Please, open the wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-create-post-helper.class.php on line 24, replace these lines:

public function insert_post( array $postarr, $lang = null, $wp_error = false ) {
		$current_language = null;
		$postarr          = wp_slash( $postarr );

with these lines

public function insert_post( array $postarr, $lang = null, $wp_error = false ) {
		$current_language = null;
		if (! $postarr["tags_input"]){
					$postarr = wp_slash( $postarr );
		}

After changing these lines, save and upload the file via your FTP. Note that this is a bug and has been reported to our developers and the above lines are the workaround for this to work correctly while the definitive fix is added in a future version of WPML.

Thank you.

setembro 26, 2019 às 4:30 pm #4648899

José

Hello,

When the definitive fix is added to WPML will I have to remove the code you're giving me know or will not be necessary?

Thanks

setembro 26, 2019 às 4:38 pm #4649039

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

It will not be necessary. Please note that this will be added in a future version of WPML and in a future release, this code will already be added and you only need to update WPML normally.

Thank you.

setembro 30, 2019 às 1:33 pm #4664875

José

Ok, it's working, thanks.
Can I now delete all the dozens of "number tags" that were created? hidden link

thank you

setembro 30, 2019 às 2:25 pm #4665261

Bruno
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Glad to hear that it now works. Yes, you can remove tags that you are not using and that may have been created incorrectly.

Thank you.