0

WPML 4.3, which will go live in 2-3 months, will use PHP features that only appear in version 5.6 and above. Since WordPress also requires PHP 5.6+, this practically doesn’t mean much to most websites.

PHP older than 5.6 is pretty ancient. In fact, PHP 5.6 is ancient too and so is PHP 7.0. As you can see in the PHP active versions, PHP 7.1 is already in «security fixes only» and active development is going into newer versions.

Supported PHP versions

Modern WordPress hosts will always be using the recent PHP versions. This makes your site run fastest and most secure.

How to test which PHP version my sites are using

If you’re not sure what version of PHP your host is offering, use the phpinfo() function. See how to check it in our minimum requirements page.

How to upgrade to modern PHP

If you discover that any of your sites are still on versions of PHP prior to 7, we recommend that you contact your host and ask for a PHP upgrade. In most cases, it’s a matter of simple configuration. Almost all hosts already have the latest version of PHP installed. They will gladly switch you over.

If your host insists on running ancient PHP versions, consider moving to one of the hosting companies that we recommend (no affiliate links, just good recommendations).

Questions?

If you’re unsure or have any questions, please leave your comment and we’ll get back to you.