Skip Navigation

Resolved

Resolved in: 4.5.7

Topic Tags: Compatibility

Overview of the issue

WordPress 6.0 introduced a change that prevents the correct saving of taxonomy terms for translated posts and pages. Specifically, translated content always has taxonomy terms from the default language stored in the database instead of the translated taxonomy terms.

This issue only happens:

  • If you use WordPress 6.0 with WPML version 4.5.6 or older.
  • For translated pages and posts that have taxonomy terms assigned and were created or edited using WordPress 6.0.

Workaround

To fix this issue for already affected content, do the following:

  1. Update WPML to version 4.5.7 or newer.
    • You should see the update available on the Plugins page in your admin. If you cannot update directly go to PluginsAdd New, click the Commercial tab and then click the Check for updates button.
  1. Use the Advanced Translation Editor, Classic Translation Editor, or the regular WordPress editor to edit the translations of all posts and pages you have edited using WordPress 6.0 prior to updating WPML to 4.5.7+. Please note that you will have to do this for all the secondary languages in your site.

комментариев 17 на “WordPress 6.0 causes taxonomy issues with WPML 4.5.6 and older”

  1. Hi,
    I cannot upload 4.5.7 from my wp dashboard — importer plugin still reports 4.5.6 version.

    Plus, downloaded 4.5.7 from my account, here, and after I uploaded in in my wp — it reports «the link is expired»

    Is there 4.5.7?

    • Hello,
      If you can’t update directly from your Dashboard you can try the following:
      — Go to Plugins -> Add new -> Commercial -> and click on «check for updates».
      Regards

  2. This is another WPML Nightmare — after updating to Version 4.57 and WooCommerce Multilingual & Multi-Currency 5.0 our english Version of WooCommerce vanished completly.
    What are you doing? I told the client to switch to another system as wpml is complicated and timeconsuming which should never be updated. The long history is showing problems after problems and many hours of seeking the conflicts.
    I am not using it anymore for any client….

    • I am sorry to hear about that, I tried looking for a ticket in our support system with that issue but couldn’t find it. I will be happy to help you if you can please report that in the WPML Support forum where we can grab all the details, debug, see what went wrong, and resolve it. Please paste here the ticket’s link once you have it.

    • So far we don’t have any reports and couldn’t reproduce it from the scratch. Could you please report that in the WPML Support forum where we can grab all the details, debug, see what went wrong, and resolve it. Please paste here the ticket’s link once you have it.

    • We are sorry for the inconveniences, however we don’t have any reports like yours. It would be great if you can help us, could you please report that in the WPML Support forum where we can see what went wrong and resolve it?
      Please paste here the ticket’s link once you have it.

  3. I insatelled WP 6 and then sitepress-multilingual-cms.4.5.7 but i doesn’t work and give me a critical error, the theme is Enfold Versione: 4.9.2.3

    Can somebody help me?

  4. Hello

    The issue has not been resolved since 4.5.7. Taxonomy terms don’t seem to get saved correctly. After deactivating WPML, everything works just fine. I’ve also tried to sync the taxonomy terms via support page in WPML. After that it works correctly until I clear the page caches.

    Editing posts that were created before the update and WP 6.0 also doesn’t help. It gets reverted after cache clear (WPEngine).

    Somehow it’s no correct in the database, this needs to get fixed quickly.