Это форум технической поддержки WPML – плагина для многоязычной WordPress.

Доступно для чтения всем, но только клиенты, купившие WPML, могут оставлять сообщения. Сотрудники WPML отвечают на сообщения форума 6 дней в неделю, 22 часов в сутки.

This topic contains 2 ответов, has 2 голосов.

Last updated by Andrey Skripnikov 6 мес., 4 нед. назад.

Assigned support staff: Noman.

Автор Сообщения
Апрель 23, 2019 в 8:28 дп #3660565

Andrey Skripnikov

Hello! I can’t connect the translation for the footer. When connecting for the English version in the Russian version, the footer disappears and is displayed in English.
2. Language switch has a lot of extra space - hidden link
How can i change it?

My website:
hidden link
[ credentials removed ]

Апрель 23, 2019 в 10:16 дп #3661839


Languages: Английский (English )

Timezone: Asia/Karachi (GMT+05:00)


Thank you for contacting WPML Support. Please note that I edited your topic because you had posted sensitive information (WP admin login info) in a public forum.

1. I have logged in to your site and enabled footer translation by selecting ‘tds_footer_page’ checkbox from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> td_011 and hit apply button.

Then added English footer page ID in translation from WPML >> String Translation as you can see in the attached screenshot and now footer appearing correctly in both languages.

2. I have added the following CSS in Custom CSS section of the theme:

.wpml-ls-item ul.sub-menu {
    width: auto !important;

.wpml-ls-item ul a {
    padding: 0 !important;

.wpml-ls-item ul.sub-menu {
    width: auto !important;
    padding: 0 !important;
    background: no-repeat;
    margin-left: 30px;

And it looks as in the attached screenshot.

Thank you

Апрель 23, 2019 в 10:54 дп #3662323

Andrey Skripnikov

My issue is resolved now. Thank you!