Skip Navigation

Waiting for author

Topic Tags: Compatibility

Overview of the issue

When using the Impeka theme integrated with the Impeka WPBakery Extension, translating images via WPML Media Translation plugin does not yield the expected results. Specifically, when an image is added using the Single image widget, it won't displayed the translated image on the front-end-

Workaround

Please, make sure of having a full backup of your site before proceeding.

  • Go to WPML > Settings > Custom XML Configuration.
  • Add the following code:
    <wpml-config>
      <shortcodes>
        <shortcode>
          <tag>impeka_single_image</tag>
          <attributes>
            <attribute>custom_title</attribute>
            <attribute>custom_caption</attribute>
            <attribute encoding="vc_link" type="link">link</attribute>
            <attribute>video_link</attribute>
            <attribute type="media-ids">image</attribute>
            <attribute type="media-ids">retina_image</attribute>
          </attributes>
        </shortcode>
      </shortcodes>
    </wpml-config>
    
  • Add a small modification in your page and refresh its translation.

השאר מענה

Please stay on topic and be respectful to others. If you need help with issues not related to this post, use our Support Forum to start a chat or submit a ticket.

תוכל להשתמש בתגים הבאים:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>