Sauter la navigation

Open

Reported for: WP All Import Multilingual 2.3.0

Topic Tags: Compatibility

Overview of the issue

When using WP-CLI to run an import with WP All Import and the WPML All Import add-on, the following error occurs:

PHP Fatal error: Uncaught Error: Class ‘WPML\AI\WCML’ not found in …/wp-content/plugins/wpml-all-import/wpml-all-import.php:275

Workaround

Please make a full backup of your site before proceeding.

  1. Open the …/wp–content/plugins/wpml–all–import/wpml–all–import.php file.
  2. Look for lines 12-14:
    require_once "includes/rapid-addon.php";
    
    require_once "vendor/autoload.php";
    

    And replace them with:

    require_once __DIR__ . "/includes/rapid-addon.php";
     
    require_once __DIR__ . "/vendor/autoload.php";
    

Laisser une réponse

Please stay on topic and be respectful to others. If you need help with issues not related to this post, use our Support Forum to start a chat or submit a ticket.

Vous pouvez utiliser ces balises :
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>